aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-04-10 07:29:39 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-04-10 07:29:39 +0000
commitb8f41a910d039fbce190805e4a4cd04618ae8dea (patch)
tree7a5b792ca6b196f6d8347de2f8cb1f2eb780cb18 /mail
parent6680f6332c941ec46c851589fdb507058cb11b56 (diff)
downloadports-b8f41a910d039fbce190805e4a4cd04618ae8dea.tar.gz
ports-b8f41a910d039fbce190805e4a4cd04618ae8dea.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/phpmailer/Makefile52
-rw-r--r--mail/phpmailer/distinfo3
-rw-r--r--mail/phpmailer/files/pkg-message4
-rw-r--r--mail/phpmailer/pkg-descr6
-rw-r--r--mail/phpmailer/pkg-plist50
6 files changed, 116 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 2f8def61b24c..fae10d50f619 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -418,6 +418,7 @@
SUBDIR += pgpsendmail
SUBDIR += php4-imap
SUBDIR += php5-imap
+ SUBDIR += phpmailer
SUBDIR += pine-pgp-filters
SUBDIR += pine4
SUBDIR += pm-lib
diff --git a/mail/phpmailer/Makefile b/mail/phpmailer/Makefile
new file mode 100644
index 000000000000..20d985069485
--- /dev/null
+++ b/mail/phpmailer/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: phpmailer
+# Date created: 6 April 2007
+# Whom: Zhen REN <bg1tpt@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpmailer
+PORTVERSION= 1.73
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${DISTVERSION}
+
+MAINTAINER= bg1tpt@gmail.com
+COMMENT= Full Featured Email Transfer Class for PHP
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_DOS2UNIX= yes
+NO_BUILD= yes
+USE_PHP= pcre
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+MSG_SRC= ${FILESDIR}/pkg-message
+
+MSG_SUB= DATADIR=${DATADIR} LOCALBASE=${LOCALBASE}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+.for f in class.phpmailer.php class.smtp.php
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DATADIR}
+.endfor
+ @${MKDIR} ${DATADIR}/language
+ @${INSTALL_DATA} ${WRKSRC}/language/* ${DATADIR}/language
+ @${MKDIR} ${DATADIR}/test
+ @${INSTALL_DATA} ${WRKSRC}/test/* ${DATADIR}/test
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in README LICENSE
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+ @${CP} -R ${WRKSRC}/docs/* ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/phpdoc/* ${DOCSDIR}
+.endif
+
+post-install:
+ @${SED} ${MSG_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${MSG_SRC} > \
+ ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/phpmailer/distinfo b/mail/phpmailer/distinfo
new file mode 100644
index 000000000000..02b3d2fb9838
--- /dev/null
+++ b/mail/phpmailer/distinfo
@@ -0,0 +1,3 @@
+MD5 (phpmailer-1.73.tar.gz) = 3a6ce5ff38090d6ca4881e31da00f623
+SHA256 (phpmailer-1.73.tar.gz) = b33f2911b2ae704d5bc0bf2f1a945e052909c63e3966cf1cf5798d667fe37c71
+SIZE (phpmailer-1.73.tar.gz) = 68644
diff --git a/mail/phpmailer/files/pkg-message b/mail/phpmailer/files/pkg-message
new file mode 100644
index 000000000000..b9d8ebd9a029
--- /dev/null
+++ b/mail/phpmailer/files/pkg-message
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/mail/phpmailer/pkg-descr b/mail/phpmailer/pkg-descr
new file mode 100644
index 000000000000..f2ba05fe5eb0
--- /dev/null
+++ b/mail/phpmailer/pkg-descr
@@ -0,0 +1,6 @@
+PHP email transport class featuring multiple file attachments, SMTP
+servers, CCs, BCCs, HTML messages, and word wrap, and more. It can
+send email via sendmail, PHP mail(), or with SMTP. Methods are based
+on the popular AspEmail active server component.
+
+WWW: http://sourceforge.net/projects/phpmailer
diff --git a/mail/phpmailer/pkg-plist b/mail/phpmailer/pkg-plist
new file mode 100644
index 000000000000..4170158e3c21
--- /dev/null
+++ b/mail/phpmailer/pkg-plist
@@ -0,0 +1,50 @@
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/SMTP.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/_class_phpmailer_php.html
+%%PORTDOCS%%%%DOCSDIR%%/PHPMailer/_class_smtp_php.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/blank.html
+%%PORTDOCS%%%%DOCSDIR%%/classtrees_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/elementindex.html
+%%PORTDOCS%%%%DOCSDIR%%/elementindex_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/errors.html
+%%PORTDOCS%%%%DOCSDIR%%/extending.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/li_PHPMailer.html
+%%PORTDOCS%%%%DOCSDIR%%/media/banner.css
+%%PORTDOCS%%%%DOCSDIR%%/media/stylesheet.css
+%%PORTDOCS%%%%DOCSDIR%%/packages.html
+%%PORTDOCS%%%%DOCSDIR%%/timeoutfix.diff
+%%DATADIR%%/class.phpmailer.php
+%%DATADIR%%/class.smtp.php
+%%DATADIR%%/language/phpmailer.lang-br.php
+%%DATADIR%%/language/phpmailer.lang-ca.php
+%%DATADIR%%/language/phpmailer.lang-cz.php
+%%DATADIR%%/language/phpmailer.lang-de.php
+%%DATADIR%%/language/phpmailer.lang-dk.php
+%%DATADIR%%/language/phpmailer.lang-en.php
+%%DATADIR%%/language/phpmailer.lang-es.php
+%%DATADIR%%/language/phpmailer.lang-fi.php
+%%DATADIR%%/language/phpmailer.lang-fo.php
+%%DATADIR%%/language/phpmailer.lang-fr.php
+%%DATADIR%%/language/phpmailer.lang-hu.php
+%%DATADIR%%/language/phpmailer.lang-it.php
+%%DATADIR%%/language/phpmailer.lang-ja.php
+%%DATADIR%%/language/phpmailer.lang-nl.php
+%%DATADIR%%/language/phpmailer.lang-no.php
+%%DATADIR%%/language/phpmailer.lang-pl.php
+%%DATADIR%%/language/phpmailer.lang-ro.php
+%%DATADIR%%/language/phpmailer.lang-ru.php
+%%DATADIR%%/language/phpmailer.lang-se.php
+%%DATADIR%%/language/phpmailer.lang-tr.php
+%%DATADIR%%/test/phpmailer_test.php
+%%DATADIR%%/test/phpunit.php
+%%DATADIR%%/test/test.png
+@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%/language
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/media
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/PHPMailer
+%%PORTDOCS%%@dirrm %%DOCSDIR%%