aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-22 16:27:08 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-22 16:27:08 +0000
commitc10f314307a4e84ca4811cb03db549590b4c364a (patch)
treeaefb02047d08a1e3c25a562330070cfdd71f0579 /mail
parentbeaeca88a88b0f7e641416a47008edd52290575c (diff)
downloadports-c10f314307a4e84ca4811cb03db549590b4c364a.tar.gz
ports-c10f314307a4e84ca4811cb03db549590b4c364a.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/fetchyahoo/Makefile8
-rw-r--r--mail/openwebmail/Makefile6
-rw-r--r--mail/p5-Email-MIME/Makefile17
-rw-r--r--mail/p5-IMAP-Client/Makefile8
-rw-r--r--mail/p5-MIME-EncWords/Makefile8
-rw-r--r--mail/p5-MIME-Lite/Makefile8
-rw-r--r--mail/p5-MIME-Tools/Makefile8
-rw-r--r--mail/p5-Mail-DKIM/Makefile8
-rw-r--r--mail/p5-Mail-DomainKeys/Makefile8
-rw-r--r--mail/p5-Mail-IMAPClient/Makefile11
-rw-r--r--mail/p5-Mail-Sender/Makefile9
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile5
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile9
-rw-r--r--mail/p5-Net-SMTP-TLS/Makefile8
-rw-r--r--mail/p5-Net-SMTP_auth/Makefile9
-rw-r--r--mail/razor-agents/Makefile8
16 files changed, 17 insertions, 121 deletions
diff --git a/mail/fetchyahoo/Makefile b/mail/fetchyahoo/Makefile
index 4a007e9a6865..916de293a96f 100644
--- a/mail/fetchyahoo/Makefile
+++ b/mail/fetchyahoo/Makefile
@@ -31,12 +31,6 @@ PORTDOCS= COPYING ChangeLog Credits INSTALL TODO index.html
NO_BUILD= yes
USE_PERL5= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
-.endif
-
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/fetchyahoo ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
@@ -49,4 +43,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/openwebmail/Makefile b/mail/openwebmail/Makefile
index c06c377a13ef..4577256b54f3 100644
--- a/mail/openwebmail/Makefile
+++ b/mail/openwebmail/Makefile
@@ -62,12 +62,6 @@ WITH_SPEEDYCGI= yes
.endif # exists(${PERL})
.endif # perl5.8
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-.endif
-
.if defined(WITH_LEARNSPAM) || defined(WITH_SPAMCHECK_ALL)
WITH_SPAMCHECK= true
.endif
diff --git a/mail/p5-Email-MIME/Makefile b/mail/p5-Email-MIME/Makefile
index d4c30879edf1..e5f8dbef915c 100644
--- a/mail/p5-Email-MIME/Makefile
+++ b/mail/p5-Email-MIME/Makefile
@@ -14,23 +14,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Easy MIME message parsing
-RUN_DEPENDS= p5-Email-Simple>=2.00.4:${PORTSDIR}/mail/p5-Email-Simple \
+BUILD_DEPENDS= p5-Email-Simple>=2.00.4:${PORTSDIR}/mail/p5-Email-Simple \
p5-Email-MIME-Encodings>=1.3:${PORTSDIR}/mail/p5-Email-MIME-Encodings \
p5-Email-MIME-ContentType>=1.01.1:${PORTSDIR}/mail/p5-Email-MIME-ContentType \
- p5-MIME-Types>=1.13:${PORTSDIR}/mail/p5-MIME-Types
-BUILD_DEPENDS= ${RUN_DEPENDS}
+ p5-MIME-Types>=1.13:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-Encode>=1.98.1:${PORTSDIR}/converters/p5-Encode
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Email::MIME.3 \
Email::MIME::Header.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-MIME-Tools>=5.404:${PORTSDIR}/mail/p5-MIME-Tools
-.else
-RUN_DEPENDS+= p5-Encode>=1.98.1:${PORTSDIR}/converters/p5-Encode
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-IMAP-Client/Makefile b/mail/p5-IMAP-Client/Makefile
index a2bd353efdd4..16e40ccb8def 100644
--- a/mail/p5-IMAP-Client/Makefile
+++ b/mail/p5-IMAP-Client/Makefile
@@ -22,10 +22,4 @@ PERL_CONFIGURE= yes
MAN3= IMAP::Client.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-MIME-EncWords/Makefile b/mail/p5-MIME-EncWords/Makefile
index 916b65a1249d..c16d907547ad 100644
--- a/mail/p5-MIME-EncWords/Makefile
+++ b/mail/p5-MIME-EncWords/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= MIME::EncWords.3 MIME::EncWords::JA_JP.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500801
-RUN_DEPENDS+= p5-MIME-Base64>=2.13:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-MIME-Lite/Makefile b/mail/p5-MIME-Lite/Makefile
index 83e335a5799f..d74ed3ee8496 100644
--- a/mail/p5-MIME-Lite/Makefile
+++ b/mail/p5-MIME-Lite/Makefile
@@ -24,13 +24,7 @@ PERL_CONFIGURE= YES
MAN3= MIME::Lite.3 MIME::changes.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
post-extract:
@${PERL} -i -ne 'print unless m,^#-, .. m,;$$, or m,^if, .. m,^},' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-MIME-Tools/Makefile b/mail/p5-MIME-Tools/Makefile
index 4871d8d40ec3..b1f71d5cebab 100644
--- a/mail/p5-MIME-Tools/Makefile
+++ b/mail/p5-MIME-Tools/Makefile
@@ -58,14 +58,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500801
-RUN_DEPENDS+= p5-MIME-Base64>=2.2:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.if ${PERL_LEVEL} < 500703
-BUILD_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
.if ${PERL_LEVEL} < 500905
RUN_DEPENDS+= p5-File-Temp>=0.18:${PORTSDIR}/devel/p5-File-Temp
.endif
diff --git a/mail/p5-Mail-DKIM/Makefile b/mail/p5-Mail-DKIM/Makefile
index d90a15f7bd98..ada60e7693c2 100644
--- a/mail/p5-Mail-DKIM/Makefile
+++ b/mail/p5-Mail-DKIM/Makefile
@@ -44,10 +44,4 @@ MAN3= Mail::DKIM.3 \
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/dkim*.pl ${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-DomainKeys/Makefile b/mail/p5-Mail-DomainKeys/Makefile
index c0affec5af6a..18c681e83a9d 100644
--- a/mail/p5-Mail-DomainKeys/Makefile
+++ b/mail/p5-Mail-DomainKeys/Makefile
@@ -23,13 +23,7 @@ PERL_CONFIGURE= yes
MAN3= Mail::DomainKeys.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
post-patch:
@${PERL} -pi -e '$$_="" if $$.>=6 && $$.<=38' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-IMAPClient/Makefile b/mail/p5-Mail-IMAPClient/Makefile
index 991304c29ce6..c759d8c92956 100644
--- a/mail/p5-Mail-IMAPClient/Makefile
+++ b/mail/p5-Mail-IMAPClient/Makefile
@@ -26,13 +26,4 @@ MAN3= Mail::IMAPClient.3 \
Mail::IMAPClient::MessageSet.3 \
Mail::IMAPClient::Thread.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-IO>=1.26:${PORTSDIR}/devel/p5-IO \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
- p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Sender/Makefile b/mail/p5-Mail-Sender/Makefile
index b7d92e7b1642..40dced262ed4 100644
--- a/mail/p5-Mail-Sender/Makefile
+++ b/mail/p5-Mail-Sender/Makefile
@@ -18,16 +18,9 @@ PERL_CONFIGURE= yes
MAN3= Mail::Sender.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.endif
-
post-patch:
.if defined(BATCH)
@${PERL} -pi -e 's/res = <STDIN>;/res = "N";/' ${WRKSRC}/Config.PL
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 5812f2861e4f..b587d900fe4d 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -273,9 +273,4 @@ post-install:
.endif
@${SED} -e 's#PREFIX#${PREFIX}#' ${PKGMESSAGE}
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-.endif
-
.include <bsd.port.post.mk>
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
index 61cb9191cd1b..506358605bc8 100644
--- a/mail/p5-Net-SMTP-Server/Makefile
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -26,11 +26,4 @@ MAN3= Net::SMTP::Server.3 \
Net::SMTP::Server::Client.3 \
Net::SMTP::Server::Relay.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Net-SMTP-TLS/Makefile b/mail/p5-Net-SMTP-TLS/Makefile
index 7807df8a5ec1..9c30f5ed1712 100644
--- a/mail/p5-Net-SMTP-TLS/Makefile
+++ b/mail/p5-Net-SMTP-TLS/Makefile
@@ -23,10 +23,4 @@ PERL_CONFIGURE= yes
MAN3= Net::SMTP::TLS.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Net-SMTP_auth/Makefile b/mail/p5-Net-SMTP_auth/Makefile
index 22f82ff44919..c3efc9faed75 100644
--- a/mail/p5-Net-SMTP_auth/Makefile
+++ b/mail/p5-Net-SMTP_auth/Makefile
@@ -22,11 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Net::SMTP_auth.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS+= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/razor-agents/Makefile b/mail/razor-agents/Makefile
index 61c0594198c4..3924c33b1048 100644
--- a/mail/razor-agents/Makefile
+++ b/mail/razor-agents/Makefile
@@ -34,10 +34,4 @@ post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${PERL} -pi -e 's|/etc/razor|${PREFIX}/etc|g'
@${PERL} -pi -e 's,share/man,man,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>