aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-01-13 03:57:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-01-13 03:57:25 +0000
commitd7f59ea8de230bb289b02649cd575560e4c71e0d (patch)
treeeae797f7211f5c20b5be446f4fa649681b374597 /mail
parent3aa9b484131b5835a7875ba57cac901593286b35 (diff)
downloadports-d7f59ea8de230bb289b02649cd575560e4c71e0d.tar.gz
ports-d7f59ea8de230bb289b02649cd575560e4c71e0d.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/addresses-goodies/Makefile3
-rw-r--r--mail/addresses/Makefile14
-rw-r--r--mail/gnumail/Makefile8
-rw-r--r--mail/pantomime/Makefile9
4 files changed, 13 insertions, 21 deletions
diff --git a/mail/addresses-goodies/Makefile b/mail/addresses-goodies/Makefile
index c2f6d957ea64..fef752c2ae58 100644
--- a/mail/addresses-goodies/Makefile
+++ b/mail/addresses-goodies/Makefile
@@ -24,7 +24,7 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_SYSTEM_LIBS+= Inspector:${GWORKSPACE_PORT}
USE_GNUSTEP_LOCAL_LIBS+= Addresses:${ADDRESSES_PORT}
-USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
WRKSRC= ${WRKDIR}/Addresses-${PORTVERSION}/Goodies
@@ -36,7 +36,6 @@ post-patch:
-e 's|VCFViewer||' \
${WRKSRC}/GNUmakefile
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
- -e 's|GNUSTEP_INSTALLATION_DIR|GNUSTEP_SYSTEM_ROOT|' \
-e 's|Library/GWorkspace|Library/Bundles|' \
-e 's|-lGWorkspace|-lInspector|' \
${WRKSRC}/VCFViewer/GNUmakefile
diff --git a/mail/addresses/Makefile b/mail/addresses/Makefile
index e81bd72d61fe..01c6806f5e00 100644
--- a/mail/addresses/Makefile
+++ b/mail/addresses/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: Addresses
+# New ports collection makefile for: addresses
# Date created: 13 Nov 2004
# Whom: Miguel Mendez <flynn@energyhq.es.eu.org>
#
@@ -15,17 +15,13 @@ DISTNAME= Addresses-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A versatile addressbook for GNUstep
-GNUSTEP_PREFIX?= ${LOCALBASE}/GNUstep
-PREFIX= ${GNUSTEP_PREFIX}
-NO_MTREE= yes
-WRKSRC= ${WRKDIR}/Addresses-${PORTVERSION}
-USE_GMAKE= yes
USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
-LDCONFIG_DIRS= ${LOCALLIBDIR}
-INSTALLS_SHLIB= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
+WRKSRC= ${WRKDIR}/Addresses-${PORTVERSION}
.include <bsd.port.mk>
diff --git a/mail/gnumail/Makefile b/mail/gnumail/Makefile
index dcb0a3793b1b..f7dc3e5b565c 100644
--- a/mail/gnumail/Makefile
+++ b/mail/gnumail/Makefile
@@ -14,8 +14,6 @@ DISTNAME= GNUMail-${PORTVERSION}pre2
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep mail client
-WRKSRC= ${WRKDIR}/GNUMail
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
@@ -23,8 +21,10 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_LOCAL_LIBS+= Pantomime:${PANTOMIME_PORT}
USE_GNUSTEP_LOCAL_LIBS+= Addresses:${ADDRESSES_PORT}
-MAKEFILE=
-ALL_TARGET=
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
+WRKSRC= ${WRKDIR}/GNUMail
+
PANTOMIME_PORT?= mail/pantomime
ADDRESSES_PORT?= mail/addresses
diff --git a/mail/pantomime/Makefile b/mail/pantomime/Makefile
index 83cba32b1aaf..9c87763a91b9 100644
--- a/mail/pantomime/Makefile
+++ b/mail/pantomime/Makefile
@@ -14,16 +14,13 @@ DISTNAME= Pantomime-${PORTVERSION}pre2
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Mail/MIME handling library for GNUstep
-WRKSRC= ${WRKDIR}/Pantomime
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
-LDCONFIG_DIRS= ${LOCALLIBDIR}
-NO_FILTER_SHLIBS= yes
-INSTALLS_SHLIB= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
+WRKSRC= ${WRKDIR}/Pantomime
.include <bsd.port.mk>