aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2011-08-21 22:49:21 +0000
committerAnders Nordby <anders@FreeBSD.org>2011-08-21 22:49:21 +0000
commiteff47be7db9cac185dff7d2000066eaa46a44980 (patch)
tree19b97596bf2ceaa40c0737907f6435b0e31c4fd2 /mail
parent45eddd17c9165cbf63fb8bf49aaaea2594bdafc0 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/cclient/Makefile7
-rw-r--r--mail/cclient/distinfo4
-rw-r--r--mail/imap-uw/Makefile10
-rw-r--r--mail/imap-uw/distinfo4
-rw-r--r--mail/imap-uw/files/pkg-message.in2
5 files changed, 21 insertions, 6 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index ddfd28ec21d5..b71c5909d9f1 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cclient
-PORTVERSION= 2007e
+PORTVERSION= 2007f
PORTEPOCH= 1
CATEGORIES= mail devel ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
@@ -19,6 +19,9 @@ DISTNAME= imap-${PORTVERSION}
MAINTAINER= anders@FreeBSD.org
COMMENT= Mark Crispin's C-client mail access routines
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
OPTIONS= SSL "Compile with SSL support" on \
SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
IPV6 "Support IPv6" on \
@@ -60,6 +63,8 @@ post-patch:
.endfor
@${REINPLACE_CMD} -e "s:/etc/ssl/certs:${PREFIX}/certs:g; \
s:/etc/ssl/private:${PREFIX}/certs:g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s:/etc/c-client.cf:${PREFIX}/etc/c-client.cf:" \
+ ${WRKSRC}/src/osdep/unix/env_unix.h
.if ! defined(WITHOUT_SSL)
@${REINPLACE_CMD} -e " \
s:SSLINCLUDE=/usr/include/openssl SSLLIB=/usr/lib:SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}: \
diff --git a/mail/cclient/distinfo b/mail/cclient/distinfo
index c8d41b9da4d7..2970605d3063 100644
--- a/mail/cclient/distinfo
+++ b/mail/cclient/distinfo
@@ -1,2 +1,2 @@
-SHA256 (imap-2007e.tar.gz) = 4b1137b87249782496ec3eeacaf83bbf09312a7d2ae3aead262179041b55565f
-SIZE (imap-2007e.tar.gz) = 1991389
+SHA256 (imap-2007f.tar.gz) = 53e15a2b5c1bc80161d42e9f69792a3fa18332b7b771910131004eb520004a28
+SIZE (imap-2007f.tar.gz) = 1990304
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index f36a90ed0f43..d4da403ad72d 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= imap
-PORTVERSION= 2007e
+PORTVERSION= 2007f
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
@@ -19,6 +19,9 @@ PKGNAMESUFFIX= -uw
MAINTAINER= anders@FreeBSD.org
COMMENT= University of Washington IMAP4rev1/POP2/POP3 mail servers
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
LIB_DEPENDS= c-client4.9:${PORTSDIR}/mail/cclient
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
@@ -62,6 +65,11 @@ MAKE_ARGS+= WITH_NETSCAPE_BRAIN_DAMAGE=yes
# See src/imapd/Makefile for more information about these three options.
.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e "s:/etc/c-client.cf:${PREFIX}/etc/c-client.cf:" \
+ ${WRKSRC}/docs/imaprc.txt
+ @${RM} ${WRKSRC}/docs/imaprc.txt.bak
+
pre-build:
@${SH} ${PKGREQ}.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
.if !defined(WITHOUT_SSL)
diff --git a/mail/imap-uw/distinfo b/mail/imap-uw/distinfo
index c8d41b9da4d7..2970605d3063 100644
--- a/mail/imap-uw/distinfo
+++ b/mail/imap-uw/distinfo
@@ -1,2 +1,2 @@
-SHA256 (imap-2007e.tar.gz) = 4b1137b87249782496ec3eeacaf83bbf09312a7d2ae3aead262179041b55565f
-SIZE (imap-2007e.tar.gz) = 1991389
+SHA256 (imap-2007f.tar.gz) = 53e15a2b5c1bc80161d42e9f69792a3fa18332b7b771910131004eb520004a28
+SIZE (imap-2007f.tar.gz) = 1990304
diff --git a/mail/imap-uw/files/pkg-message.in b/mail/imap-uw/files/pkg-message.in
index ca41cd71f947..ca631b568bb3 100644
--- a/mail/imap-uw/files/pkg-message.in
+++ b/mail/imap-uw/files/pkg-message.in
@@ -19,6 +19,8 @@ pop3 session required pam_unix.so
The pam_unix module does not have session support, so we do not use it for
session management. Be sure to read up on pam.conf(5).
+To configure imap-uw read %%DOCSDIR%%/imaprc.txt.
+
===> NB: IMAP-UW now rejects non-encrypted logins by default. To change this
===> behaviour, recompile and reinstall cclient and imap-uw ports with one of
===> the following make variables defined: