aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-08 18:45:38 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-08 18:45:38 +0000
commit2cf4c1e2c8f35d7e8d8df1acc5a582d916a7d608 (patch)
treefffa16c225e5c8c0a72ed5f5d5c9a88be4d7839c /mail
parent346415e3c06029d36c899250a77aa33df43cf6fc (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Email-MIME/Makefile3
-rw-r--r--mail/p5-FuzzyOcr/Makefile8
-rw-r--r--mail/p5-Mail-CClient/Makefile3
-rw-r--r--mail/p5-Mail-DKIM/Makefile9
-rw-r--r--mail/p5-Mail-Graph/Makefile10
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile18
-rw-r--r--mail/p5-Net-POP3-SSLWrapper/Makefile9
-rw-r--r--mail/p5-SES/Makefile8
8 files changed, 7 insertions, 61 deletions
diff --git a/mail/p5-Email-MIME/Makefile b/mail/p5-Email-MIME/Makefile
index ce01cbf23b9c..4ef98b788979 100644
--- a/mail/p5-Email-MIME/Makefile
+++ b/mail/p5-Email-MIME/Makefile
@@ -28,7 +28,4 @@ MAN3= Email::MIME.3 \
Email::MIME::Header.3 \
Email::MIME::Modifier.3
-regression-test: build
- cd ${WRKSRC}/ && ${MAKE} test
-
.include <bsd.port.mk>
diff --git a/mail/p5-FuzzyOcr/Makefile b/mail/p5-FuzzyOcr/Makefile
index a2a61fd4c391..7026a17b9ffa 100644
--- a/mail/p5-FuzzyOcr/Makefile
+++ b/mail/p5-FuzzyOcr/Makefile
@@ -50,12 +50,6 @@ PLIST_FILES= ${SA_CONFIGDIR}/FuzzyOcr.pm \
%%EXAMPLESDIR%%/FuzzyOcr.cf %%EXAMPLESDIR%%/FuzzyOcr.words
PLIST_DIRS= %%EXAMPLESDIR%%
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin,${LOCALBASE}/bin,g' \
-e 's,/bin/grep,/usr/bin/grep,g' \
@@ -82,4 +76,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-CClient/Makefile b/mail/p5-Mail-CClient/Makefile
index 840007c87a2c..bb446f063ba3 100644
--- a/mail/p5-Mail-CClient/Makefile
+++ b/mail/p5-Mail-CClient/Makefile
@@ -5,14 +5,13 @@
# $FreeBSD$
#
-PORTNAME= CClient
+PORTNAME= Mail-CClient
PORTVERSION= 1.12
PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:HDIAS
PKGNAMEPREFIX= p5-
-DISTNAME= Mail-Cclient-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to the c-client mailbox API
diff --git a/mail/p5-Mail-DKIM/Makefile b/mail/p5-Mail-DKIM/Makefile
index b9906ec7c3cc..92943e80f7e6 100644
--- a/mail/p5-Mail-DKIM/Makefile
+++ b/mail/p5-Mail-DKIM/Makefile
@@ -43,11 +43,4 @@ MAN3= Mail::DKIM.3 \
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/dkim*.pl ${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Graph/Makefile b/mail/p5-Mail-Graph/Makefile
index f2de44cc19bd..7754fc86b5ec 100644
--- a/mail/p5-Mail-Graph/Makefile
+++ b/mail/p5-Mail-Graph/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
EXAMPLESCRIPT= samples/*pl
@@ -40,10 +40,4 @@ post-install:
${INSTALL_SCRIPT} ${EXAMPLEOUTPUT} ${EXAMPLESDIR}/output && \
${INSTALL_SCRIPT} ${EXAMPLEARCHIVE} ${EXAMPLESDIR}/archive
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index f52a819f2c3a..bc2d48ab00bf 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -65,16 +65,6 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Archive-Tar>=1.23:${PORTSDIR}/archivers/p5-Archive-Tar \
- p5-IO-Zlib>=1.04:${PORTSDIR}/archivers/p5-IO-Zlib \
- p5-Test-Harness>=3.16:${PORTSDIR}/devel/p5-Test-Harness
-.endif
-
.if defined (WITH_SPAMC)
CONFIGURE_ARGS+= BUILD_SPAMC=yes
.else
@@ -114,15 +104,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DB
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-.if defined(WITH_RAZOR)
RUN_DEPENDS+= razor-agents>=2.84:${PORTSDIR}/mail/razor-agents
-.else
-.if ${PERL_LEVEL} < 501000
-.if !defined(WITH_DKIM)
-RUN_DEPENDS+= p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1
-.endif
-.endif
-.endif
.if defined(WITH_DKIM)
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
diff --git a/mail/p5-Net-POP3-SSLWrapper/Makefile b/mail/p5-Net-POP3-SSLWrapper/Makefile
index d9a7df191faa..f8e2cc8725b2 100644
--- a/mail/p5-Net-POP3-SSLWrapper/Makefile
+++ b/mail/p5-Net-POP3-SSLWrapper/Makefile
@@ -21,11 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Net::POP3::SSLWrapper.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/p5-SES/Makefile b/mail/p5-SES/Makefile
index efbfc12eb505..4dd0fb742f99 100644
--- a/mail/p5-SES/Makefile
+++ b/mail/p5-SES/Makefile
@@ -43,10 +43,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/SES.pm ${PREFIX}/${SITE_PERL_REL}/
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>