aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-28 09:16:25 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-28 09:16:25 +0000
commit11d33d1b4a55f26c6c437dbcbc425b3850122da9 (patch)
treed0212421e4360c42b340781a50728868f4bfa414 /mail
parent6c8d9b79b0d82421429d52afd05a94c015d17c67 (diff)
downloadports-11d33d1b4a55f26c6c437dbcbc425b3850122da9.tar.gz
ports-11d33d1b4a55f26c6c437dbcbc425b3850122da9.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug132062139
2 files changed, 40 insertions, 1 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 2c2617af0126..a563ac05568c 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 45.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1320621 b/mail/thunderbird/files/patch-bug1320621
new file mode 100644
index 000000000000..170d2eba8baf
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1320621
@@ -0,0 +1,39 @@
+Make sure --enable-system-hunspell picks up system headers
+
+--- mozilla/extensions/spellcheck/hunspell/glue/moz.build
++++ mozilla/extensions/spellcheck/hunspell/glue/moz.build
+@@ -11,12 +11,14 @@ UNIFIED_SOURCES += [
+ 'RemoteSpellCheckEngineParent.cpp',
+ ]
+
+-CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
+-
+ FINAL_LIBRARY = 'xul'
+
++if CONFIG['MOZ_NATIVE_HUNSPELL']:
++ CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
++else:
++ LOCAL_INCLUDES += ['../src']
++
+ LOCAL_INCLUDES += [
+- '../src',
+ '/dom/base',
+ '/extensions/spellcheck/src',
+ ]
+--- mozilla/extensions/spellcheck/src/moz.build
++++ mozilla/extensions/spellcheck/src/moz.build
+@@ -17,9 +17,13 @@ UNIFIED_SOURCES += [
+
+ FINAL_LIBRARY = 'xul'
+
++if CONFIG['MOZ_NATIVE_HUNSPELL']:
++ CXXFLAGS += CONFIG['MOZ_HUNSPELL_CFLAGS']
++else:
++ LOCAL_INCLUDES += ['../hunspell/src']
++
+ LOCAL_INCLUDES += [
+ '../hunspell/glue',
+- '../hunspell/src',
+ '/dom/base',
+ ]
+ EXPORTS.mozilla += [