aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-14 14:57:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-14 14:57:22 +0000
commiteb61dd9d0a37f5e13469d33aeb0a48172a7865bf (patch)
treea9cc24676cff9a6db0085ffd872be378dac93963 /mail
parent0f2129efb01ba325036b016f4cb16fdb88669b49 (diff)
downloadports-eb61dd9d0a37f5e13469d33aeb0a48172a7865bf.tar.gz
ports-eb61dd9d0a37f5e13469d33aeb0a48172a7865bf.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/dspam-devel/Makefile19
-rw-r--r--mail/dspam-devel/pkg-message2
-rw-r--r--mail/dspam/Makefile19
-rw-r--r--mail/dspam/pkg-message2
4 files changed, 34 insertions, 8 deletions
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index d3ca7a884136..527d2ba98d13 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -17,6 +17,7 @@ OPTIONS= MYSQL "Use MySQL and not db4 as database" off \
MYSQL_COMPRESS "Compress dspam <--> MySQL" off \
MAILDROP "Use Maildrop as local delivery agent" off \
PROCMAIL "Use Procmail as local delivery agent" off \
+ SENDMAIL_LDA "Use Sendmail as local delivery agent" off \
SENDMAIL "Play nice with sendmail server" off \
QMAIL "Play nice with Qmail mail server" off \
ENABLE_SPAM_DELIVERY "Deliver messages marked as spam" off \
@@ -82,6 +83,14 @@ RUN_DEPENDS+= procmail:${PORTSDIR}/mail/procmail
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/bin/procmail $u'
.endif
+.if defined(WITH_SENDMAIL_LDA) && exists(/usr/sbin/sendmail)
+CONFIGURE_ARGS+= --with-local-delivery-agent=/usr/sbin/sendmail
+.else
+.if defined(WITH_SENDMAIL_LDA) && exists(${LOCALBASE}/sbin/sendmail)
+CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/sbin/sendmail'
+.endif
+.endif
+
.if defined(WITH_SENDMAIL)
CONFIGURE_ARGS+= --with-dspam-mode=4511
.endif
@@ -145,11 +154,15 @@ post-patch:
s|-ldb-4.1|-ldb41|g' ${WRKSRC}/configure
pre-configure:
-.if defined(WITH_MAILDROP) && defined(WITH_PROCMAIL)
+.if defined(WITH_MAILDROP) && (defined(WITH_PROCMAIL) || defined(WITH_SENDMAIL_LDA))
+ @${ECHO_CMD} "You can only use one local delivery agent at once."
+ @${FALSE}
+.endif
+.if defined(WITH_PROCMAIL) && (defined(WITH_MAILDROP) || defined(WITH_SENDMAIL_LDA))
@${ECHO_CMD} "You can only use one local delivery agent at once."
@${FALSE}
.endif
-.if defined(WITH_VIRT_USERS) && !defined(WITH_MYSQL)
+.if !defined(WITH_MYSQL) && (defined(WITH_MYSQL_COMPRESS) || defined(WITH_VIRT_USERS))
@${ECHO_CMD} "You need MySQL support to use this feature."
@${FALSE}
.endif
@@ -158,7 +171,7 @@ post-install:
.if defined(WITH_MYSQL)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/tools.mysql_drv && \
- ${INSTALL_DATA} README *.sql.* ${EXAMPLESDIR}
+ ${INSTALL_DATA} README *.sql* ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/mysql.data ${EXAMPLESDIR}
.endif
.if !defined(NOPORTDOCS)
diff --git a/mail/dspam-devel/pkg-message b/mail/dspam-devel/pkg-message
index de633fe89ee8..e46eb3a3d43b 100644
--- a/mail/dspam-devel/pkg-message
+++ b/mail/dspam-devel/pkg-message
@@ -4,7 +4,7 @@
how to configure DSPAM with your MTA. Examples are provided for
sendmail, exim and other popular MTAs.
%%MYSQL%%
-%%MYSQL%% See %%DOCSDIR%%/mysql/README
+%%MYSQL%% See %%EXAMPLESDIR%%/README
%%MYSQL%% for instructions on how to configure MySQL
%%MYSQL%% for use with DSPAM.
%%MYSQL%%
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index d3ca7a884136..527d2ba98d13 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -17,6 +17,7 @@ OPTIONS= MYSQL "Use MySQL and not db4 as database" off \
MYSQL_COMPRESS "Compress dspam <--> MySQL" off \
MAILDROP "Use Maildrop as local delivery agent" off \
PROCMAIL "Use Procmail as local delivery agent" off \
+ SENDMAIL_LDA "Use Sendmail as local delivery agent" off \
SENDMAIL "Play nice with sendmail server" off \
QMAIL "Play nice with Qmail mail server" off \
ENABLE_SPAM_DELIVERY "Deliver messages marked as spam" off \
@@ -82,6 +83,14 @@ RUN_DEPENDS+= procmail:${PORTSDIR}/mail/procmail
CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/bin/procmail $u'
.endif
+.if defined(WITH_SENDMAIL_LDA) && exists(/usr/sbin/sendmail)
+CONFIGURE_ARGS+= --with-local-delivery-agent=/usr/sbin/sendmail
+.else
+.if defined(WITH_SENDMAIL_LDA) && exists(${LOCALBASE}/sbin/sendmail)
+CONFIGURE_ARGS+= --with-local-delivery-agent='${LOCALBASE}/sbin/sendmail'
+.endif
+.endif
+
.if defined(WITH_SENDMAIL)
CONFIGURE_ARGS+= --with-dspam-mode=4511
.endif
@@ -145,11 +154,15 @@ post-patch:
s|-ldb-4.1|-ldb41|g' ${WRKSRC}/configure
pre-configure:
-.if defined(WITH_MAILDROP) && defined(WITH_PROCMAIL)
+.if defined(WITH_MAILDROP) && (defined(WITH_PROCMAIL) || defined(WITH_SENDMAIL_LDA))
+ @${ECHO_CMD} "You can only use one local delivery agent at once."
+ @${FALSE}
+.endif
+.if defined(WITH_PROCMAIL) && (defined(WITH_MAILDROP) || defined(WITH_SENDMAIL_LDA))
@${ECHO_CMD} "You can only use one local delivery agent at once."
@${FALSE}
.endif
-.if defined(WITH_VIRT_USERS) && !defined(WITH_MYSQL)
+.if !defined(WITH_MYSQL) && (defined(WITH_MYSQL_COMPRESS) || defined(WITH_VIRT_USERS))
@${ECHO_CMD} "You need MySQL support to use this feature."
@${FALSE}
.endif
@@ -158,7 +171,7 @@ post-install:
.if defined(WITH_MYSQL)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/tools.mysql_drv && \
- ${INSTALL_DATA} README *.sql.* ${EXAMPLESDIR}
+ ${INSTALL_DATA} README *.sql* ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/mysql.data ${EXAMPLESDIR}
.endif
.if !defined(NOPORTDOCS)
diff --git a/mail/dspam/pkg-message b/mail/dspam/pkg-message
index de633fe89ee8..e46eb3a3d43b 100644
--- a/mail/dspam/pkg-message
+++ b/mail/dspam/pkg-message
@@ -4,7 +4,7 @@
how to configure DSPAM with your MTA. Examples are provided for
sendmail, exim and other popular MTAs.
%%MYSQL%%
-%%MYSQL%% See %%DOCSDIR%%/mysql/README
+%%MYSQL%% See %%EXAMPLESDIR%%/README
%%MYSQL%% for instructions on how to configure MySQL
%%MYSQL%% for use with DSPAM.
%%MYSQL%%