aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-07-20 13:49:36 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-07-20 13:49:36 +0000
commitb0b3269e707d350f8fcbe0c7bce596e018ad3fd5 (patch)
treedbad24977796386441b1aaa493d3ea4bd9996b70 /mail
parentdee1e07efbbd38d4732cb6a1adbfd5d3340dbe7f (diff)
downloadports-b0b3269e707d350f8fcbe0c7bce596e018ad3fd5.tar.gz
ports-b0b3269e707d350f8fcbe0c7bce596e018ad3fd5.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/listar/Makefile45
-rw-r--r--mail/listar/distinfo1
-rw-r--r--mail/listar/files/patch-aa39
-rw-r--r--mail/listar/pkg-comment1
-rw-r--r--mail/listar/pkg-descr13
-rw-r--r--mail/listar/pkg-install64
-rw-r--r--mail/listar/pkg-plist51
8 files changed, 215 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index aca5eccf0841..a771334dbb5a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -39,6 +39,7 @@
SUBDIR += kbiff
SUBDIR += knewmail
SUBDIR += lbdb
+ SUBDIR += listar
SUBDIR += listmanager
SUBDIR += mailagent
SUBDIR += mailcrypt
diff --git a/mail/listar/Makefile b/mail/listar/Makefile
new file mode 100644
index 000000000000..346c400fa62a
--- /dev/null
+++ b/mail/listar/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: listar
+# Date created: 09 Apr 2000
+# Whom: Peter Losher <plosher@wwiv.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= listar
+PORTVERSION= 0.129a
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.listar.org/pub/listar/
+
+MAINTAINER= plosher@wwiv.com
+
+USE_GMAKE= yes
+
+NO_PACKAGE= "Requires listar uid"
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+pre-patch:
+
+ @ ${CP} ${WRKSRC}/Makefile.dist ${WRKSRC}/Makefile
+
+pre-install:
+
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/INSTALL ${PKGNAME} PRE-INSTALL
+ @ ${MKDIR} ${PREFIX}/listar
+ @ ${CP} -R ${WRKDIR}/${DISTNAME}/* ${PREFIX}/listar
+ @ ${RM} -R ${PREFIX}/listar/src/
+ @ ${RM} -R ${PREFIX}/listar/debian/
+ @ ${CHOWN} -R listar:listar ${PREFIX}/listar/*
+
+post-install:
+
+ @${ECHO_MSG} "---------------------------------------------------"
+ @${ECHO_MSG} "- Thank You for installing the Listar Listserver -"
+ @${ECHO_MSG} "- package. Please read the documentation located -"
+ @${ECHO_MSG} "- in ${PREFIX}/listar/, or online at: -"
+ @${ECHO_MSG} "- -"
+ @${ECHO_MSG} "- http://www.listar.org/ -"
+ @${ECHO_MSG} "- -"
+ @${ECHO_MSG} "- -The Listar Developers -"
+ @${ECHO_MSG} "---------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/mail/listar/distinfo b/mail/listar/distinfo
new file mode 100644
index 000000000000..6154bafefbf9
--- /dev/null
+++ b/mail/listar/distinfo
@@ -0,0 +1 @@
+MD5 (listar-0.129a.tar.gz) = c9b6c5297def7c6c30740bb5c8a39f32
diff --git a/mail/listar/files/patch-aa b/mail/listar/files/patch-aa
new file mode 100644
index 000000000000..64748403015b
--- /dev/null
+++ b/mail/listar/files/patch-aa
@@ -0,0 +1,39 @@
+--- Makefile.dist Thu Nov 11 16:49:23 1999
++++ Makefile Sat Apr 8 23:44:45 2000
+@@ -6,8 +6,8 @@
+ # they should be set. All of them are conditional on options set in this
+ # file, so it should be relatively easy to determine which branch is correct
+
+-BINDIR = ..
+-MODDIR = ../modules
++BINDIR = /usr/local/listar
++MODDIR = /usr/local/listar/modules
+
+ # First things first we need to set up some various options since OS's aren't
+ # as nice about things are they could be.
+@@ -27,7 +27,7 @@
+ # Uncomment this if you are on a BSD system AND you want dynamic modules
+ # SunOS (4 and 5 both) also needs this setting.
+ #
+-#BSDMOD = 1
++BSDMOD = 1
+
+ # Uncomment this if you are compiling on OpenBSD with modules (BSDMOD = 1)
+ #OBSDMOD = 1
+@@ -49,7 +49,7 @@
+ # Uncomment this if you have the GNU strftime() function. This version
+ # of the function understands %z to return the numerical offset. It's better
+ # to use that if it's available for RFC822 date headers
+-GNU_STRFTIME=-DGNU_STRFTIME
++#GNU_STRFTIME=-DGNU_STRFTIME
+
+ # Uncomment this if you are on a machine that doesn't have strerror()
+ #
+@@ -301,6 +301,7 @@
+ install: targets
+ cp build/listar ${BINDIR}
+ chmod ug+s ${BINDIR}/listar
++ chown -R listar:listar ${BINDIR}
+ ifdef DYNMOD
+ @for dir in ${MODULES}; do \
+ cp build/$${dir}.lpm ${MODDIR}/$${dir}.lpm; \
diff --git a/mail/listar/pkg-comment b/mail/listar/pkg-comment
new file mode 100644
index 000000000000..8fec7689a34d
--- /dev/null
+++ b/mail/listar/pkg-comment
@@ -0,0 +1 @@
+The Listar Listserver \ Mailing List Manager
diff --git a/mail/listar/pkg-descr b/mail/listar/pkg-descr
new file mode 100644
index 000000000000..62e5a284acf7
--- /dev/null
+++ b/mail/listar/pkg-descr
@@ -0,0 +1,13 @@
+Listar is a open-source (GNU Licence) software package that adminsters
+mailing lists (similar to Majordomo and Listserv). Some of Listar's
+features include:
+
+ - A modular design structure, so that you can compile what you
+ need (and don't)
+ - The ability to strip down MIME messages and remove their
+ attachments.
+ - Ability to be run in a multi-Virtual Host configuration.
+
+Take a look at Listar's website to get a full feature list:
+
+WWW: http://www.listar.org/
diff --git a/mail/listar/pkg-install b/mail/listar/pkg-install
new file mode 100644
index 000000000000..4dd9d905df54
--- /dev/null
+++ b/mail/listar/pkg-install
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+user=listar
+group=listar
+
+ask() {
+ local question default answer
+
+ question=$1
+ default=$2
+ if [ -z "${PACKAGE_BUILDING}" ]; then
+ read -p "${question} [${default}]? " answer
+ fi
+ if [ x${answer} = x ]; then
+ answer=${default}
+ fi
+ echo ${answer}
+}
+
+yesno() {
+ local dflt question answer
+
+ question=$1
+ dflt=$2
+ while :; do
+ answer=$(ask "${question}" "${dflt}")
+ case "${answer}" in
+ [Yy]*) return 0;;
+ [Nn]*) return 1;;
+ esac
+ echo "Please answer yes or no."
+ done
+}
+
+if [ x"$2" = xPRE-INSTALL ]; then
+ if pw groupshow "${group}" 2>/dev/null; then
+ echo "You already have a group \"${group}\", so I will use it."
+ else
+ echo "You need a group \"${group}\"."
+ if yesno "Would you like me to create it" y; then
+ pw groupadd ${group} -h - || exit
+ echo "Done."
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${user}" 2>/dev/null; then
+ echo "You already have a user \"${user}\", so I will use it."
+ else
+ echo "You need a user \"${user}\"."
+ if yesno "Would you like me to create it" y; then
+ pw useradd ${user} -g ${group} -h - -d /nonexistent \
+ -s /nonexistent -c "Listar Listserver" || exit
+ echo "Done."
+ else
+ echo "Please create it, and try again."
+ exit 1
+ fi
+ fi
+
+fi
+
diff --git a/mail/listar/pkg-plist b/mail/listar/pkg-plist
new file mode 100644
index 000000000000..059069863089
--- /dev/null
+++ b/mail/listar/pkg-plist
@@ -0,0 +1,51 @@
+listar/COPYRIGHT
+listar/LICENSE
+listar/NOTE
+listar/PLATFORMS
+listar/README
+listar/README.126
+listar/README.ANTISPAM
+listar/README.CVS
+listar/README.DIGEST
+listar/README.LISTS
+listar/banned
+listar/listar
+listar/listar.aliases.dist
+listar/listar.cfg.dist
+listar/listar.dsw
+listar/listar.hlp
+listar/listar.spec
+listar/lists/test/text/blacklist.txt
+listar/lists/test/text/closed-post.txt
+listar/lists/test/text/footer.txt
+listar/lists/test/text/intro.txt
+listar/lists/test/config
+listar/lists/test/cookies
+listar/lists/test/users
+listar/modules/README
+listar/modules/bouncer.lpm
+listar/modules/listarchive.lpm
+listar/modules/filearchive.lpm
+listar/modules/admin.lpm
+listar/modules/acctmgr.lpm
+listar/modules/stat.lpm
+listar/modules/send.lpm
+listar/modules/base.lpm
+listar/modules/digest.lpm
+listar/modules/antispam.lpm
+listar/modules/administrivia.lpm
+listar/modules/toolbox.lpm
+listar/modules/pantomime.lpm
+listar/modules/listargate.lpm
+listar/modules/password.lpm
+listar/queue/README
+listar/scripts/listargate.cgi.dist
+listar/scripts/fixlist.pl.dist
+listar/spam-regexp.sample
+@dirrm listar/lists/test/text
+@dirrm listar/lists/test
+@dirrm listar/lists
+@dirrm listar/modules
+@dirrm listar/queue
+@dirrm listar/scripts
+@dirrm listar