aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-09-21 11:06:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-09-21 11:06:03 +0000
commit1e3119b07ebe66367ead55242a47710e556bf383 (patch)
tree2051ba0023bbf060fa37051dc7fc6990710a53b1 /mail
parent0dea0192303406b3b949a31479a4264b58bafce6 (diff)
downloadports-1e3119b07ebe66367ead55242a47710e556bf383.tar.gz
ports-1e3119b07ebe66367ead55242a47710e556bf383.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/antivirus-milter/Makefile7
-rw-r--r--mail/dk-milter/Makefile3
-rw-r--r--mail/meta1/Makefile2
-rw-r--r--mail/milter-regex/Makefile3
-rw-r--r--mail/noattach/Makefile3
-rw-r--r--mail/pathalias/Makefile3
-rw-r--r--mail/raysfilter/Makefile3
-rw-r--r--mail/rbl-milter/Makefile3
-rw-r--r--mail/ripmime/Makefile2
-rw-r--r--mail/sendmail-sasl/Makefile1
-rw-r--r--mail/sendmail/Makefile2
-rw-r--r--mail/sentinel/Makefile4
-rw-r--r--mail/sid-milter/Makefile2
-rw-r--r--mail/sma/Makefile3
-rw-r--r--mail/spamilter/Makefile3
-rw-r--r--mail/vbsfilter/Makefile3
16 files changed, 29 insertions, 18 deletions
diff --git a/mail/antivirus-milter/Makefile b/mail/antivirus-milter/Makefile
index a90b3eff315e..5a7d42833166 100644
--- a/mail/antivirus-milter/Makefile
+++ b/mail/antivirus-milter/Makefile
@@ -12,17 +12,18 @@ COMMENT= Sendmail milter wich uses McAfee Virus Scan or clamav
LICENSE= BSD
-USE_RC_SUBR= antivirus-milter
+NO_STAGE= yes
CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
LIBS+= -lmilter ${PTHREAD_LIBS}
-ANTIVIRUS_DIR?= /var/spool/antivirus
PLIST_SUB+= ANTIVIRUS=${ANTIVIRUS_DIR}
SUB_LIST+= ANTIVIRUS=${ANTIVIRUS_DIR}
SED_SCRIPT= -e 's|%%ANTIVIRUS%%|${ANTIVIRUS_DIR}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g'
+USE_RC_SUBR= antivirus-milter
+
+ANTIVIRUS_DIR?= /var/spool/antivirus
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/dk-milter/Makefile b/mail/dk-milter/Makefile
index e913e48e1376..2469abc0d1d6 100644
--- a/mail/dk-milter/Makefile
+++ b/mail/dk-milter/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= SF/${PORTNAME}/DomainKeys%20Milter/${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Domainkeys milter for Sendmail
+NO_STAGE= yes
+
USE_RC_SUBR= milter-dk
USE_OPENSSL= yes
@@ -39,7 +41,6 @@ SITE+= ${FILESDIR}/site.config.m4
SITE_SUB+= -e "s|%%PREFIX%%|${PREFIX}|g" \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g"
-NO_STAGE= yes
.include <bsd.port.pre.mk>
WITHOUT_MILTER_CFLAGS= yes
diff --git a/mail/meta1/Makefile b/mail/meta1/Makefile
index 9a0221be2f53..947cf9987e48 100644
--- a/mail/meta1/Makefile
+++ b/mail/meta1/Makefile
@@ -13,6 +13,7 @@ COMMENT= Secure and efficient mail gateway
NOT_FOR_ARCHS= ia64
MAKE_JOBS_UNSAFE= yes
CONFLICTS= smx-*
+NO_STAGE= yes
.if !defined(SENDMAIL_WITHOUT_SHMEM) && !defined(BUILDING_INDEX)
IPCCHECK!= ipcrm -q 0 2>&1 || true
@@ -42,7 +43,6 @@ EXTRA_SBIN= libcheck/noroot libconf/tree libmta/statit \
#GROUPS= meta1s meta1q meta1c meta1m meta1
#USERS= meta1s meta1q meta1c meta1m meta1
-NO_STAGE= yes
# default config:
META1CONFDIR?= ${PREFIX}/etc/meta1
NOLOGIN_CMD?= /usr/sbin/nologin
diff --git a/mail/milter-regex/Makefile b/mail/milter-regex/Makefile
index 756c01dda9f0..576c33694cfe 100644
--- a/mail/milter-regex/Makefile
+++ b/mail/milter-regex/Makefile
@@ -12,6 +12,8 @@ COMMENT= Milter plugin to sendmail for regular expression filtering
LICENSE= BSD
LICENSE_FILE= ${FILESDIR}/COPYRIGHT
+NO_STAGE= yes
+
MAILUSER?= mailnull
MAN8= milter-regex.8
PLIST_FILES= libexec/milter-regex
@@ -19,7 +21,6 @@ USE_RC_SUBR= milterregex
SPOOLDIR?= /var/run/milter-regex
SUB_LIST= SPOOLDIR=${SPOOLDIR}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/noattach/Makefile b/mail/noattach/Makefile
index cd7a7ffd4ffa..b73dbfef429d 100644
--- a/mail/noattach/Makefile
+++ b/mail/noattach/Makefile
@@ -12,6 +12,8 @@ COMMENT= An attachment filter for Sendmail Milter
GNU_CONFIGURE= yes
USE_RC_SUBR= noattach
+NO_STAGE= yes
+
CFLAGS+= ${PTHREAD_CFLAGS:S=""==}
MAN8= noattach.8
DOCSFILES= AUTHORS THANKS INSTALL NEWS README TODO ChangeLog
@@ -20,7 +22,6 @@ SAMPLEFILES= README noattach.patterns noattach.patterns.johncon
CONFIGURE_ARGS+= --enable-ldap
.endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/pathalias/Makefile b/mail/pathalias/Makefile
index 093526ee8e0f..1133f30c6cb4 100644
--- a/mail/pathalias/Makefile
+++ b/mail/pathalias/Makefile
@@ -9,13 +9,14 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Mail routing tools
+NO_STAGE= yes
+
ALL_TARGET= pathalias
MAN8= pathalias.8
BIN8= pathalias
PLIST_FILES= bin/pathalias
-NO_STAGE= yes
do-install:
.for i in ${BIN8}
@${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin
diff --git a/mail/raysfilter/Makefile b/mail/raysfilter/Makefile
index e65935881cbe..e918c0d18ed3 100644
--- a/mail/raysfilter/Makefile
+++ b/mail/raysfilter/Makefile
@@ -10,6 +10,8 @@ DISTNAME= rays-filter-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A configurable filter for Sendmail Milter
+NO_STAGE= yes
+
CTARGETS+= rays-filter
CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
LIBS+= ${PTHREAD_LIBS}
@@ -18,7 +20,6 @@ BINFILES= mf-reset mf-start mf-stop mf-archive mf-analyze mf-memory
DOCSFILES= rays-filter.html install.html configure.html operate.html \
utilities.html GNU-public-licence.txt copyright.txt README
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/rbl-milter/Makefile b/mail/rbl-milter/Makefile
index f2c6e4543e4d..f087532288c7 100644
--- a/mail/rbl-milter/Makefile
+++ b/mail/rbl-milter/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://opensource.confusticate.com/rbl-milter/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A milter that adds mail header warnings on mail from open-relays
+NO_STAGE= yes
+
USE_RC_SUBR= rblmilter
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -19,7 +21,6 @@ CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}
PLIST_FILES= sbin/rbl-milter
.if defined(NO_WERROR)
-NO_STAGE= yes
pre-configure:
@${CP} ${WRKSRC}/configure ${WRKSRC}/configure.sed
@${SED} 's!-Werror!!' ${WRKSRC}/configure.sed >${WRKSRC}/configure
diff --git a/mail/ripmime/Makefile b/mail/ripmime/Makefile
index 1e3f2be63c04..4cedb8b51cf1 100644
--- a/mail/ripmime/Makefile
+++ b/mail/ripmime/Makefile
@@ -12,11 +12,11 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Extracts attached files out of a MIME encoded email package
MAKE_JOBS_UNSAFE= yes
+NO_STAGE= yes
PLIST_FILES= bin/ripmime
MAN1= ripmime.1
-NO_STAGE= yes
pre-build:
@${REINPLACE_CMD} -e 's!CC=!CC?=!; s!/usr/local!${PREFIX}!; \
s!^CFLAGS=!CFLAGS ?=!' \
diff --git a/mail/sendmail-sasl/Makefile b/mail/sendmail-sasl/Makefile
index 43d4a0370230..2afda45f30e0 100644
--- a/mail/sendmail-sasl/Makefile
+++ b/mail/sendmail-sasl/Makefile
@@ -11,7 +11,6 @@ SENDMAIL_PORT?= sendmail
MASTERDIR?= ${.CURDIR}/../${SENDMAIL_PORT}
.if exists(${.CURDIR}/Makefile.local)
-NO_STAGE= yes
.include "${.CURDIR}/Makefile.local"
.endif
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 0b81bda415f3..6f96de8ec010 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -13,6 +13,7 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Reliable, highly configurable mail transfer agent with utilities
CONFLICTS?= courier-0.* postfix-1.* postfix-2.* smail-3.* zmailer-2.* opensmtpd-*
+NO_STAGE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WCONF= ${WRKSRC}/devtools/Site
@@ -45,7 +46,6 @@ MILTER_DESC= Build libmilter
MILTER_SHARED_DESC= Build shared libmilter
MILTER_POOL_DESC= Enable milter thread pools
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSHMEM} && !defined(BUILDING_INDEX)
diff --git a/mail/sentinel/Makefile b/mail/sentinel/Makefile
index 95a64d56471c..fa074aeded68 100644
--- a/mail/sentinel/Makefile
+++ b/mail/sentinel/Makefile
@@ -11,10 +11,12 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= A sendmail milter API implementation
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+
+NO_STAGE= yes
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/sid-milter/Makefile b/mail/sid-milter/Makefile
index da1d945b39b3..f04480507da2 100644
--- a/mail/sid-milter/Makefile
+++ b/mail/sid-milter/Makefile
@@ -9,6 +9,7 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= An sid and spf milter for Sendmail
RESTRICTED= may incorporate intellectual property, possible patent issues
+NO_STAGE= yes
WCONF= ${WRKSRC}/devtools/Site
MAN8= sid-filter.8
@@ -32,7 +33,6 @@ PLIST_FILES+= include/libar.h lib/libar.a
.endif
USE_RC_SUBR= milter-sid
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/sma/Makefile b/mail/sma/Makefile
index 75079430813d..7523e21d61d5 100644
--- a/mail/sma/Makefile
+++ b/mail/sma/Makefile
@@ -10,12 +10,13 @@ MASTER_SITE_SUBDIR= dinoex
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Program that analyses Sendmail log entries
+NO_STAGE= yes
+
MAN8= sma.8
DOCSFILES= BUGS COPYRIGHT HISTORY README TODO
SAMPLEFILES= sma.conf
ALL_TARGET= sma
-NO_STAGE= yes
do-configure:
@${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.sed
${SED} -e "s,CC =,CC?= ," \
diff --git a/mail/spamilter/Makefile b/mail/spamilter/Makefile
index 940571bf3e81..a40619827f78 100644
--- a/mail/spamilter/Makefile
+++ b/mail/spamilter/Makefile
@@ -14,6 +14,8 @@ COMMENT= A Sendmail LibMilter filter to block spam
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
+NO_STAGE= yes
+
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --have-resn
USE_RC_SUBR= spamilter
@@ -27,7 +29,6 @@ DOCSFILES= Changelog INSTALL LICENSE docs/docs.html docs/docs.txt \
conf/db.rcpt conf/db.rdnsbl conf/db.sndr \
conf/policy.html conf/spamilter.rc
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/mail/vbsfilter/Makefile b/mail/vbsfilter/Makefile
index 9eeda53b578f..291f9f9ed9ed 100644
--- a/mail/vbsfilter/Makefile
+++ b/mail/vbsfilter/Makefile
@@ -13,6 +13,8 @@ COMMENT= A vbs-attachment filter for Sendmail Milter
LICENSE= GPLv2
+NO_STAGE= yes
+
USE_RC_SUBR= vbsfilter
PLIST_FILES= libexec/vbsfilter
@@ -21,7 +23,6 @@ LIBS+= ${PTHREAD_LIBS}
LIBS+= -lmilter
CFLAGS+= -Wall ${PTHREAD_CFLAGS:S=""==}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"