aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2009-12-18 22:23:57 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2009-12-18 22:23:57 +0000
commit44f1b3b22f93109d89865948972a41b2e4eb9340 (patch)
treeb8ae16cc14c76976164b23ed176693bb5500f757 /mail
parentf7ff0e5edd2d7678c12f824a49264afdcb07dcd2 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird3/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 459680c9c677..151143fe9a6a 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
DISTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${DISTVERSION}/source/
@@ -45,7 +46,8 @@ MOZ_EXPORT= MOZ_THUNDERBIRD=1 MAIL_PKG_SHARED=1
MOZILLA_PLIST_DIRS= bin lib
MOZ_PKGCONFIG_FILES=
-PORTNAME_ICON= ${PREFIX}/lib/${PORTNAME}/icons/default.xpm
+PORTNAME_ICON= ${PORTNAME}.png
+PORTNAME_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/chrome/icons/default/default48.png
SYSTEM_PREFS= ${FAKEDIR}/lib/${PORTNAME}-${PORTVERSION}/defaults/pref/${PORTNAME}.js
MOZ_PIS_SCRIPTS=moz_pis_S50cleanhome
@@ -80,8 +82,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
.endif
post-extract::
- ${SED} -e 's|@MOZILLA_ICON@|${MOZILLA_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
- -e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \
+ ${SED} -e 's|@PORTNAME_ICON@|${PORTNAME_ICON}|' \
<${FILESDIR}/thunderbird.desktop.in >${WRKDIR}/${MOZILLA_EXEC_NAME}.desktop
${LN} -s ${WRKSRC}/mail ${WRKSRC}/mozilla/mail
@@ -112,10 +113,12 @@ port-pre-install:
pre-install:
@${ECHO_CMD} 'share/applications/${PORTNAME}.desktop' >> ${PLIST}
+ @${ECHO_CMD} 'share/pixmaps/${PORTNAME_ICON}' >> ${PLIST}
@${ECHO_CMD} '@dirrmtry share/applications' >> ${PLIST}
post-install:
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKDIR}/${MOZILLA_EXEC_NAME}.desktop ${PREFIX}/share/applications
+ ${LN} -sf ${PORTNAME_ICON_SRC} ${PREFIX}/share/pixmaps/${PORTNAME_ICON}
.include <bsd.port.post.mk>