aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1997-05-19 13:01:11 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1997-05-19 13:01:11 +0000
commit5d9b41e9cf60bb8e524369edcc7af831aafe611a (patch)
tree40fa65f8cba77b77e2e5512f199cc3befa0efaef /mail
parent34dbcb1cf9d72fd4a592060618468c0c205516ea (diff)
downloadports-5d9b41e9cf60bb8e524369edcc7af831aafe611a.tar.gz
ports-5d9b41e9cf60bb8e524369edcc7af831aafe611a.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile68
-rw-r--r--mail/mutt-devel/files/patch-0162
-rw-r--r--mail/mutt/Makefile68
-rw-r--r--mail/mutt/files/patch-0162
-rw-r--r--mail/mutt14/Makefile68
-rw-r--r--mail/mutt14/files/patch-0162
6 files changed, 294 insertions, 96 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index a3c0c6db12af..cca33b5323f5 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -1,37 +1,75 @@
# ex:ts=8
-# New ports collection makefile for: mutt
+# New ports collection makefile for: mutt w/pgp hooks
# Version required: 0.xy
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.27 1997/04/05 17:27:37 obrien Exp $
+# $Id: Makefile,v 1.32 1997/05/17 05:34:22 obrien Exp $
-DISTNAME= ${PKGNAME}e
-PKGNAME= mutt-0.74
+BASEDIST= mutt-0.74
+DISTNAME= ${BASEDIST}
+PKGNAME= mutt-pgp-0.74
CATEGORIES= mail
-MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/ \
- ftp://ftp.ibp.fr/pub/unix/mail/mutt/ \
- ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
- ftp://ftp.teuto.de/pub/user/lmb/ \
- ftp://ftp.funet.fi/pub/unix/mail/mutt/
+MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/
+MASTER_SITE_OVERRIDE=
-PATCH_SITES= ftp://ftp.nuxi.com/pub/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.math.fu-berlin.de/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
- ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/
+PATCH_SITES= http://www.frmug.org/mutt/mutt/0.73/ \
+ http://www.math.fu-berlin.de/~leitner/mutt/0.73/ \
+ http://www.efrei.fr/~parmelan/mutt/0.73/ \
+ ftp://www.frmug.org/pub/mutt/mutt/0.73/
PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
+# Need to define USA_RESIDENT to YES or NO
+RESTRICTED= "USA ITAR export restrictions (has PGP hooks)"
+
DIST_SUBDIR= mutt
-WRKSRC= ${WRKDIR}/${PKGNAME}
#PATCH_DIST_STRIP= -p2
PATCH_DIST_STRIP= -p1
#PATCH_DIST_STRIP=
GNU_CONFIGURE= yes
MAN1= mutt.1
+.if !defined(USA_RESIDENT) || (${USA_RESIDENT} != YES && ${USA_RESIDENT} != yes && ${USA_RESIDENT} != NO && ${USA_RESIDENT} != no)
+pre-fetch:
+ @echo
+ @echo You must set variable USA_RESIDENT to YES, if you are USA resident,
+ @echo or to NO if you aren\'t a USA resident in order to build this package
+ @false
+
+.elif defined(USA_RESIDENT)
+.if ${USA_RESIDENT} == YES || ${USA_RESIDENT} == yes
+# can't grab patches from Nuxi unless you are in USA/Canada
+PATCH_SITES:= ftp://ftp.nuxi.com/pub/mutt/${BASEDIST:S/^mutt-//}/ \
+ ${PATCH_SITES}
+pre-fetch: # don't use "do-fetch" otherwise we won't get the patches
+ @${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
+ @(cd ${DISTDIR}/${DIST_SUBDIR} ; \
+ if [ ! -f ${DISTFILES} -a ! -f `${BASENAME} ${DISTFILES}` ]; then \
+ ${FETCH_CMD} -o /tmp/README.US-only ${MASTER_SITES}README.US-only ; \
+ sed -e 's:US-only/.*:&:w /tmp/muttusa.dir' /tmp/README.US-only >/dev/null ; \
+ USADISTRIB=`sed -e 's:^.*US-only/::' /tmp/muttusa.dir` ; \
+ ${FETCH_CMD} -m ${FETCH_BEFORE_ARGS} ${MASTER_SITES}US-only/$$USADISTRIB/${DISTNAME}${EXTRACT_SUFX} ${FETCH_AFTER_ARGS} ; \
+ /bin/rm -f /tmp/README.US-only /tmp/muttusa.dir ; \
+ fi)
+FILESDIR= ${.CURDIR}/files.usa
+
+.else #non-USA resident
+DISTNAME= ${BASEDIST}e
+FILESDIR= ${.CURDIR}/files.non_usa
+MASTER_SITES:= ftp://ftp.ibp.fr/pub/unix/mail/mutt/mutt/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
+ ftp://ftp.teuto.de/pub/user/lmb/ \
+ ftp://ftp.funet.fi/pub/unix/mail/mutt/ \
+ ${MASTER_SITES}
+# 01.pgp.1 needs to be applied before all others!
+PATCHFILES:= 01.pgp.1 ${PATCHFILES}
+WRKSRC= ${WRKDIR}/${BASEDIST}
+
+.endif # USA resident = yes
+.endif # USA resident set
+
post-install:
@#### don't strip until out of beta peroid
diff --git a/mail/mutt-devel/files/patch-01 b/mail/mutt-devel/files/patch-01
index 636181881511..ec137d95bb90 100644
--- a/mail/mutt-devel/files/patch-01
+++ b/mail/mutt-devel/files/patch-01
@@ -1,17 +1,45 @@
---- Makefile.in.orig Mon Jan 27 18:15:59 1997
-+++ Makefile.in Wed Jan 29 07:23:40 1997
-@@ -72,10 +72,13 @@
- sendlib.c \
- url.c
-
--all: mutt
-+all: mutt docs
-
- mutt: $(OBJS) $(REGEX)
- $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
-+
-+docs:
-+ cd doc && make fbsd
-
- install: mutt
- $(srcdir)/mkinstalldirs $(bindir)
+*** Makefile.in.orig Sat May 17 03:05:18 1997
+--- Makefile.in Mon May 19 15:41:18 1997
+***************
+*** 34,40 ****
+ XCPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@
+ CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
+ LDFLAGS=@LDFLAGS@
+! LIBS=@LIBS@
+ REGEX=@REGEX@
+ OBJS= addrbook.o alias.o attach.o bind.o browser.o buffy.o color.o \
+ commands.o \
+--- 34,40 ----
+ XCPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@
+ CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
+ LDFLAGS=@LDFLAGS@
+! LIBS=@LIBS@ -lmytinfo
+ REGEX=@REGEX@
+ OBJS= addrbook.o alias.o attach.o bind.o browser.o buffy.o color.o \
+ commands.o \
+***************
+*** 52,61 ****
+ EXCLUDE=config.h config.cache config.log config.status tags Makefile \
+ rx/Makefile
+
+! all: mutt
+
+ mutt: $(OBJS) $(REGEX)
+ $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
+
+ install: mutt
+ $(srcdir)/mkinstalldirs $(bindir)
+--- 52,64 ----
+ EXCLUDE=config.h config.cache config.log config.status tags Makefile \
+ rx/Makefile
+
+! all: mutt docs
+
+ mutt: $(OBJS) $(REGEX)
+ $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
++
++ docs:
++ cd doc && make fbsd
+
+ install: mutt
+ $(srcdir)/mkinstalldirs $(bindir)
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index a3c0c6db12af..cca33b5323f5 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -1,37 +1,75 @@
# ex:ts=8
-# New ports collection makefile for: mutt
+# New ports collection makefile for: mutt w/pgp hooks
# Version required: 0.xy
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.27 1997/04/05 17:27:37 obrien Exp $
+# $Id: Makefile,v 1.32 1997/05/17 05:34:22 obrien Exp $
-DISTNAME= ${PKGNAME}e
-PKGNAME= mutt-0.74
+BASEDIST= mutt-0.74
+DISTNAME= ${BASEDIST}
+PKGNAME= mutt-pgp-0.74
CATEGORIES= mail
-MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/ \
- ftp://ftp.ibp.fr/pub/unix/mail/mutt/ \
- ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
- ftp://ftp.teuto.de/pub/user/lmb/ \
- ftp://ftp.funet.fi/pub/unix/mail/mutt/
+MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/
+MASTER_SITE_OVERRIDE=
-PATCH_SITES= ftp://ftp.nuxi.com/pub/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.math.fu-berlin.de/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
- ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/
+PATCH_SITES= http://www.frmug.org/mutt/mutt/0.73/ \
+ http://www.math.fu-berlin.de/~leitner/mutt/0.73/ \
+ http://www.efrei.fr/~parmelan/mutt/0.73/ \
+ ftp://www.frmug.org/pub/mutt/mutt/0.73/
PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
+# Need to define USA_RESIDENT to YES or NO
+RESTRICTED= "USA ITAR export restrictions (has PGP hooks)"
+
DIST_SUBDIR= mutt
-WRKSRC= ${WRKDIR}/${PKGNAME}
#PATCH_DIST_STRIP= -p2
PATCH_DIST_STRIP= -p1
#PATCH_DIST_STRIP=
GNU_CONFIGURE= yes
MAN1= mutt.1
+.if !defined(USA_RESIDENT) || (${USA_RESIDENT} != YES && ${USA_RESIDENT} != yes && ${USA_RESIDENT} != NO && ${USA_RESIDENT} != no)
+pre-fetch:
+ @echo
+ @echo You must set variable USA_RESIDENT to YES, if you are USA resident,
+ @echo or to NO if you aren\'t a USA resident in order to build this package
+ @false
+
+.elif defined(USA_RESIDENT)
+.if ${USA_RESIDENT} == YES || ${USA_RESIDENT} == yes
+# can't grab patches from Nuxi unless you are in USA/Canada
+PATCH_SITES:= ftp://ftp.nuxi.com/pub/mutt/${BASEDIST:S/^mutt-//}/ \
+ ${PATCH_SITES}
+pre-fetch: # don't use "do-fetch" otherwise we won't get the patches
+ @${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
+ @(cd ${DISTDIR}/${DIST_SUBDIR} ; \
+ if [ ! -f ${DISTFILES} -a ! -f `${BASENAME} ${DISTFILES}` ]; then \
+ ${FETCH_CMD} -o /tmp/README.US-only ${MASTER_SITES}README.US-only ; \
+ sed -e 's:US-only/.*:&:w /tmp/muttusa.dir' /tmp/README.US-only >/dev/null ; \
+ USADISTRIB=`sed -e 's:^.*US-only/::' /tmp/muttusa.dir` ; \
+ ${FETCH_CMD} -m ${FETCH_BEFORE_ARGS} ${MASTER_SITES}US-only/$$USADISTRIB/${DISTNAME}${EXTRACT_SUFX} ${FETCH_AFTER_ARGS} ; \
+ /bin/rm -f /tmp/README.US-only /tmp/muttusa.dir ; \
+ fi)
+FILESDIR= ${.CURDIR}/files.usa
+
+.else #non-USA resident
+DISTNAME= ${BASEDIST}e
+FILESDIR= ${.CURDIR}/files.non_usa
+MASTER_SITES:= ftp://ftp.ibp.fr/pub/unix/mail/mutt/mutt/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
+ ftp://ftp.teuto.de/pub/user/lmb/ \
+ ftp://ftp.funet.fi/pub/unix/mail/mutt/ \
+ ${MASTER_SITES}
+# 01.pgp.1 needs to be applied before all others!
+PATCHFILES:= 01.pgp.1 ${PATCHFILES}
+WRKSRC= ${WRKDIR}/${BASEDIST}
+
+.endif # USA resident = yes
+.endif # USA resident set
+
post-install:
@#### don't strip until out of beta peroid
diff --git a/mail/mutt/files/patch-01 b/mail/mutt/files/patch-01
index 636181881511..ec137d95bb90 100644
--- a/mail/mutt/files/patch-01
+++ b/mail/mutt/files/patch-01
@@ -1,17 +1,45 @@
---- Makefile.in.orig Mon Jan 27 18:15:59 1997
-+++ Makefile.in Wed Jan 29 07:23:40 1997
-@@ -72,10 +72,13 @@
- sendlib.c \
- url.c
-
--all: mutt
-+all: mutt docs
-
- mutt: $(OBJS) $(REGEX)
- $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
-+
-+docs:
-+ cd doc && make fbsd
-
- install: mutt
- $(srcdir)/mkinstalldirs $(bindir)
+*** Makefile.in.orig Sat May 17 03:05:18 1997
+--- Makefile.in Mon May 19 15:41:18 1997
+***************
+*** 34,40 ****
+ XCPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@
+ CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
+ LDFLAGS=@LDFLAGS@
+! LIBS=@LIBS@
+ REGEX=@REGEX@
+ OBJS= addrbook.o alias.o attach.o bind.o browser.o buffy.o color.o \
+ commands.o \
+--- 34,40 ----
+ XCPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@
+ CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
+ LDFLAGS=@LDFLAGS@
+! LIBS=@LIBS@ -lmytinfo
+ REGEX=@REGEX@
+ OBJS= addrbook.o alias.o attach.o bind.o browser.o buffy.o color.o \
+ commands.o \
+***************
+*** 52,61 ****
+ EXCLUDE=config.h config.cache config.log config.status tags Makefile \
+ rx/Makefile
+
+! all: mutt
+
+ mutt: $(OBJS) $(REGEX)
+ $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
+
+ install: mutt
+ $(srcdir)/mkinstalldirs $(bindir)
+--- 52,64 ----
+ EXCLUDE=config.h config.cache config.log config.status tags Makefile \
+ rx/Makefile
+
+! all: mutt docs
+
+ mutt: $(OBJS) $(REGEX)
+ $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
++
++ docs:
++ cd doc && make fbsd
+
+ install: mutt
+ $(srcdir)/mkinstalldirs $(bindir)
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index a3c0c6db12af..cca33b5323f5 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -1,37 +1,75 @@
# ex:ts=8
-# New ports collection makefile for: mutt
+# New ports collection makefile for: mutt w/pgp hooks
# Version required: 0.xy
# Date created: Thur July 25, 1996
# Whom: David O'Brien (obrien@NUXI.com)
#
-# $Id: Makefile,v 1.27 1997/04/05 17:27:37 obrien Exp $
+# $Id: Makefile,v 1.32 1997/05/17 05:34:22 obrien Exp $
-DISTNAME= ${PKGNAME}e
-PKGNAME= mutt-0.74
+BASEDIST= mutt-0.74
+DISTNAME= ${BASEDIST}
+PKGNAME= mutt-pgp-0.74
CATEGORIES= mail
-MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/ \
- ftp://ftp.ibp.fr/pub/unix/mail/mutt/ \
- ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
- ftp://ftp.teuto.de/pub/user/lmb/ \
- ftp://ftp.funet.fi/pub/unix/mail/mutt/
+MASTER_SITES= ftp://ftp.cs.hmc.edu/pub/me/mutt/
+MASTER_SITE_OVERRIDE=
-PATCH_SITES= ftp://ftp.nuxi.com/pub/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.frmug.org/mutt/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.math.fu-berlin.de/~leitner/mutt/${PKGNAME:S/^mutt-//}/ \
- http://www.efrei.fr/~parmelan/mutt/${PKGNAME:S/^mutt-//}/ \
- ftp://www.frmug.org/pub/mutt/mutt/${PKGNAME:S/^mutt-//}/
+PATCH_SITES= http://www.frmug.org/mutt/mutt/0.73/ \
+ http://www.math.fu-berlin.de/~leitner/mutt/0.73/ \
+ http://www.efrei.fr/~parmelan/mutt/0.73/ \
+ ftp://www.frmug.org/pub/mutt/mutt/0.73/
PATCHFILES=
MAINTAINER= obrien@FreeBSD.org
+# Need to define USA_RESIDENT to YES or NO
+RESTRICTED= "USA ITAR export restrictions (has PGP hooks)"
+
DIST_SUBDIR= mutt
-WRKSRC= ${WRKDIR}/${PKGNAME}
#PATCH_DIST_STRIP= -p2
PATCH_DIST_STRIP= -p1
#PATCH_DIST_STRIP=
GNU_CONFIGURE= yes
MAN1= mutt.1
+.if !defined(USA_RESIDENT) || (${USA_RESIDENT} != YES && ${USA_RESIDENT} != yes && ${USA_RESIDENT} != NO && ${USA_RESIDENT} != no)
+pre-fetch:
+ @echo
+ @echo You must set variable USA_RESIDENT to YES, if you are USA resident,
+ @echo or to NO if you aren\'t a USA resident in order to build this package
+ @false
+
+.elif defined(USA_RESIDENT)
+.if ${USA_RESIDENT} == YES || ${USA_RESIDENT} == yes
+# can't grab patches from Nuxi unless you are in USA/Canada
+PATCH_SITES:= ftp://ftp.nuxi.com/pub/mutt/${BASEDIST:S/^mutt-//}/ \
+ ${PATCH_SITES}
+pre-fetch: # don't use "do-fetch" otherwise we won't get the patches
+ @${MKDIR} ${DISTDIR}/${DIST_SUBDIR}
+ @(cd ${DISTDIR}/${DIST_SUBDIR} ; \
+ if [ ! -f ${DISTFILES} -a ! -f `${BASENAME} ${DISTFILES}` ]; then \
+ ${FETCH_CMD} -o /tmp/README.US-only ${MASTER_SITES}README.US-only ; \
+ sed -e 's:US-only/.*:&:w /tmp/muttusa.dir' /tmp/README.US-only >/dev/null ; \
+ USADISTRIB=`sed -e 's:^.*US-only/::' /tmp/muttusa.dir` ; \
+ ${FETCH_CMD} -m ${FETCH_BEFORE_ARGS} ${MASTER_SITES}US-only/$$USADISTRIB/${DISTNAME}${EXTRACT_SUFX} ${FETCH_AFTER_ARGS} ; \
+ /bin/rm -f /tmp/README.US-only /tmp/muttusa.dir ; \
+ fi)
+FILESDIR= ${.CURDIR}/files.usa
+
+.else #non-USA resident
+DISTNAME= ${BASEDIST}e
+FILESDIR= ${.CURDIR}/files.non_usa
+MASTER_SITES:= ftp://ftp.ibp.fr/pub/unix/mail/mutt/mutt/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
+ ftp://ftp.teuto.de/pub/user/lmb/ \
+ ftp://ftp.funet.fi/pub/unix/mail/mutt/ \
+ ${MASTER_SITES}
+# 01.pgp.1 needs to be applied before all others!
+PATCHFILES:= 01.pgp.1 ${PATCHFILES}
+WRKSRC= ${WRKDIR}/${BASEDIST}
+
+.endif # USA resident = yes
+.endif # USA resident set
+
post-install:
@#### don't strip until out of beta peroid
diff --git a/mail/mutt14/files/patch-01 b/mail/mutt14/files/patch-01
index 636181881511..ec137d95bb90 100644
--- a/mail/mutt14/files/patch-01
+++ b/mail/mutt14/files/patch-01
@@ -1,17 +1,45 @@
---- Makefile.in.orig Mon Jan 27 18:15:59 1997
-+++ Makefile.in Wed Jan 29 07:23:40 1997
-@@ -72,10 +72,13 @@
- sendlib.c \
- url.c
-
--all: mutt
-+all: mutt docs
-
- mutt: $(OBJS) $(REGEX)
- $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
-+
-+docs:
-+ cd doc && make fbsd
-
- install: mutt
- $(srcdir)/mkinstalldirs $(bindir)
+*** Makefile.in.orig Sat May 17 03:05:18 1997
+--- Makefile.in Mon May 19 15:41:18 1997
+***************
+*** 34,40 ****
+ XCPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@
+ CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
+ LDFLAGS=@LDFLAGS@
+! LIBS=@LIBS@
+ REGEX=@REGEX@
+ OBJS= addrbook.o alias.o attach.o bind.o browser.o buffy.o color.o \
+ commands.o \
+--- 34,40 ----
+ XCPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@
+ CFLAGS=@CFLAGS@ -DSHAREDIR=\"$(sharedir)\" $(XCPPFLAGS)
+ LDFLAGS=@LDFLAGS@
+! LIBS=@LIBS@ -lmytinfo
+ REGEX=@REGEX@
+ OBJS= addrbook.o alias.o attach.o bind.o browser.o buffy.o color.o \
+ commands.o \
+***************
+*** 52,61 ****
+ EXCLUDE=config.h config.cache config.log config.status tags Makefile \
+ rx/Makefile
+
+! all: mutt
+
+ mutt: $(OBJS) $(REGEX)
+ $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
+
+ install: mutt
+ $(srcdir)/mkinstalldirs $(bindir)
+--- 52,64 ----
+ EXCLUDE=config.h config.cache config.log config.status tags Makefile \
+ rx/Makefile
+
+! all: mutt docs
+
+ mutt: $(OBJS) $(REGEX)
+ $(CC) -o mutt $(OBJS) $(REGEX) $(LDFLAGS) $(LIBS)
++
++ docs:
++ cd doc && make fbsd
+
+ install: mutt
+ $(srcdir)/mkinstalldirs $(bindir)