aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-02 01:02:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-06-02 01:02:27 +0000
commit68338952426e0d4e3b373e7fd926682d66dbc8b0 (patch)
treef6db1812124b28755eee5f9cbb35f0b80adc0747 /mail
parentf86b91b75666673cabb027a2365747ecde61bd85 (diff)
downloadports-68338952426e0d4e3b373e7fd926682d66dbc8b0.tar.gz
ports-68338952426e0d4e3b373e7fd926682d66dbc8b0.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/evolution-exchange/Makefile35
-rw-r--r--mail/evolution-exchange/distinfo2
-rw-r--r--mail/evolution-exchange/files/patch-configure11
-rw-r--r--mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c13
-rw-r--r--mail/evolution-exchange/files/patch-ltmain.sh51
-rw-r--r--mail/evolution-exchange/pkg-descr13
-rw-r--r--mail/evolution-exchange/pkg-plist23
-rw-r--r--mail/ximian-connector/Makefile35
-rw-r--r--mail/ximian-connector/distinfo2
-rw-r--r--mail/ximian-connector/files/patch-configure11
-rw-r--r--mail/ximian-connector/files/patch-lib::e2k-autoconfig.c13
-rw-r--r--mail/ximian-connector/files/patch-ltmain.sh51
-rw-r--r--mail/ximian-connector/pkg-descr13
-rw-r--r--mail/ximian-connector/pkg-plist23
15 files changed, 297 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index bf284bf54841..eec5a654599e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -431,6 +431,7 @@
SUBDIR += xbuffy
SUBDIR += xc-mail
SUBDIR += xfmail
+ SUBDIR += ximian-connector
SUBDIR += xlbiff
SUBDIR += xmail
SUBDIR += xmailbox
diff --git a/mail/evolution-exchange/Makefile b/mail/evolution-exchange/Makefile
new file mode 100644
index 000000000000..25deecad6486
--- /dev/null
+++ b/mail/evolution-exchange/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ximian-connector
+# Date created: 30 May 2004
+# Whom: kiesel
+#
+# $FreeBSD$
+#
+
+PORTNAME= ximian
+PORTVERSION= 1.4.7.1
+CATEGORIES= mail gnome
+MASTER_SITES= http://ftp.ximian.com/pub/source/evolution/
+PKGNAMESUFFIX= -connector
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= kiesel@schlund.de
+COMMENT= Evolution plugin to connect to Microsoft Exchange servers
+
+BUILD_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WANT_OPENLDAP_VER= 21
+WANT_OPENLDAP_SASL= yes
+USE_GNOME= gnomeprefix gnomehack gnometarget
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-openldap=${LOCALBASE} \
+ --with-static-ldap=no
+
+EVO_VERSION= 1.4
+PLIST_SUB= VERSION="1.4" EVO_VERSION=${EVO_VERSION}
+
+.include <bsd.port.mk>
diff --git a/mail/evolution-exchange/distinfo b/mail/evolution-exchange/distinfo
new file mode 100644
index 000000000000..ff3a864f146c
--- /dev/null
+++ b/mail/evolution-exchange/distinfo
@@ -0,0 +1,2 @@
+MD5 (ximian-connector-1.4.7.1.tar.gz) = fad20b3b50161a99f1e36b704590e600
+SIZE (ximian-connector-1.4.7.1.tar.gz) = 898976
diff --git a/mail/evolution-exchange/files/patch-configure b/mail/evolution-exchange/files/patch-configure
new file mode 100644
index 000000000000..b2b64b88e985
--- /dev/null
+++ b/mail/evolution-exchange/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jun 1 20:52:34 2004
++++ configure Tue Jun 1 20:52:55 2004
+@@ -22992,7 +22992,7 @@
+
+ case $with_static_ldap in
+ no|"")
+- if test -f $with_openldap/lib/libldap.la; then
++ if test -f $with_openldap/lib/libldap.so; then
+ with_static_ldap=no
+ else
+ with_static_ldap=yes
diff --git a/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c b/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c
new file mode 100644
index 000000000000..d5806c41d0c5
--- /dev/null
+++ b/mail/evolution-exchange/files/patch-lib::e2k-autoconfig.c
@@ -0,0 +1,13 @@
+--- lib/e2k-autoconfig.c.orig Tue May 11 11:09:03 2004
++++ lib/e2k-autoconfig.c Tue Jun 1 20:47:50 2004
+@@ -25,6 +25,10 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <resolv.h>
+ #include <arpa/nameser.h>
+
diff --git a/mail/evolution-exchange/files/patch-ltmain.sh b/mail/evolution-exchange/files/patch-ltmain.sh
new file mode 100644
index 000000000000..263a5ce21d00
--- /dev/null
+++ b/mail/evolution-exchange/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Mon Apr 5 19:24:18 2004
++++ ltmain.sh Tue Jun 1 20:45:09 2004
+@@ -1346,7 +1346,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1361,8 +1361,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3056,6 +3064,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5528,10 +5539,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/mail/evolution-exchange/pkg-descr b/mail/evolution-exchange/pkg-descr
new file mode 100644
index 000000000000..c89d7aba86dd
--- /dev/null
+++ b/mail/evolution-exchange/pkg-descr
@@ -0,0 +1,13 @@
+Ximian Connector is a plugin for Evolution that adds Exchange client
+capabilities to Evolution.
+
+With the Evolution Connector installed, Evolution functions as an
+Exchange client, enabling users to become full participants in company-wide
+group scheduling and other collaborative tasks. Linux, Solaris and FreeBSD
+users can access public folders, Global Address Lists, email, calendar,
+task lists, and group scheduling information.
+
+WWW: http://www.novell.com/products/connector/
+
+- Alex Kiesel
+kiesel@schlund.de
diff --git a/mail/evolution-exchange/pkg-plist b/mail/evolution-exchange/pkg-plist
new file mode 100644
index 000000000000..4d9afd021282
--- /dev/null
+++ b/mail/evolution-exchange/pkg-plist
@@ -0,0 +1,23 @@
+bin/ximian-connector-setup
+etc/gconf/gconf.xml.defaults/apps/evolution/exchange/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/evolution/exchange/%gconf.xml
+etc/gconf/schemas/apps_evolution_exchange.schemas
+lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.so
+lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.urls
+libdata/bonobo/servers/GNOME_Evolution_Exchange_Storage.server
+libexec/evolution/%%EVO_VERSION%%/evolution-exchange-storage
+share/gnome/evolution/%%EVO_VERSION%%/images/connector.png
+share/gnome/evolution/%%EVO_VERSION%%/images/exchange-delegates-48.png
+share/gnome/evolution/%%EVO_VERSION%%/images/exchange-oof-48.png
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-autoconfig-wizard.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-delegates.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-oof.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-permissions-dialog.glade
+share/gnome/ximian-connector/%%VERSION%%/images/connector.png
+share/locale/de/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+@dirrm share/gnome/ximian-connector/%%VERSION%%/images
+@dirrm share/gnome/ximian-connector/%%VERSION%%/glade
+@dirrm share/gnome/ximian-connector/%%VERSION%%
+@dirrm share/gnome/ximian-connector
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/evolution/exchange
+@dirrm etc/gconf/gconf.xml.defaults/apps/evolution/exchange
diff --git a/mail/ximian-connector/Makefile b/mail/ximian-connector/Makefile
new file mode 100644
index 000000000000..25deecad6486
--- /dev/null
+++ b/mail/ximian-connector/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ximian-connector
+# Date created: 30 May 2004
+# Whom: kiesel
+#
+# $FreeBSD$
+#
+
+PORTNAME= ximian
+PORTVERSION= 1.4.7.1
+CATEGORIES= mail gnome
+MASTER_SITES= http://ftp.ximian.com/pub/source/evolution/
+PKGNAMESUFFIX= -connector
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= kiesel@schlund.de
+COMMENT= Evolution plugin to connect to Microsoft Exchange servers
+
+BUILD_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+RUN_DEPENDS= evolution-${EVO_VERSION}:${PORTSDIR}/mail/evolution
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WANT_OPENLDAP_VER= 21
+WANT_OPENLDAP_SASL= yes
+USE_GNOME= gnomeprefix gnomehack gnometarget
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-openldap=${LOCALBASE} \
+ --with-static-ldap=no
+
+EVO_VERSION= 1.4
+PLIST_SUB= VERSION="1.4" EVO_VERSION=${EVO_VERSION}
+
+.include <bsd.port.mk>
diff --git a/mail/ximian-connector/distinfo b/mail/ximian-connector/distinfo
new file mode 100644
index 000000000000..ff3a864f146c
--- /dev/null
+++ b/mail/ximian-connector/distinfo
@@ -0,0 +1,2 @@
+MD5 (ximian-connector-1.4.7.1.tar.gz) = fad20b3b50161a99f1e36b704590e600
+SIZE (ximian-connector-1.4.7.1.tar.gz) = 898976
diff --git a/mail/ximian-connector/files/patch-configure b/mail/ximian-connector/files/patch-configure
new file mode 100644
index 000000000000..b2b64b88e985
--- /dev/null
+++ b/mail/ximian-connector/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jun 1 20:52:34 2004
++++ configure Tue Jun 1 20:52:55 2004
+@@ -22992,7 +22992,7 @@
+
+ case $with_static_ldap in
+ no|"")
+- if test -f $with_openldap/lib/libldap.la; then
++ if test -f $with_openldap/lib/libldap.so; then
+ with_static_ldap=no
+ else
+ with_static_ldap=yes
diff --git a/mail/ximian-connector/files/patch-lib::e2k-autoconfig.c b/mail/ximian-connector/files/patch-lib::e2k-autoconfig.c
new file mode 100644
index 000000000000..d5806c41d0c5
--- /dev/null
+++ b/mail/ximian-connector/files/patch-lib::e2k-autoconfig.c
@@ -0,0 +1,13 @@
+--- lib/e2k-autoconfig.c.orig Tue May 11 11:09:03 2004
++++ lib/e2k-autoconfig.c Tue Jun 1 20:47:50 2004
+@@ -25,6 +25,10 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <resolv.h>
+ #include <arpa/nameser.h>
+
diff --git a/mail/ximian-connector/files/patch-ltmain.sh b/mail/ximian-connector/files/patch-ltmain.sh
new file mode 100644
index 000000000000..263a5ce21d00
--- /dev/null
+++ b/mail/ximian-connector/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Mon Apr 5 19:24:18 2004
++++ ltmain.sh Tue Jun 1 20:45:09 2004
+@@ -1346,7 +1346,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1361,8 +1361,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3056,6 +3064,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5528,10 +5539,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/mail/ximian-connector/pkg-descr b/mail/ximian-connector/pkg-descr
new file mode 100644
index 000000000000..c89d7aba86dd
--- /dev/null
+++ b/mail/ximian-connector/pkg-descr
@@ -0,0 +1,13 @@
+Ximian Connector is a plugin for Evolution that adds Exchange client
+capabilities to Evolution.
+
+With the Evolution Connector installed, Evolution functions as an
+Exchange client, enabling users to become full participants in company-wide
+group scheduling and other collaborative tasks. Linux, Solaris and FreeBSD
+users can access public folders, Global Address Lists, email, calendar,
+task lists, and group scheduling information.
+
+WWW: http://www.novell.com/products/connector/
+
+- Alex Kiesel
+kiesel@schlund.de
diff --git a/mail/ximian-connector/pkg-plist b/mail/ximian-connector/pkg-plist
new file mode 100644
index 000000000000..4d9afd021282
--- /dev/null
+++ b/mail/ximian-connector/pkg-plist
@@ -0,0 +1,23 @@
+bin/ximian-connector-setup
+etc/gconf/gconf.xml.defaults/apps/evolution/exchange/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/evolution/exchange/%gconf.xml
+etc/gconf/schemas/apps_evolution_exchange.schemas
+lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.so
+lib/evolution/%%EVO_VERSION%%/camel-providers/libcamelexchange.urls
+libdata/bonobo/servers/GNOME_Evolution_Exchange_Storage.server
+libexec/evolution/%%EVO_VERSION%%/evolution-exchange-storage
+share/gnome/evolution/%%EVO_VERSION%%/images/connector.png
+share/gnome/evolution/%%EVO_VERSION%%/images/exchange-delegates-48.png
+share/gnome/evolution/%%EVO_VERSION%%/images/exchange-oof-48.png
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-autoconfig-wizard.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-delegates.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-oof.glade
+share/gnome/ximian-connector/%%VERSION%%/glade/exchange-permissions-dialog.glade
+share/gnome/ximian-connector/%%VERSION%%/images/connector.png
+share/locale/de/LC_MESSAGES/ximian-connector-%%VERSION%%.mo
+@dirrm share/gnome/ximian-connector/%%VERSION%%/images
+@dirrm share/gnome/ximian-connector/%%VERSION%%/glade
+@dirrm share/gnome/ximian-connector/%%VERSION%%
+@dirrm share/gnome/ximian-connector
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/evolution/exchange
+@dirrm etc/gconf/gconf.xml.defaults/apps/evolution/exchange