aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2011-10-07 06:50:00 +0000
committerAlex Dupre <ale@FreeBSD.org>2011-10-07 06:50:00 +0000
commit6fa216e657751da8c97fe3ac2a09f30103cfa8e5 (patch)
treea6800afda808aed4ca52a98a90f5d7eb258c1cc1 /mail
parentbd596633b7ca376bd4785a8e87b5a1905c6e6c59 (diff)
downloadports-6fa216e657751da8c97fe3ac2a09f30103cfa8e5.tar.gz
ports-6fa216e657751da8c97fe3ac2a09f30103cfa8e5.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/roundcube/Makefile3
-rw-r--r--mail/roundcube/files/patch-program_include_rcube_session.php35
2 files changed, 18 insertions, 20 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index 1526ae52b9be..f53edb986523 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -7,6 +7,7 @@
PORTNAME= roundcube
DISTVERSION= 0.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= mail www
MASTER_SITES= SF/${PORTNAME}mail/${PORTNAME}mail/${DISTVERSION:U}
@@ -18,8 +19,6 @@ COMMENT= Fully skinnable XHTML/CSS webmail written in PHP
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE= doesn't work, a fix will be committed tomorrow
-
NO_BUILD= yes
CONFLICTS= ja-roundcube-[0-9]*
diff --git a/mail/roundcube/files/patch-program_include_rcube_session.php b/mail/roundcube/files/patch-program_include_rcube_session.php
index 4a5b05807e56..3393c95653c2 100644
--- a/mail/roundcube/files/patch-program_include_rcube_session.php
+++ b/mail/roundcube/files/patch-program_include_rcube_session.php
@@ -1,5 +1,5 @@
---- program/include/rcube_session.php.orig 2011-09-21 14:22:40.000000000 +0200
-+++ program/include/rcube_session.php 2011-10-04 18:06:20.000000000 +0200
+--- program/include/rcube_session.php.orig 2011-10-07 08:21:40.000000000 +0200
++++ program/include/rcube_session.php 2011-10-07 08:28:55.000000000 +0200
@@ -33,7 +33,6 @@
private $ip;
private $start;
@@ -17,24 +17,23 @@
$this->key = $key;
if (!empty($this->vars))
-@@ -169,15 +168,7 @@
+@@ -169,13 +168,13 @@
}
if ($oldvars !== false) {
- $newvars = $this->_fixvars($vars, $oldvars);
--
-- if ($newvars !== $oldvars) {
-- $this->db->query(
-- sprintf("UPDATE %s SET vars=?, changed=%s WHERE sess_id=?",
-- get_table_name('session'), $now),
++ $newvars = $vars;
+
+ if ($newvars !== $oldvars) {
+ $this->db->query(
+ sprintf("UPDATE %s SET vars=?, changed=%s WHERE sess_id=?",
+ get_table_name('session'), $now),
- base64_encode($newvars), $key);
-- }
-- else if ($ts - $this->changed > $this->lifetime / 2) {
-+ if ($ts - $this->changed > $this->lifetime / 2) {
- $this->db->query("UPDATE ".get_table_name('session')." SET changed=$now WHERE sess_id=?", $key);
++ $newvars, $key);
}
- }
-@@ -186,7 +177,7 @@
+ else if ($ts - $this->changed > $this->lifetime / 2) {
+ $this->db->query("UPDATE ".get_table_name('session')." SET changed=$now WHERE sess_id=?", $key);
+@@ -186,7 +185,7 @@
sprintf("INSERT INTO %s (sess_id, vars, ip, created, changed) ".
"VALUES (?, ?, ?, %s, %s)",
get_table_name('session'), $now, $now),
@@ -43,7 +42,7 @@
}
return true;
-@@ -194,29 +185,6 @@
+@@ -194,29 +193,6 @@
/**
@@ -73,16 +72,16 @@
* Handler for session_destroy()
*
* @param string Session ID
-@@ -295,7 +263,7 @@
+@@ -295,7 +271,7 @@
else // else read data again
$oldvars = $this->mc_read($key);
- $newvars = $oldvars !== false ? $this->_fixvars($vars, $oldvars) : $vars;
-+ $newvars = $oldvars !== false ? $oldvars : $vars;
++ $newvars = $vars;
if ($newvars !== $oldvars || $ts - $this->changed > $this->lifetime / 2) {
$value = serialize(array('changed' => time(), 'ip' => $this->ip, 'vars' => $newvars));
-@@ -386,7 +354,6 @@
+@@ -386,7 +362,6 @@
if (empty($var))
return $this->destroy(session_id());