aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2004-06-04 14:25:10 +0000
committerAnders Nordby <anders@FreeBSD.org>2004-06-04 14:25:10 +0000
commitadfcae54db273889a8043c9ae6abd95fdcba5f32 (patch)
tree15d8adae78313fe6b56355f6e7949e90e3b05c55 /mail
parentf6070309f24dc92f43f8115e25901b66e4072144 (diff)
downloadports-adfcae54db273889a8043c9ae6abd95fdcba5f32.tar.gz
ports-adfcae54db273889a8043c9ae6abd95fdcba5f32.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/imap-uw/Makefile10
-rw-r--r--mail/imap-uw/distinfo4
-rw-r--r--mail/imap-uw/files/patch-ab29
-rw-r--r--mail/imap-uw/files/patch-ah12
-rw-r--r--mail/imap-uw/files/patch-ai12
-rw-r--r--mail/imap-uw/pkg-plist54
6 files changed, 91 insertions, 30 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 2c5d8b9e023e..4d0797a8c02c 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= imap
-PORTVERSION= 2002d
+PORTVERSION= 2004
PORTEPOCH= 1
-CATEGORIES= mail
+CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
ftp://ftp.nuug.no/pub/anders/distfiles/%SUBDIR%/ \
http://atreides.freenix.no/~anders/%SUBDIR%/ \
@@ -26,6 +26,7 @@ LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
WRKSRC= ${WRKDIR}/${DISTNAME}
MAN1= dmail.1 mailutil.1 tmail.1
@@ -102,6 +103,11 @@ post-install:
@${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
@${ECHO} "================================================================================"
.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} -m 0755 -p ${DOCSDIR}
+ @${TAR} -C ${WRKSRC}/docs -cf - . | \
+ (umask 022; ${TAR} -C ${DOCSDIR} -xf -)
+.endif
cert:
@${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/certs
diff --git a/mail/imap-uw/distinfo b/mail/imap-uw/distinfo
index 4f6aa823f145..7b718609f479 100644
--- a/mail/imap-uw/distinfo
+++ b/mail/imap-uw/distinfo
@@ -1,2 +1,2 @@
-MD5 (imap-2002d.tar.Z) = 64e82a195d21481fc4c54c4ed9fe0527
-SIZE (imap-2002d.tar.Z) = 2155224
+MD5 (imap-2004.tar.Z) = ec3dafeeae320457a1d098157e9bf969
+SIZE (imap-2004.tar.Z) = 2220333
diff --git a/mail/imap-uw/files/patch-ab b/mail/imap-uw/files/patch-ab
index 43d26fb58aef..6de8fc321668 100644
--- a/mail/imap-uw/files/patch-ab
+++ b/mail/imap-uw/files/patch-ab
@@ -1,15 +1,16 @@
---- src/osdep/unix/Makefile.orig Wed Apr 11 00:02:06 2001
-+++ src/osdep/unix/Makefile Sat Apr 14 03:20:57 2001
-@@ -28,12 +28,12 @@
+--- src/osdep/unix/Makefile.orig Fri Apr 30 02:08:48 2004
++++ src/osdep/unix/Makefile Fri Jun 4 07:34:19 2004
+@@ -29,13 +29,13 @@
# Extended flags needed for SSL. You may need to modify.
-SSLDIR=/usr/local/ssl
-SSLCERTS=$(SSLDIR)/certs
--SSLINCLUDE=$(SSLDIR)/include
--SSLLIB=$(SSLDIR)/lib
+SSLDIR=$(OPENSSLBASE)
+SSLCERTS=$(PREFIX)/certs
+ SSLKEYS=$(SSLCERTS)
+-SSLINCLUDE=$(SSLDIR)/include
+-SSLLIB=$(SSLDIR)/lib
+SSLINCLUDE=$(OPENSSLINC)
+SSLLIB=$(OPENSSLLIB)
@@ -18,16 +19,16 @@
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
# to use this instead
-@@ -46,7 +46,7 @@
+@@ -48,7 +48,7 @@
SSLCFLAGS= -I$(SSLINCLUDE) -I$(SSLINCLUDE)/openssl\
- -DSSL_CERT_DIRECTORY=\"$(SSLCERTS)\"
+ -DSSL_CERT_DIRECTORY=\"$(SSLCERTS)\" -DSSL_KEY_DIRECTORY=\"$(SSLKEYS)\"
-SSLLDFLAGS= -L$(SSLLIB) -lssl $(SSLCRYPTO) $(SSLRSA)
+SSLLDFLAGS= # -L$(SSLLIB) -lssl $(SSLCRYPTO) $(SSLRSA)
# Extended flags needed for non-standard passwd types. You may need to modify.
-@@ -60,7 +60,7 @@
+@@ -62,7 +62,7 @@
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
DCELDFLAGS= -ldce
@@ -36,7 +37,7 @@
# Build parameters normally set by the individual port
-@@ -97,7 +97,7 @@
+@@ -99,7 +99,7 @@
# Commands possibly overriden by the individual port
ARRC=ar rc
@@ -45,16 +46,16 @@
LN=ln -s
RANLIB=ranlib
-@@ -115,7 +115,7 @@
+@@ -117,7 +117,7 @@
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
- unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
+ unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
-CFLAGS=-g
+CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
CAT=cat
MAKE=make
-@@ -198,6 +198,15 @@
+@@ -200,6 +200,15 @@
BASECFLAGS="-g -B/usr/lib/big/ -Dvoid=char -Dconst=" \
RANLIB=true ARRC="ar -rc"
@@ -70,7 +71,7 @@
bs3: # BSD/i386 3.0 or higher
$(BUILD) `$(CAT) SPECIALS` OS=bsi \
CHECKPW=bsi LOGINPW=bsi CRXTYPE=nfs \
-@@ -217,8 +226,9 @@
+@@ -219,8 +228,9 @@
SPOOLDIR=/var \
ACTIVEFILE=/usr/local/news/lib/active \
RSHPATH=/usr/bin/rsh \
@@ -82,7 +83,7 @@
bsi: # BSD/i386
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
-@@ -764,7 +774,7 @@
+@@ -788,7 +798,7 @@
build: clean once $(ARCHIVE)
diff --git a/mail/imap-uw/files/patch-ah b/mail/imap-uw/files/patch-ah
index e51bdbc222bd..c307a9d0c75f 100644
--- a/mail/imap-uw/files/patch-ah
+++ b/mail/imap-uw/files/patch-ah
@@ -1,5 +1,5 @@
---- src/ipopd/ipop3d.c.orig Fri Jan 17 18:17:58 2003
-+++ src/ipopd/ipop3d.c Mon Jun 2 02:47:10 2003
+--- src/ipopd/ipop3d.c.orig Tue Apr 27 21:50:29 2004
++++ src/ipopd/ipop3d.c Fri Jun 4 07:47:10 2004
@@ -28,6 +28,11 @@
#include <time.h>
#include "c-client.h"
@@ -22,7 +22,7 @@
+extern char *getenv ();
+#endif /* DRAC_AUTH */
+
- char *version = "2003.83"; /* server version */
+ char *version = "2004.87"; /* server version */
short state = AUTHORIZATION; /* server state */
short critical = NIL; /* non-zero if in critical code */
@@ -88,7 +99,53 @@
@@ -89,7 +89,7 @@
#include "linkage.c"
/* initialize server */
server_init (pgmname,"pop3","pop3s",clkint,kodint,hupint,trmint);
-@@ -209,9 +266,13 @@
+@@ -201,9 +258,13 @@
syslog (LOG_INFO,"AUTHENTICATE %s failure host=%.80s",s,
tcp_clienthost ());
}
@@ -104,7 +104,7 @@
else syslog (LOG_INFO,"Auth user=%.80s host=%.80s no mailbox",
user,tcp_clienthost ());
}
-@@ -248,9 +309,13 @@
+@@ -231,9 +292,13 @@
PSOUT ("-ERR Missing APOP argument\015\012");
else if (!(user = apop_login (challenge,s,t,argc,argv)))
PSOUT ("-ERR Bad APOP\015\012");
@@ -119,7 +119,7 @@
else syslog (LOG_INFO,"APOP user=%.80s host=%.80s no mailbox",
user,tcp_clienthost ());
}
-@@ -580,6 +645,9 @@
+@@ -564,6 +629,9 @@
/* attempt the login */
if (server_login (user,pass,t,argc,argv)) {
int ret = mbxopen ("INBOX");
diff --git a/mail/imap-uw/files/patch-ai b/mail/imap-uw/files/patch-ai
index 4fe49c32a757..73afa6495244 100644
--- a/mail/imap-uw/files/patch-ai
+++ b/mail/imap-uw/files/patch-ai
@@ -1,5 +1,5 @@
---- src/imapd/imapd.c.orig Thu Apr 3 00:09:25 2003
-+++ src/imapd/imapd.c Mon May 19 22:20:56 2003
+--- src/imapd/imapd.c.orig Tue Apr 27 21:48:26 2004
++++ src/imapd/imapd.c Fri Jun 4 07:49:07 2004
@@ -29,6 +29,11 @@
#include "c-client.h"
#include <sys/stat.h>
@@ -12,7 +12,7 @@
#define CRLF PSOUT ("\015\012") /* primary output terpri */
-@@ -178,6 +183,12 @@
+@@ -183,6 +188,12 @@
/* Global storage */
@@ -22,10 +22,10 @@
+extern char *getenv ();
+#endif /* DRAC_AUTH */
+
- char *version = "2003.338"; /* version number of this server */
+ char *version = "2004.350"; /* version number of this server */
time_t alerttime = 0; /* time of last alert */
time_t sysalerttime = 0; /* time of last system alert */
-@@ -238,7 +249,50 @@
+@@ -245,7 +256,50 @@
msg_string_next, /* get next byte in string structure */
msg_string_setpos /* set position in string structure */
};
@@ -77,7 +77,7 @@
/* Main program */
int main (int argc,char *argv[])
-@@ -1189,6 +1243,9 @@
+@@ -1227,6 +1281,9 @@
lasterror ());
return;
}
diff --git a/mail/imap-uw/pkg-plist b/mail/imap-uw/pkg-plist
index d81fc55cea24..3c2bc4812eb5 100644
--- a/mail/imap-uw/pkg-plist
+++ b/mail/imap-uw/pkg-plist
@@ -6,3 +6,57 @@ libexec/imapd
libexec/ipop2d
libexec/ipop3d
libexec/mlock
+%%PORTDOCS%%%%DOCSDIR%%/BUILD
+%%PORTDOCS%%%%DOCSDIR%%/CONFIG
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/IPv6.txt
+%%PORTDOCS%%%%DOCSDIR%%/RELNOTES
+%%PORTDOCS%%%%DOCSDIR%%/SSLBUILD
+%%PORTDOCS%%%%DOCSDIR%%/Y2K
+%%PORTDOCS%%%%DOCSDIR%%/bugs.txt
+%%PORTDOCS%%%%DOCSDIR%%/calendar.txt
+%%PORTDOCS%%%%DOCSDIR%%/commndmt.txt
+%%PORTDOCS%%%%DOCSDIR%%/draft/README
+%%PORTDOCS%%%%DOCSDIR%%/draft/compare.txt
+%%PORTDOCS%%%%DOCSDIR%%/draft/i18n.txt
+%%PORTDOCS%%%%DOCSDIR%%/draft/sort.txt
+%%PORTDOCS%%%%DOCSDIR%%/drivers.txt
+%%PORTDOCS%%%%DOCSDIR%%/formats.txt
+%%PORTDOCS%%%%DOCSDIR%%/imaprc.txt
+%%PORTDOCS%%%%DOCSDIR%%/internal.txt
+%%PORTDOCS%%%%DOCSDIR%%/locking.txt
+%%PORTDOCS%%%%DOCSDIR%%/md5.txt
+%%PORTDOCS%%%%DOCSDIR%%/naming.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc1731.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc1732.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc1733.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2061.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2062.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2086.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2087.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2088.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2177.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2180.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2192.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2193.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2195.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2221.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2222.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2234.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2245.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2342.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2359.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2595.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2683.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc2971.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3348.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3501.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3502.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3503.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3516.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3656.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc/rfc3691.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/draft
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/rfc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%