aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-01 16:04:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-01 16:04:13 +0000
commite89671740cb5570597de7cd008ff57f650aa68ed (patch)
tree4a1df7e8e60a8e55f7b379cab79657a369337c46 /mail
parentaeedf5fbdbbdf4b244a0cc0d181ffed7328a33c6 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/dovecot2/Makefile57
-rw-r--r--mail/dovecot2/pkg-descr14
2 files changed, 41 insertions, 30 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 3e31217033d0..89a333e7e853 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -3,12 +3,13 @@
PORTNAME= dovecot
PORTVERSION= 2.2.13
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
MAINTAINER= adamw@FreeBSD.org
-COMMENT= Secure and compact IMAP and POP3 servers
+COMMENT= Secure, fast and powerful IMAP and POP3 server
LICENSE= LGPL21 MIT
LICENSE_COMB= dual
@@ -43,12 +44,11 @@ INSTALL_TARGET= install-strip
USERS= dovecot dovenull
GROUPS= ${USERS}
-# Default requirement for dovecot rc script
-_REQUIRE= LOGIN
-
-OPTIONS_DEFINE= KQUEUE SSL GSSAPI VPOPMAIL LDAP LUCENE PGSQL MYSQL SQLITE \
+OPTIONS_DEFINE= KQUEUE SSL VPOPMAIL LDAP LUCENE PGSQL MYSQL SQLITE \
SOLR DOCS EXAMPLES LIBWRAP
-OPTIONS_DEFAULT=KQUEUE SSL
+OPTIONS_SINGLE= GSSAPI
+OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+OPTIONS_DEFAULT=KQUEUE SSL GSSAPI_NONE
OPTIONS_SUB= yes
KQUEUE_DESC= kqueue(2) support
@@ -56,37 +56,49 @@ VPOPMAIL_DESC= vpopmail support
LUCENE_DESC= CLucene FTS support
SOLR_DESC= Solr FTS support
+GSSAPI_NONE_DESC= Build without GSSAPI support
+GSSAPI_BASE_DESC= Use GSSAPI from base
+GSSAPI_HEIMDAL_DESC= Use Heimdal GSSAPI from security/heimdal
+GSSAPI_MIT_DESC= Use MIT GSSAPI from security/krb5
+
DOCS_CONFIGURE_WITH= docs
-GSSAPI_CONFIGURE_WITH= gssapi
-GSSAPI_LDFLAGS= -lgssapi_krb5
+GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
+GSSAPI_BASE_USES= gssapi
+GSSAPI_BASE_CONFIGURE_ON= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_HEIMDAL_CONFIGURE_ON= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_MIT_USES= gssapi:mit
+GSSAPI_MIT_CONFIGURE_ON= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
KQUEUE_CONFIGURE_OFF= --with-ioloop=poll
KQUEUE_CONFIGURE_ON= --with-ioloop=kqueue
-LDAP_CONFIGURE_WITH= ldap
LDAP_USE= OPENLDAP=yes
+LDAP_CONFIGURE_WITH= ldap
+LDAP_RC_REQUIRE= slapd
LIBWRAP_CONFIGURE_WITH= libwrap
LUCENE_CONFIGURE_WITH= lucene
LUCENE_LIB_DEPENDS= libclucene-core.so:${PORTSDIR}/textproc/clucene
-MYSQL_CONFIGURE_WITH= mysql
MYSQL_USE= MYSQL=yes
+MYSQL_CONFIGURE_WITH= mysql
+MYSQL_RC_REQUIRE= mysql
-PGSQL_CONFIGURE_WITH= pgsql
PGSQL_USE= PGSQL=yes
+PGSQL_CONFIGURE_WITH= pgsql
+PGSQL_RC_REQUIRE= postgresql
-SOLR_BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
SOLR_CONFIGURE_WITH= solr
+SOLR_BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
SOLR_LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-SQLITE_CONFIGURE_WITH= sqlite
SQLITE_USE= SQLITE=3
+SQLITE_CONFIGURE_WITH= sqlite
-SSL_CONFIGURE_OFF= --without-ssl
-SSL_CONFIGURE_ON= --with-ssl=openssl
+SSL_CONFIGURE_WITH= ssl=openssl
VPOPMAIL_BUILD_DEPENDS= ${LOCALBASE}/vpopmail/bin/vchkpw:${PORTSDIR}/mail/vpopmail
VPOPMAIL_CONFIGURE_WITH=vpopmail
@@ -101,17 +113,12 @@ PORTEXAMPLES= *
BROKEN= Does not build on arm
.endif
-.if ${PORT_OPTIONS:MLDAP}
-_REQUIRE+= slapd
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-_REQUIRE+= postgresql
-.endif
+# Default requirement for dovecot rc script
+_REQUIRE= LOGIN
-.if ${PORT_OPTIONS:MMYSQL}
-_REQUIRE+= mysql
-.endif
+.for opt in ${PORT_OPTIONS}
+_REQUIRE+= ${${opt}_RC_REQUIRE}
+.endfor
SUB_LIST+= REQUIRE="${_REQUIRE}"
SUB_FILES+= pkg-message
diff --git a/mail/dovecot2/pkg-descr b/mail/dovecot2/pkg-descr
index 48a277c6a21a..835233a35f71 100644
--- a/mail/dovecot2/pkg-descr
+++ b/mail/dovecot2/pkg-descr
@@ -1,7 +1,11 @@
-Dovecot is a secure and compact IMAP server which is in the early stages
-of development. It supports Maildirs and mbox formats and much of the
-IMAP v4 protocol including SSL/TLS. IPv6 support is also included.
-Dovecot supports authentication with OpenLDAP, PostgreSQL, MySQL, vpopmail
-and PAM.
+Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like
+systems, written with security primarily in mind. Dovecot is an excellent
+choice for both small and large installations. It's fast, simple to set up,
+requires no special administration and it uses very little memory.
+
+Dovecot is high-performing, self-optimizing, self-healing, and easily
+extensible. It includes IMAP4rev1 and POP3 support. IPv6, SSL and TLS are
+supported. It supports multiple commonly used IMAP extensions, including SORT,
+THREAD and IDLE.
WWW: http://www.dovecot.org/