aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-05 13:31:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-05 13:31:33 +0000
commitfa3dce7f14375921ce998259d912d882e25e3fb4 (patch)
tree0f30690b7e601f7a6dbe5b6bca382e2ea09d0599 /mail
parentccc4fa37c53720081b98746de698202bd59ad060 (diff)
downloadports-fa3dce7f14375921ce998259d912d882e25e3fb4.tar.gz
ports-fa3dce7f14375921ce998259d912d882e25e3fb4.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/msmtp-devel/Makefile49
-rw-r--r--mail/msmtp-devel/distinfo2
-rw-r--r--mail/msmtp-devel/pkg-descr5
4 files changed, 57 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index eec5a654599e..804921520aa1 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -196,6 +196,7 @@
SUBDIR += mreport
SUBDIR += msgconvert
SUBDIR += msmtp
+ SUBDIR += msmtp-devel
SUBDIR += mulberry
SUBDIR += mutt
SUBDIR += mutt-devel
diff --git a/mail/msmtp-devel/Makefile b/mail/msmtp-devel/Makefile
new file mode 100644
index 000000000000..c399b5dd3178
--- /dev/null
+++ b/mail/msmtp-devel/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: msmtp-devel
+# Date created: 2 June 2004
+# Whom: Roman Bogorodskiy
+#
+# $FreeBSD$
+#
+
+PORTNAME= msmtp
+PORTVERSION= 1.1.1
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= msmtp
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= The development version of SMTP plugin for MUAs
+
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG=yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAN1= msmtp.1
+PLIST_FILES= bin/msmtp
+
+CONFLICTS= msmtp-0.* \
+ msmtp-1.0.*
+
+.if !defined(WITH_OPENSSL)
+WITH_GNUTLS= yes
+.endif
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+.endif
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-ssl=openssl
+.endif
+
+.if defined(WITH_GNU_SASL)
+LIB_DEPENDS+= gsasl:${PORTSDIR}/security/gsasl
+.else
+CONFIGURE_ARGS+= --disable-gsasl
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/msmtp-devel/distinfo b/mail/msmtp-devel/distinfo
new file mode 100644
index 000000000000..451eaa7f0883
--- /dev/null
+++ b/mail/msmtp-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (msmtp-1.1.1.tar.gz) = 5ffb4f26c68760ffbaf7d37ff06d7abb
+SIZE (msmtp-1.1.1.tar.gz) = 147697
diff --git a/mail/msmtp-devel/pkg-descr b/mail/msmtp-devel/pkg-descr
new file mode 100644
index 000000000000..a2eb44e8e704
--- /dev/null
+++ b/mail/msmtp-devel/pkg-descr
@@ -0,0 +1,5 @@
+This is a development version of msmtp. Most of the code was rewritten or
+restructured, so it needs some testing. Some new features were also added:
+SMTP pipelining, the --serverinfo option, and the --from option.
+
+WWW: http://msmtp.sourceforge.net/