aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-12-07 07:54:44 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-12-07 07:54:44 +0000
commit64c8e5a93756dcf81b5d1b58f978cf743fba6ef4 (patch)
treec025ceac9a0c30398582468006b5e6750f5d8678 /mail
parent6a514bf3b2706f86482f8de7743617781af7efbf (diff)
downloadports-64c8e5a93756dcf81b5d1b58f978cf743fba6ef4.tar.gz
ports-64c8e5a93756dcf81b5d1b58f978cf743fba6ef4.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/php72-imap/Makefile1
-rw-r--r--mail/php72-imap/files/patch-php__imap.c40
-rw-r--r--mail/php72-imap/files/patch-php__imap.h10
3 files changed, 0 insertions, 51 deletions
diff --git a/mail/php72-imap/Makefile b/mail/php72-imap/Makefile
index 8391b4ca8c1d..0d9e7835f449 100644
--- a/mail/php72-imap/Makefile
+++ b/mail/php72-imap/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
CATEGORIES= mail
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php72
diff --git a/mail/php72-imap/files/patch-php__imap.c b/mail/php72-imap/files/patch-php__imap.c
deleted file mode 100644
index faa12adafa16..000000000000
--- a/mail/php72-imap/files/patch-php__imap.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- php_imap.c.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.c
-@@ -562,6 +562,15 @@ static const zend_module_dep imap_deps[]
- };
- /* }}} */
-
-+
-+/* {{{ PHP_INI
-+ */
-+PHP_INI_BEGIN()
-+STD_PHP_INI_BOOLEAN("imap.enable_insecure_rsh", "0", PHP_INI_SYSTEM, OnUpdateBool, enable_rsh, zend_imap_globals, imap_globals)
-+PHP_INI_END()
-+/* }}} */
-+
-+
- /* {{{ imap_module_entry
- */
- zend_module_entry imap_module_entry = {
-@@ -835,6 +844,8 @@ PHP_MINIT_FUNCTION(imap)
- {
- unsigned long sa_all = SA_MESSAGES | SA_RECENT | SA_UNSEEN | SA_UIDNEXT | SA_UIDVALIDITY;
-
-+ REGISTER_INI_ENTRIES();
-+
- #ifndef PHP_WIN32
- mail_link(&unixdriver); /* link in the unix driver */
- mail_link(&mhdriver); /* link in the mh driver */
-@@ -1052,6 +1063,12 @@ PHP_MINIT_FUNCTION(imap)
- GC_TEXTS texts
- */
-
-+ if (!IMAPG(enable_rsh)) {
-+ /* disable SSH and RSH, see https://bugs.php.net/bug.php?id=77153 */
-+ mail_parameters (NIL, SET_RSHTIMEOUT, 0);
-+ mail_parameters (NIL, SET_SSHTIMEOUT, 0);
-+ }
-+
- le_imap = zend_register_list_destructors_ex(mail_close_it, NULL, "imap", module_number);
- return SUCCESS;
- }
diff --git a/mail/php72-imap/files/patch-php__imap.h b/mail/php72-imap/files/patch-php__imap.h
deleted file mode 100644
index f27f888f2ee7..000000000000
--- a/mail/php72-imap/files/patch-php__imap.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- php_imap.h.orig 2018-09-11 22:12:36 UTC
-+++ php_imap.h
-@@ -214,6 +214,7 @@ ZEND_BEGIN_MODULE_GLOBALS(imap)
- #endif
- /* php_stream for php_mail_gets() */
- php_stream *gets_stream;
-+ zend_bool enable_rsh;
- ZEND_END_MODULE_GLOBALS(imap)
-
- #ifdef ZTS