aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-12-03 22:23:03 +0000
committerSteve Wills <swills@FreeBSD.org>2018-12-03 22:23:03 +0000
commit9f2ff2b76ef58a36d86cf0987e5b342b6588cb96 (patch)
treebaa79ed2d2459d68d1cb7184a4c745863d1d5eea /mail
parent8f5df7ffc74271c00710e1843a0bd12ce5b36067 (diff)
downloadports-9f2ff2b76ef58a36d86cf0987e5b342b6588cb96.tar.gz
ports-9f2ff2b76ef58a36d86cf0987e5b342b6588cb96.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt/Makefile40
-rw-r--r--mail/mutt/distinfo10
-rw-r--r--mail/mutt/files/extra-patch-ifdef46
-rw-r--r--mail/mutt/files/extra-patch-reverse_reply27
-rw-r--r--mail/mutt/files/extra-patch-smartdate10
-rw-r--r--mail/mutt/files/patch-Makefile.in6
-rw-r--r--mail/mutt/files/patch-contrib_Makefile.in5
-rw-r--r--mail/mutt/files/patch-date-conditional8
-rw-r--r--mail/mutt/files/patch-dgc-deepif4
-rw-r--r--mail/mutt/files/patch-doc_Makefile.in12
-rw-r--r--mail/mutt/files/patch-muttlib.c4
-rw-r--r--mail/mutt/files/patch-qresync-crash21
-rw-r--r--mail/mutt/files/patch-smime-sender10
-rw-r--r--mail/mutt/files/patch-threadcomplete10
-rw-r--r--mail/mutt/pkg-plist5
15 files changed, 117 insertions, 101 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 60fe8535eaab..87b964cb1878 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mutt
-DISTVERSION= 1.10.1
+DISTVERSION= 1.11.0
CATEGORIES+= mail ipv6
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
ftp://ftp.fu-berlin.de/pub/unix/mail/mutt/ \
@@ -18,12 +18,16 @@ PATCH_SITES+= http://www.mutt.org.ua/download/mutt-${VVV_PATCH_VERSION}/:vvv \
http://vc.org.ua/mutt/:vc
PATCH_DIST_STRIP= -p1
-MAINTAINER?= dereks@lifeofadishwasher.com
-COMMENT?= Small but powerful text based program for read/writing e-mail
+MAINTAINER= dereks@lifeofadishwasher.com
+COMMENT= Small but powerful text based program for read/writing e-mail
LICENSE= GPLv2+
-CONFLICTS?= ja-mutt-[0-9]* ja-mutt-devel-[0-9]* mutt-1.4* mutt-devel-lite-[0-9]* mutt-lite-[0-9]* zh-mutt-devel-[0-9]*
+RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:misc/mime-support
+
+USES= cpe shebangfix ssl
+
+CONFLICTS= ja-mutt-[0-9]* ja-mutt-devel-[0-9]* mutt-1.4* mutt-devel-lite-[0-9]* mutt-lite-[0-9]* zh-mutt-devel-[0-9]*
DOCSDIR?= ${PREFIX}/share/doc/mutt
EXAMPLESDIR?= ${PREFIX}/share/examples/mutt
@@ -34,7 +38,8 @@ CONFIGURE_ARGS= --disable-fcntl --with-ssl=${OPENSSLBASE} \
--enable-external-dotlock --enable-pop --enable-imap \
--enable-compressed --enable-sidebar
-USES+= cpe ncurses shebangfix ssl
+INFO= ${PORTNAME}
+
SHEBANG_FILES= doc/gen-map-doc smime_keys.pl contrib/smime_keys_test.pl
.if defined(MUTT_CONFIGURE_ARGS)
@@ -45,9 +50,6 @@ GNU_CONFIGURE= yes
OPTIONS_SUB= yes
-.if defined (MUTT_LITE)
-OPTIONS_EXCLUDE= NLS DOCS EXAMPLES
-.else
OPTIONS_DEFINE= SASL DEBUG DOCS EXAMPLES FLOCK \
FORCEBASE64 GPGME GREETING_PATCH HTML ICONV IDN IFDEF_PATCH \
LOCALES_FIX MAILBOX_MANPAGES MAILDIR_MTIME_PATCH \
@@ -93,28 +95,12 @@ OPTIONS_DEFAULT= GPGME HTML HCACHE_BDB ICONV IDN \
IFDEF_PATCH LOCALES_FIX MAILBOX_MANPAGES MAILDIR_MTIME_PATCH \
NLS NCURSES QUOTE_PATCH REVERSE_REPLY_PATCH SMART_DATE \
SMIME_OUTLOOK_COMPAT SASL SMTP URLVIEW XML GSSAPI_NONE
-.endif
-RUN_DEPENDS+= ${LOCALBASE}/etc/mime.types:misc/mime-support
-
-.if !defined (MUTT_LITE)
ASPELL_BUILD_DEPENDS= aspell:textproc/aspell
ASPELL_RUN_DEPENDS= aspell:textproc/aspell
ISPELL_BUILD_DEPENDS= ispell:textproc/aspell-ispell
ISPELL_RUN_DEPENDS= ispell:textproc/aspell-ispell
URLVIEW_RUN_DEPENDS= urlview:textproc/urlview
-.endif
-
-.if defined (MUTT_LITE)
-PKGNAMESUFFIX= -lite
-USES+= ncurses
-PLIST_SUB+= MAILBOX_MANPAGES=""
-PLIST_SUB+= HTML="@comment "
-PLIST_SUB+= NNTP="@comment "
-# XXX bug in bpm ?
-PLIST_SUB+= NLS="@comment "
-CONFIGURE_ARGS+= --disable-nls --disable-iconv --without-idn
-.endif
.ifmake makesum # for optional distfiles patchfiles
PORT_DBDIR= /dev/null
@@ -172,7 +158,8 @@ FLOCK_CONFIGURE_ENABLE= flock
LOCALES_FIX_CONFIGURE_ON= --enable-locales-fix
-IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
+IDN_LIB_DEPENDS= libidn2.so:dns/libidn2 \
+ libunistring.so:devel/libunistring
IDN_CONFIGURE_WITH= idn2
IDN_IMPLIES= ICONV
@@ -190,6 +177,7 @@ GREETING_PATCH_PATCHFILES= mutt-${GREETING_PATCH_VERSION}.vc.greeting:vc
QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.gz:vvv \
patch-${VVV_PATCH_VERSION}.vvv.quote.gz:vvv
+NNTP_BROKEN= NNTP 1.10.0 broken with mutt 1.11.0
NNTP_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.nntp.gz:-p1:vvv
NNTP_CONFIGURE_ON= --enable-nntp
NNTP_VARS= XML_NEEDED=yes
@@ -202,7 +190,7 @@ DOCS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-doc-ref
# un/comment as each VERSION is created for PORTVERSION
VVV_PATCH_VERSION= 1.10.0
-GREETING_PATCH_VERSION= 1.10.0
+#GREETING_PATCH_VERSION= 1.11.0
.if !defined(VVV_PATCH_VERSION)
VVV_PATCH_VERSION= ${PORTVERSION}
diff --git a/mail/mutt/distinfo b/mail/mutt/distinfo
index 06be97440110..a2100845a1f4 100644
--- a/mail/mutt/distinfo
+++ b/mail/mutt/distinfo
@@ -1,8 +1,8 @@
-TIMESTAMP = 1531761572
-SHA256 (mutt/mutt-1.10.1.tar.gz) = 734a3883158ec3d180cf6538d8bd7f685ce641d2cdef657aa0038f76e79a54a0
-SIZE (mutt/mutt-1.10.1.tar.gz) = 4255890
-SHA256 (mutt/mutt-1.10.0.vc.greeting) = e33b0659290cfbcff0055a5e3ec0762fed7eb76127e0c29cd00586d62cb92df8
-SIZE (mutt/mutt-1.10.0.vc.greeting) = 4560
+TIMESTAMP = 1543291077
+SHA256 (mutt/mutt-1.11.0.tar.gz) = 92c9261933809fed34d66469cb83c7f83bb29f721cd48d608c40cafd299c10e3
+SIZE (mutt/mutt-1.11.0.tar.gz) = 4568953
+SHA256 (mutt/mutt-1.11.0.vc.greeting) = 57bd75016350e3ab8516f27154016e23a29176d2f1163258d31531f4aa722afc
+SIZE (mutt/mutt-1.11.0.vc.greeting) = 4560
SHA256 (mutt/patch-1.10.0.vvv.nntp.gz) = 895c168f00cd073234c6cbb0d6972b5b390c64bf9ee5a13f58e0ea0652cabe4a
SIZE (mutt/patch-1.10.0.vvv.nntp.gz) = 60723
SHA256 (mutt/patch-1.10.0.vvv.initials.gz) = 7254751c439d4b138e89b47f71bd4e37c1c257130a8c88af91189fd8e4f249bb
diff --git a/mail/mutt/files/extra-patch-ifdef b/mail/mutt/files/extra-patch-ifdef
index deeceae31fb9..5bb33012e833 100644
--- a/mail/mutt/files/extra-patch-ifdef
+++ b/mail/mutt/files/extra-patch-ifdef
@@ -1,28 +1,12 @@
---- init.h.orig 2018-05-19 23:45:18 UTC
-+++ init.h
-@@ -4114,6 +4114,7 @@
- static int parse_unlists (BUFFER *, BUFFER *, unsigned long, BUFFER *);
- static int parse_alias (BUFFER *, BUFFER *, unsigned long, BUFFER *);
- static int parse_unalias (BUFFER *, BUFFER *, unsigned long, BUFFER *);
-+static int parse_ifdef (BUFFER *, BUFFER *, unsigned long, BUFFER *);
- static int parse_echo (BUFFER *, BUFFER *, unsigned long, BUFFER *);
- static int parse_ignore (BUFFER *, BUFFER *, unsigned long, BUFFER *);
- static int parse_unignore (BUFFER *, BUFFER *, unsigned long, BUFFER *);
-@@ -4178,6 +4178,7 @@
- { "hdr_order", parse_list, UL &HeaderOrderList },
- #ifdef HAVE_ICONV
- { "iconv-hook", mutt_parse_hook, MUTT_ICONVHOOK },
-+ { "ifdef", parse_ifdef, 0 },
- #endif
- { "ignore", parse_ignore, 0 },
- { "lists", parse_lists, 0 },
---- PATCHES.orig 2018-05-19 23:44:00 UTC
+--- PATCHES.orig 2018-11-29 22:49:51 UTC
+++ PATCHES
-@@ -0,0 +1 @@
+@@ -1,2 +1,3 @@
+patch-1.5.4.cd.ifdef.1
---- init.c.orig 2018-05-19 23:44:00 UTC
+ vvv.quote
+ vvv.initials
+--- init.c.orig 2018-11-24 19:06:11 UTC
+++ init.c
-@@ -650,6 +650,52 @@
+@@ -650,6 +650,52 @@ static mbchar_table *parse_mbchar_table
return t;
}
@@ -75,3 +59,21 @@
static int parse_unignore (BUFFER *buf, BUFFER *s, unsigned long data, BUFFER *err)
{
do
+--- init.h.orig 2018-11-29 22:49:51 UTC
++++ init.h
+@@ -4195,6 +4195,7 @@ static int parse_lists (BUFFER *, BUFFER
+ static int parse_unlists (BUFFER *, BUFFER *, unsigned long, BUFFER *);
+ static int parse_alias (BUFFER *, BUFFER *, unsigned long, BUFFER *);
+ static int parse_unalias (BUFFER *, BUFFER *, unsigned long, BUFFER *);
++static int parse_ifdef (BUFFER *, BUFFER *, unsigned long, BUFFER *);
+ static int parse_echo (BUFFER *, BUFFER *, unsigned long, BUFFER *);
+ static int parse_ignore (BUFFER *, BUFFER *, unsigned long, BUFFER *);
+ static int parse_unignore (BUFFER *, BUFFER *, unsigned long, BUFFER *);
+@@ -4259,6 +4260,7 @@ const struct command_t Commands[] = {
+ { "hdr_order", parse_list, UL &HeaderOrderList },
+ #ifdef HAVE_ICONV
+ { "iconv-hook", mutt_parse_hook, MUTT_ICONVHOOK },
++ { "ifdef", parse_ifdef, 0 },
+ #endif
+ { "ignore", parse_ignore, 0 },
+ { "index-format-hook",mutt_parse_idxfmt_hook, MUTT_IDXFMTHOOK },
diff --git a/mail/mutt/files/extra-patch-reverse_reply b/mail/mutt/files/extra-patch-reverse_reply
index a6f750704eec..7e7a7bcd8348 100644
--- a/mail/mutt/files/extra-patch-reverse_reply
+++ b/mail/mutt/files/extra-patch-reverse_reply
@@ -1,10 +1,13 @@
---- PATCHES.orig 2018-05-19 20:39:17 UTC
+--- PATCHES.orig 2018-11-29 22:55:14 UTC
+++ PATCHES
-@@ -0,0 +1 @@
+@@ -1,3 +1,4 @@
+patch-1.5.6.cb.reverse_reply.2
---- init.h.orig 2018-05-19 20:37:42 UTC
+ patch-1.5.4.cd.ifdef.1
+ vvv.quote
+ vvv.initials
+--- init.h.orig 2018-11-29 22:55:14 UTC
+++ init.h
-@@ -2748,6 +2748,13 @@
+@@ -2820,6 +2820,13 @@ struct option_t MuttVars[] = {
** possibly including eventual real names. When it is \fIunset\fP, mutt will
** override any such real names with the setting of the $$realname variable.
*/
@@ -18,9 +21,9 @@
{ "rfc2047_parameters", DT_BOOL, R_NONE, OPTRFC2047PARAMS, 0 },
/*
** .pp
---- mutt.h.orig 2018-05-19 20:36:22 UTC
+--- mutt.h.orig 2018-11-29 22:55:14 UTC
+++ mutt.h
-@@ -466,6 +466,7 @@
+@@ -478,6 +478,7 @@ enum
OPTREVALIAS,
OPTREVNAME,
OPTREVREAL,
@@ -28,9 +31,9 @@
OPTRFC2047PARAMS,
OPTSAVEADDRESS,
OPTSAVEEMPTY,
---- protos.h.orig 2018-05-19 20:33:53 UTC
+--- protos.h.orig 2018-11-24 19:06:21 UTC
+++ protos.h
-@@ -93,6 +93,7 @@
+@@ -85,6 +85,7 @@ ADDRESS *mutt_get_address (ENVELOPE *, c
ADDRESS *mutt_lookup_alias (const char *s);
ADDRESS *mutt_remove_duplicates (ADDRESS *);
ADDRESS *mutt_remove_xrefs (ADDRESS *, ADDRESS *);
@@ -38,9 +41,9 @@
ADDRESS *mutt_expand_aliases (ADDRESS *);
ADDRESS *mutt_parse_adrlist (ADDRESS *, const char *);
---- send.c.orig 2018-05-19 20:33:53 UTC
+--- send.c.orig 2018-10-04 22:30:10 UTC
+++ send.c
-@@ -598,6 +598,10 @@
+@@ -600,6 +600,10 @@ void mutt_fix_reply_recipients (ENVELOPE
/* the CC field can get cluttered, especially with lists */
env->to = mutt_remove_duplicates (env->to);
env->cc = mutt_remove_duplicates (env->cc);
@@ -51,9 +54,9 @@
env->cc = mutt_remove_xrefs (env->to, env->cc);
if (env->cc && !env->to)
---- sendlib.c.orig 2018-05-19 20:33:53 UTC
+--- sendlib.c.orig 2018-11-24 19:06:11 UTC
+++ sendlib.c
-@@ -2753,6 +2753,35 @@
+@@ -2754,6 +2754,35 @@ static void set_noconv_flags (BODY *b, s
}
}
diff --git a/mail/mutt/files/extra-patch-smartdate b/mail/mutt/files/extra-patch-smartdate
index 1eeab84752bc..5e82a8d189b7 100644
--- a/mail/mutt/files/extra-patch-smartdate
+++ b/mail/mutt/files/extra-patch-smartdate
@@ -1,6 +1,6 @@
---- hdrline.c.orig 2018-05-19 20:36:17 UTC
+--- hdrline.c.orig 2018-11-29 23:19:39 UTC
+++ hdrline.c
-@@ -249,6 +249,89 @@
+@@ -249,6 +249,89 @@ static char *apply_subject_mods (ENVELOP
* %Y = `x-label:' field (if present, tree unfolded, and != parent's x-label)
* %Z = status flags */
@@ -90,7 +90,7 @@
static const char *
hdr_format_str (char *dest,
size_t destlen,
-@@ -422,7 +505,13 @@
+@@ -422,7 +505,13 @@ hdr_format_str (char *dest,
if (!do_locales)
setlocale (LC_TIME, "C");
@@ -105,9 +105,9 @@
if (!do_locales)
setlocale (LC_TIME, "");
---- mutt.h.orig 2018-05-19 20:44:10 UTC
+--- mutt.h.orig 2018-11-29 23:17:47 UTC
+++ mutt.h
-@@ -148,6 +148,16 @@
+@@ -156,6 +156,16 @@ typedef enum
MUTT_FORMAT_NOFILTER = (1<<7) /* do not allow filtering on this pass */
} format_flag;
diff --git a/mail/mutt/files/patch-Makefile.in b/mail/mutt/files/patch-Makefile.in
index 3152f59deaba..14066a7a7320 100644
--- a/mail/mutt/files/patch-Makefile.in
+++ b/mail/mutt/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2018-05-19 20:48:16 UTC
+--- Makefile.in.orig 2018-11-25 17:43:43 UTC
+++ Makefile.in
-@@ -471,7 +471,7 @@
+@@ -531,7 +531,7 @@ AUTOMAKE_OPTIONS = 1.6 foreign
@BUILD_DOC_TRUE@DOC_SUBDIR = doc
@BUILD_IMAP_TRUE@IMAP_SUBDIR = imap
@BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap
@@ -9,7 +9,7 @@
bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
@BUILD_HCACHE_TRUE@HCVERSION = hcversion.h
BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION)
-@@ -1355,18 +1355,9 @@
+@@ -1667,18 +1667,9 @@ install-exec-hook:
rm -f $(DESTDIR)$(bindir)/mutt.dotlock ; \
ln -sf $(DESTDIR)$(bindir)/mutt_dotlock $(DESTDIR)$(bindir)/mutt.dotlock ; \
fi
diff --git a/mail/mutt/files/patch-contrib_Makefile.in b/mail/mutt/files/patch-contrib_Makefile.in
index 8d8b027bea19..a75296c0ebd7 100644
--- a/mail/mutt/files/patch-contrib_Makefile.in
+++ b/mail/mutt/files/patch-contrib_Makefile.in
@@ -1,5 +1,6 @@
-Index: contrib/Makefile.in
-@@ -270,7 +270,7 @@
+--- contrib/Makefile.in.orig 2018-11-25 17:43:43 UTC
++++ contrib/Makefile.in
+@@ -272,7 +272,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
subdir = contrib
diff --git a/mail/mutt/files/patch-date-conditional b/mail/mutt/files/patch-date-conditional
index 9cbae9c3718a..64c7f2f456bd 100644
--- a/mail/mutt/files/patch-date-conditional
+++ b/mail/mutt/files/patch-date-conditional
@@ -2,7 +2,7 @@
+++ PATCHES
@@ -0,0 +1 @@
+patch-1.5.0.ats.date_conditional.1
---- hdrline.c.orig 2017-12-03 03:10:17 UTC
+--- hdrline.c.orig 2018-11-24 19:06:11 UTC
+++ hdrline.c
@@ -428,6 +428,53 @@ hdr_format_str (char *dest,
const char *cp;
@@ -58,9 +58,9 @@
p = dest;
---- muttlib.c.orig 2017-12-03 03:10:17 UTC
+--- muttlib.c.orig 2018-11-24 19:06:21 UTC
+++ muttlib.c
-@@ -1335,7 +1335,16 @@ void mutt_FormatString (char *dest, /*
+@@ -1382,7 +1382,16 @@ void mutt_FormatString (char *dest, /*
if (*src == '?')
{
flags |= MUTT_FORMAT_OPTIONAL;
@@ -78,7 +78,7 @@
}
else
{
-@@ -1351,12 +1360,12 @@ void mutt_FormatString (char *dest, /*
+@@ -1398,12 +1407,12 @@ void mutt_FormatString (char *dest, /*
count++;
}
*cp = 0;
diff --git a/mail/mutt/files/patch-dgc-deepif b/mail/mutt/files/patch-dgc-deepif
index 6150184efad4..95291b448c09 100644
--- a/mail/mutt/files/patch-dgc-deepif
+++ b/mail/mutt/files/patch-dgc-deepif
@@ -1,6 +1,6 @@
--- muttlib.c.orig 2017-06-03 02:20:37 UTC
+++ muttlib.c
-@@ -1378,6 +1378,12 @@ void mutt_FormatString (char *dest, /*
+@@ -1425,6 +1425,12 @@ void mutt_FormatString (char *dest, /*
count = 0;
while (count < sizeof (ifstring) && *src && *src != '?' && *src != '&')
{
@@ -13,7 +13,7 @@
*cp++ = *src++;
count++;
}
-@@ -1390,7 +1396,13 @@ void mutt_FormatString (char *dest, /*
+@@ -1437,7 +1437,13 @@ void mutt_FormatString (char *dest, /*
count = 0;
while (count < sizeof (elsestring) && *src && *src != '?')
{
diff --git a/mail/mutt/files/patch-doc_Makefile.in b/mail/mutt/files/patch-doc_Makefile.in
index aa566f24aeaf..ac235a26e158 100644
--- a/mail/mutt/files/patch-doc_Makefile.in
+++ b/mail/mutt/files/patch-doc_Makefile.in
@@ -1,6 +1,6 @@
---- doc/Makefile.in.orig 2018-01-27 22:36:31 UTC
+--- doc/Makefile.in.orig 2018-12-01 04:54:52 UTC
+++ doc/Makefile.in
-@@ -664,14 +664,7 @@ install-data-local: makedoc-all instdoc
+@@ -678,14 +678,7 @@ install-data-local: makedoc-all instdoc
-for f in $(HTML_DOCFILES) ; do \
$(INSTALL) -m 644 $$f $(DESTDIR)$(docdir) ; \
done
@@ -13,10 +13,10 @@
- $(INSTALL) -m 644 Muttrc $(DESTDIR)$(sysconfdir) ; \
- fi
+ $(INSTALL) -m 644 Muttrc $(DESTDIR)$(sysconfdir)/Muttrc.sample
-
- uninstall-local:
- for f in mutt.1 mutt_dotlock.1 smime_keys.1 pgpewrap.1 pgpring.1; do \
-@@ -694,9 +687,7 @@ uninstall-local:
+ -if [ -f mutt.info ] ; then \
+ $(MKDIR_P) $(DESTDIR)$(infodir) ; \
+ $(INSTALL) -m 644 mutt.info $(DESTDIR)$(infodir) ; \
+@@ -721,9 +714,7 @@ uninstall-local:
check:
manual.txt: manual.html
diff --git a/mail/mutt/files/patch-muttlib.c b/mail/mutt/files/patch-muttlib.c
index 0c781433eece..788cfa256c59 100644
--- a/mail/mutt/files/patch-muttlib.c
+++ b/mail/mutt/files/patch-muttlib.c
@@ -1,6 +1,6 @@
---- muttlib.c.orig 2016-10-08 19:35:50 UTC
+--- muttlib.c.orig 2018-11-24 19:06:21 UTC
+++ muttlib.c
-@@ -802,16 +802,15 @@ void mutt_merge_envelopes(ENVELOPE* base
+@@ -845,16 +845,15 @@ void _mutt_buffer_mktemp (BUFFER *buf, c
void _mutt_mktemp (char *s, size_t slen, const char *prefix, const char *suffix,
const char *src, int line)
{
diff --git a/mail/mutt/files/patch-qresync-crash b/mail/mutt/files/patch-qresync-crash
new file mode 100644
index 000000000000..646bf42ae5e1
--- /dev/null
+++ b/mail/mutt/files/patch-qresync-crash
@@ -0,0 +1,21 @@
+--- imap/message.c.orig 2018-11-18 18:07:02 UTC
++++ imap/message.c
+@@ -652,6 +652,18 @@ static int read_headers_condstore_qresyn
+ {
+ imap_hcache_close (idata);
+ imap_expunge_mailbox (idata);
++
++ /* undo expunge count updates.
++ * mx_update_context() will do this at the end of the header fetch. */
++ ctx->vcount = 0;
++ ctx->vsize = 0;
++ ctx->tagged = 0;
++ ctx->deleted = 0;
++ ctx->new = 0;
++ ctx->unread = 0;
++ ctx->changed = 0;
++ ctx->flagged = 0;
++
+ idata->hcache = imap_hcache_open (idata, NULL);
+ idata->reopen &= ~IMAP_EXPUNGE_PENDING;
+ }
diff --git a/mail/mutt/files/patch-smime-sender b/mail/mutt/files/patch-smime-sender
index fe881fa63c2a..6b7bc23e86ea 100644
--- a/mail/mutt/files/patch-smime-sender
+++ b/mail/mutt/files/patch-smime-sender
@@ -1,4 +1,4 @@
---- commands.c.orig 2017-09-08 22:18:16 UTC
+--- commands.c.orig 2018-10-04 22:30:10 UTC
+++ commands.c
@@ -186,7 +186,7 @@ int mutt_display_message (HEADER *cur)
{
@@ -9,9 +9,9 @@
mutt_message ( _("S/MIME signature successfully verified."));
else
mutt_error ( _("S/MIME certificate owner does not match sender."));
---- init.h.orig 2017-09-08 22:18:16 UTC
+--- init.h.orig 2018-11-24 19:06:11 UTC
+++ init.h
-@@ -3160,6 +3169,15 @@ struct option_t MuttVars[] = {
+@@ -3232,6 +3232,15 @@ struct option_t MuttVars[] = {
** to determine the key to use. It will ask you to supply a key, if it can't find one.
** (S/MIME only)
*/
@@ -27,9 +27,9 @@
{ "smime_self_encrypt_as", DT_SYN, R_NONE, UL "smime_default_key", 0 },
{ "smime_default_key", DT_STR, R_NONE, UL &SmimeDefaultKey, 0 },
/*
---- mutt.h.orig 2017-09-08 22:18:16 UTC
+--- mutt.h.orig 2018-11-24 19:06:11 UTC
+++ mutt.h
-@@ -539,6 +540,7 @@ enum
+@@ -551,6 +551,7 @@ enum
OPTSMIMEISDEFAULT,
OPTSMIMESELFENCRYPT,
OPTASKCERTLABEL,
diff --git a/mail/mutt/files/patch-threadcomplete b/mail/mutt/files/patch-threadcomplete
index 3d3f9bb01306..1c39e0fd8981 100644
--- a/mail/mutt/files/patch-threadcomplete
+++ b/mail/mutt/files/patch-threadcomplete
@@ -1,6 +1,6 @@
---- mutt.h.orig 2018-05-19 21:17:16 UTC
+--- mutt.h.orig 2018-11-24 19:06:11 UTC
+++ mutt.h
-@@ -225,6 +225,7 @@
+@@ -234,6 +234,7 @@ enum
MUTT_EXPIRED,
MUTT_SUPERSEDED,
MUTT_TRASH,
@@ -8,9 +8,9 @@
/* actions for mutt_pattern_comp/mutt_pattern_exec */
MUTT_AND,
---- pattern.c.orig 2018-05-19 20:33:53 UTC
+--- pattern.c.orig 2018-11-24 19:06:11 UTC
+++ pattern.c
-@@ -57,6 +57,7 @@
+@@ -57,6 +57,7 @@ static const struct pattern_flags
}
Flags[] =
{
@@ -18,7 +18,7 @@
{ 'A', MUTT_ALL, 0, NULL },
{ 'b', MUTT_BODY, MUTT_FULL_MSG, eat_regexp },
{ 'B', MUTT_WHOLE_MSG, MUTT_FULL_MSG, eat_regexp },
-@@ -1294,6 +1295,16 @@
+@@ -1343,6 +1344,16 @@ mutt_pattern_exec (struct pattern_t *pat
else
result = mutt_is_list_cc (pat->alladdr, h->env->to, h->env->cc);
return (pat->not ^ result);
diff --git a/mail/mutt/pkg-plist b/mail/mutt/pkg-plist
index 6fc5f6dd3e44..4bf8dc483cb4 100644
--- a/mail/mutt/pkg-plist
+++ b/mail/mutt/pkg-plist
@@ -2,14 +2,14 @@ bin/flea
bin/mutt
bin/muttbug
@(,mail,2755) bin/mutt_dotlock
+bin/mutt_pgpring
bin/pgpewrap
-bin/pgpring
bin/smime_keys
@sample etc/Muttrc.sample
man/man1/mutt.1.gz
man/man1/mutt_dotlock.1.gz
+man/man1/mutt_pgpring.1.gz
man/man1/pgpewrap.1.gz
-man/man1/pgpring.1.gz
man/man1/smime_keys.1.gz
man/man5/mailcap.5.gz
%%MAILBOX_MANPAGES%%man/man5/mbox.5.gz
@@ -89,6 +89,7 @@ man/man5/muttrc.5.gz
%%NLS%%share/locale/es/LC_MESSAGES/mutt.mo
%%NLS%%share/locale/et/LC_MESSAGES/mutt.mo
%%NLS%%share/locale/eu/LC_MESSAGES/mutt.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/mutt.mo
%%NLS%%share/locale/fr/LC_MESSAGES/mutt.mo
%%NLS%%share/locale/ga/LC_MESSAGES/mutt.mo
%%NLS%%share/locale/gl/LC_MESSAGES/mutt.mo