aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-24 14:12:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-24 14:12:32 +0000
commit5fd6da9c78b8c107732c855569192912759c1b3b (patch)
treece259c1ae25fa1043075dfad1bc66ae331eaf0ba /mail
parent061d14d29d01cf4db26cad604ac0e7d8ec353100 (diff)
downloadports-5fd6da9c78b8c107732c855569192912759c1b3b.tar.gz
ports-5fd6da9c78b8c107732c855569192912759c1b3b.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/phpmailer/Makefile10
-rw-r--r--mail/phpmailer/distinfo4
-rw-r--r--mail/phpmailer/pkg-plist111
3 files changed, 53 insertions, 72 deletions
diff --git a/mail/phpmailer/Makefile b/mail/phpmailer/Makefile
index d82df49b534e..c16b4ee53bc7 100644
--- a/mail/phpmailer/Makefile
+++ b/mail/phpmailer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= phpmailer
-PORTVERSION= 5.2.6
+PORTVERSION= 5.2.7
CATEGORIES= mail
MASTER_SITES= https://github.com/Synchro/PHPMailer/archive/
DISTNAME= v${PORTVERSION}
@@ -12,24 +12,26 @@ COMMENT= Full Featured Email Transfer Class for PHP
LICENSE= LGPL3
+OPTIONS_DEFINE= DOCS EXAMPLES
+
WRKSRC= ${WRKDIR}/PHPMailer-${PORTVERSION}
-USE_DOS2UNIX= yes
NO_BUILD= yes
USE_PHP= yes
+USES= dos2unix
SUB_FILES= pkg-message
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
-.for f in class.phpmailer.php class.pop3.php class.smtp.php composer.json
+.for f in PHPMailerAutoload.php class.phpmailer.php class.pop3.php \
+ class.smtp.php composer.json
@${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DATADIR}
.endfor
.for d in extras language test
@${MKDIR} ${STAGEDIR}${DATADIR}/$d
@${INSTALL_DATA} ${WRKSRC}/$d/* ${STAGEDIR}${DATADIR}/$d
.endfor
- @${CP} -R ${WRKSRC}/test_script ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in changelog.md README.md LICENSE
@${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
diff --git a/mail/phpmailer/distinfo b/mail/phpmailer/distinfo
index 7248230760f1..37a77aabccab 100644
--- a/mail/phpmailer/distinfo
+++ b/mail/phpmailer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (v5.2.6.tar.gz) = a013aaee52f6c7c7c0b4043db1db02dcaf9a58df93faba647ae78015b6b2a7da
-SIZE (v5.2.6.tar.gz) = 196379
+SHA256 (v5.2.7.tar.gz) = 645eee4dff3da73487698f4b829743aa58026abb8ed4d7f72630e817aaaaaedf
+SIZE (v5.2.7.tar.gz) = 152319
diff --git a/mail/phpmailer/pkg-plist b/mail/phpmailer/pkg-plist
index 49734da84cbb..753c720da00e 100644
--- a/mail/phpmailer/pkg-plist
+++ b/mail/phpmailer/pkg-plist
@@ -8,28 +8,51 @@
%%PORTDOCS%%%%DOCSDIR%%/faq.html
%%PORTDOCS%%%%DOCSDIR%%/generatedocs.sh
%%PORTDOCS%%%%DOCSDIR%%/pop3_article.txt
-%%PORTDOCS%%%%DOCSDIR%%/use_gmail.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/LGPLv3.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/code_generator.phps
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contents.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/phpmailer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/exceptions.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmail.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/phpmailer.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images/phpmailer_mini.gif
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index.html
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_db_smtp_basic.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_mail_advanced.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_mail_basic.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_pop_before_smtp_advanced.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_pop_before_smtp_basic.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_sendmail_advanced.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_sendmail_basic.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp_advanced.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp_advanced_no_auth.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp_basic.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp_basic_no_auth.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp_gmail_advanced.php
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_smtp_gmail_basic.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mail.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mailing_list.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pop_before_smtp.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/XRegExp.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/shAutoloader.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/shBrushPhp.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/shCore.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/shLegacy.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sendmail.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smtp.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smtp_no_auth.phps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCore.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreDefault.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreDjango.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreEclipse.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreEmacs.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreFadeToGrey.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreMDUltra.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreMidnight.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shCoreRDark.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeAppleScript.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeDefault.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeDjango.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeEclipse.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeEmacs.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeFadeToGrey.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeMDUltra.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeMidnight.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeRDark.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/shThemeVisualStudio.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/styles/wrapping.png
+%%DATADIR%%/PHPMailerAutoload.php
%%DATADIR%%/class.phpmailer.php
%%DATADIR%%/class.pop3.php
%%DATADIR%%/class.smtp.php
%%DATADIR%%/composer.json
+%%DATADIR%%/extras/EasyPeasyICS.php
%%DATADIR%%/extras/class.html2text.php
%%DATADIR%%/extras/htmlfilter.php
%%DATADIR%%/extras/ntlm_sasl_client.php
@@ -43,6 +66,7 @@
%%DATADIR%%/language/phpmailer.lang-eo.php
%%DATADIR%%/language/phpmailer.lang-es.php
%%DATADIR%%/language/phpmailer.lang-et.php
+%%DATADIR%%/language/phpmailer.lang-fa.php
%%DATADIR%%/language/phpmailer.lang-fi.php
%%DATADIR%%/language/phpmailer.lang-fo.php
%%DATADIR%%/language/phpmailer.lang-fr.php
@@ -50,6 +74,7 @@
%%DATADIR%%/language/phpmailer.lang-hu.php
%%DATADIR%%/language/phpmailer.lang-it.php
%%DATADIR%%/language/phpmailer.lang-ja.php
+%%DATADIR%%/language/phpmailer.lang-lt.php
%%DATADIR%%/language/phpmailer.lang-nl.php
%%DATADIR%%/language/phpmailer.lang-no.php
%%DATADIR%%/language/phpmailer.lang-pl.php
@@ -58,68 +83,22 @@
%%DATADIR%%/language/phpmailer.lang-se.php
%%DATADIR%%/language/phpmailer.lang-sk.php
%%DATADIR%%/language/phpmailer.lang-tr.php
+%%DATADIR%%/language/phpmailer.lang-uk.php
%%DATADIR%%/language/phpmailer.lang-zh.php
%%DATADIR%%/language/phpmailer.lang-zh_cn.php
-%%DATADIR%%/test/contents.html
+%%DATADIR%%/test/fakepopserver.sh
%%DATADIR%%/test/fakesendmail.sh
%%DATADIR%%/test/phpmailerLangTest.php
%%DATADIR%%/test/phpmailerTest.php
-%%DATADIR%%/test/test.png
+%%DATADIR%%/test/runfakepopserver.sh
%%DATADIR%%/test/test_callback.php
%%DATADIR%%/test/testbootstrap-dist.php
-%%DATADIR%%/test/testemail.php
-%%DATADIR%%/test_script/LGPLv3.txt
-%%DATADIR%%/test_script/contents.html
-%%DATADIR%%/test_script/images/aikido.gif
-%%DATADIR%%/test_script/images/bkgrnd.gif
-%%DATADIR%%/test_script/images/phpmailer.gif
-%%DATADIR%%/test_script/index.php
-%%DATADIR%%/test_script/scripts/clipboard.swf
-%%DATADIR%%/test_script/scripts/shBrushBash.js
-%%DATADIR%%/test_script/scripts/shBrushCSharp.js
-%%DATADIR%%/test_script/scripts/shBrushCpp.js
-%%DATADIR%%/test_script/scripts/shBrushCss.js
-%%DATADIR%%/test_script/scripts/shBrushDelphi.js
-%%DATADIR%%/test_script/scripts/shBrushDiff.js
-%%DATADIR%%/test_script/scripts/shBrushGroovy.js
-%%DATADIR%%/test_script/scripts/shBrushJScript.js
-%%DATADIR%%/test_script/scripts/shBrushJava.js
-%%DATADIR%%/test_script/scripts/shBrushPerl.js
-%%DATADIR%%/test_script/scripts/shBrushPhp.js
-%%DATADIR%%/test_script/scripts/shBrushPlain.js
-%%DATADIR%%/test_script/scripts/shBrushPython.js
-%%DATADIR%%/test_script/scripts/shBrushRuby.js
-%%DATADIR%%/test_script/scripts/shBrushScala.js
-%%DATADIR%%/test_script/scripts/shBrushSql.js
-%%DATADIR%%/test_script/scripts/shBrushVb.js
-%%DATADIR%%/test_script/scripts/shBrushXml.js
-%%DATADIR%%/test_script/scripts/shCore.js
-%%DATADIR%%/test_script/scripts/shLegacy.js
-%%DATADIR%%/test_script/src/shCore.js
-%%DATADIR%%/test_script/src/shLegacy.js
-%%DATADIR%%/test_script/styles/help.png
-%%DATADIR%%/test_script/styles/magnifier.png
-%%DATADIR%%/test_script/styles/page_white_code.png
-%%DATADIR%%/test_script/styles/page_white_copy.png
-%%DATADIR%%/test_script/styles/printer.png
-%%DATADIR%%/test_script/styles/shCore.css
-%%DATADIR%%/test_script/styles/shThemeDefault.css
-%%DATADIR%%/test_script/styles/shThemeDjango.css
-%%DATADIR%%/test_script/styles/shThemeEmacs.css
-%%DATADIR%%/test_script/styles/shThemeFadeToGrey.css
-%%DATADIR%%/test_script/styles/shThemeMidnight.css
-%%DATADIR%%/test_script/styles/shThemeRDark.css
-%%DATADIR%%/test_script/styles/wrapping.png
-%%DATADIR%%/test_script/test.html
-@dirrm %%DATADIR%%/test_script/styles
-@dirrm %%DATADIR%%/test_script/src
-@dirrm %%DATADIR%%/test_script/scripts
-@dirrm %%DATADIR%%/test_script/images
-@dirrm %%DATADIR%%/test_script
@dirrm %%DATADIR%%/test
@dirrm %%DATADIR%%/language
@dirrm %%DATADIR%%/extras
@dirrm %%DATADIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/styles
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/scripts
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/images
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%