aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-05 17:20:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-05 17:20:17 +0000
commit9ee3bae316f128a4ae7d85ef30d8349cb51169aa (patch)
treeadafbe2192a2e1c4bd94ae82d0762c9950e6b6f4 /mail
parentbef7524add5f504ccb25bece6476b7768517f134 (diff)
downloadports-9ee3bae316f128a4ae7d85ef30d8349cb51169aa.tar.gz
ports-9ee3bae316f128a4ae7d85ef30d8349cb51169aa.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/quickml/Makefile72
-rw-r--r--mail/quickml/distinfo2
-rw-r--r--mail/quickml/files/patch-Makefile.in19
-rw-r--r--mail/quickml/files/patch-configure.ac32
-rw-r--r--mail/quickml/files/quickml.sh18
-rw-r--r--mail/quickml/files/with-mta.en.rd73
-rw-r--r--mail/quickml/files/without_quickml-analog24
-rw-r--r--mail/quickml/pkg-descr7
-rw-r--r--mail/quickml/pkg-install31
-rw-r--r--mail/quickml/pkg-message12
-rw-r--r--mail/quickml/pkg-plist23
12 files changed, 314 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index bf8ef5019494..3d7657296e07 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -348,6 +348,7 @@
SUBDIR += qsf
SUBDIR += qtools
SUBDIR += queue-repair
+ SUBDIR += quickml
SUBDIR += raysfilter
SUBDIR += razor-agents
SUBDIR += rbl-milter
diff --git a/mail/quickml/Makefile b/mail/quickml/Makefile
new file mode 100644
index 000000000000..933b043836f7
--- /dev/null
+++ b/mail/quickml/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: quickml
+# Date created: 11 June 2004
+# Whom: Yuichiro AIZAWA <yaizawa@mdbl.sfc.keio.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quickml
+PORTVERSION= 0.7
+CATEGORIES= mail
+MASTER_SITES= http://namazu.org/%7esatoru/quickml/
+
+MAINTAINER= yaizawa@mdbl.sfc.keio.ac.jp
+COMMENT= An easy-to-use mailing list system
+
+OPTIONS+= ANALOG "Enable quickml-analog" on
+
+PKGINSTALL= ${WRKDIR}/pkg-install
+
+QUICKML_USER= quickml
+QUICKML_GROUP= quickml
+
+USE_AUTOTOOLS= yes
+USE_AUTOCONF_VER= 259
+GNU_CONFIGURE= yes
+USE_RUBY= yes
+
+USE_RC_SUBR= yes
+FILES_SUB= USER=${QUICKML_USER} GROUP=${QUICKML_GROUP} \
+ PREFIX=${PREFIX} RC_SUBR=${RC_SUBR} RUBY=${RUBY}
+
+CONFIGURE_ARGS+= --with-ruby="${RUBY}"
+CONFIGURE_ARGS+= --with-user="${QUICKML_USER}"
+CONFIGURE_ARGS+= --with-group="${QUICKML_GROUP}"
+CONFIGURE_ARGS+= --with-rubydir="${RUBY_LIBDIR}"
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_ANALOG)
+USE_GHOSTSCRIPT_RUN= yes
+RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
+ convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+post-patch:
+ @${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/quickml.sh > ${WRKDIR}/quickml.sh
+.if defined(WITHOUT_ANALOG)
+ ${PATCH} ${PATCH_DIST_ARGS} < ${FILESDIR}/without_quickml-analog
+.endif
+
+pre-install:
+ @${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${PKGDIR}/pkg-install > ${PKGINSTALL}
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ml-usage.en.rd ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quickml.en.rd ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/quickml.ja.rd ${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/with-mta.en.rd ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/with-mta.ja.rd ${DOCSDIR}
+.endif
+.if !exists(${PREFIX}/etc/rc.d/quickml.sh)
+ @${ECHO} "Installing ${PREFIX}/etc/rc.d/quickml.sh startup file."
+ ${INSTALL_SCRIPT} -m 751 ${WRKDIR}/quickml.sh ${PREFIX}/etc/rc.d/quickml.sh
+.endif
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' -e 's|%%DOCSDIR%%|${DOCSDIR}|g' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/mail/quickml/distinfo b/mail/quickml/distinfo
new file mode 100644
index 000000000000..7a3f5127107d
--- /dev/null
+++ b/mail/quickml/distinfo
@@ -0,0 +1,2 @@
+MD5 (quickml-0.7.tar.gz) = 590c19a227eacb78f96c11c9f89886bb
+SIZE (quickml-0.7.tar.gz) = 94147
diff --git a/mail/quickml/files/patch-Makefile.in b/mail/quickml/files/patch-Makefile.in
new file mode 100644
index 000000000000..8c19f9b7ccf7
--- /dev/null
+++ b/mail/quickml/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+*** Makefile.in.orig Mon Jun 7 19:21:36 2004
+--- Makefile.in Thu Jul 1 00:18:18 2004
+***************
+*** 626,632 ****
+ -e 's!%PIDFILE%!$(PIDFILE)!g' \
+ quickml-ctl.in > quickml-ctl
+ chmod +x quickml-ctl
+! chmod -w quickml-analog
+
+ quickmlrc.sample: quickmlrc.sample.in Makefile
+ rm -f quickmlrc.sample
+--- 626,632 ----
+ -e 's!%PIDFILE%!$(PIDFILE)!g' \
+ quickml-ctl.in > quickml-ctl
+ chmod +x quickml-ctl
+! chmod -w quickml-ctl
+
+ quickmlrc.sample: quickmlrc.sample.in Makefile
+ rm -f quickmlrc.sample
diff --git a/mail/quickml/files/patch-configure.ac b/mail/quickml/files/patch-configure.ac
new file mode 100644
index 000000000000..cbaf8906c379
--- /dev/null
+++ b/mail/quickml/files/patch-configure.ac
@@ -0,0 +1,32 @@
+*** configure.ac.orig Mon Jun 7 17:50:58 2004
+--- configure.ac Sat Jul 3 01:16:54 2004
+***************
+*** 5,14 ****
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+
+! AC_PATH_PROG(RUBY, ruby, no)
+! if test "$RUBY" = "no"; then
+! AC_MSG_ERROR(ruby not found)
+! fi
+
+ AC_ARG_WITH(
+ user,
+--- 5,21 ----
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+
+! AC_ARG_WITH(
+! ruby,
+! [ --with-ruby=RUBY quickml runs with RUBY [[ruby]]],
+! [RUBY=${withval}],
+! [AC_PATH_PROG(RUBY, ruby, no)
+! if test "$RUBY" = "no"; then
+! AC_MSG_ERROR(ruby not found)
+! fi
+! ]
+! )
+! AC_SUBST(RUBY)
+
+ AC_ARG_WITH(
+ user,
diff --git a/mail/quickml/files/quickml.sh b/mail/quickml/files/quickml.sh
new file mode 100644
index 000000000000..3e1b6de452bf
--- /dev/null
+++ b/mail/quickml/files/quickml.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/mail/quickml/files/Attic/quickml.sh,v 1.1 2004-07-05 17:20:17 pav Exp $
+#
+
+. %%RC_SUBR%%
+
+name="quickml"
+rcvar=`set_rcvar`
+
+command="%%RUBY%%"
+command_args="%%PREFIX%%/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+required_files=%%PREFIX%%/etc/quickmlrc
+
+load_rc_config $name
+
+run_rc_command "$1"
diff --git a/mail/quickml/files/with-mta.en.rd b/mail/quickml/files/with-mta.en.rd
new file mode 100644
index 000000000000..2db4091785a7
--- /dev/null
+++ b/mail/quickml/files/with-mta.en.rd
@@ -0,0 +1,73 @@
+=begin
+
+= quickml server: How to coexist with other MTA
+
+Last Update: 2002-04-28 (Release date: 2002-04-28)
+
+
+== Configurate quickml server
+
+1. Create user `quickml' and group `quickml' on the UNIX host to
+ quickml server.
+
+2. Configure quickmlrc as below:
+
+ Config = {
+ :user => 'quickml',
+ :group => 'quickml',
+ :port => 10025,
+ :bind_address => "127.0.0.1",
+
+== Configure DNS
+
+Set MX record of the domain name that is for quickml service
+(ex. foobar.com) to the host running quickml server.
+
+== Configure MTA
+
+=== Case of qmail
+
+1. Add
+
+ foobar.com
+
+to /var/qmail/control/rcpthosts.
+
+2. Add
+
+ foobar.com:localhost:10025
+
+to /var/qmail/control/smtproutes.
+
+=== Case of Postfix
+
+1. Add
+
+ foobar.com smtp:[localhost:10025]
+
+to /etc/postfix/transport.
+
+2. Add
+
+ transport_maps = hash:/etc/transport
+
+to /etc/postfix/main.cf, and execute commands as below.
+
+ # postmap transport
+ # postfix reload
+
+== Acknowledgement
+
+This document is courtesy of imformation from
+((<Mr. Taku Kudo|URL:http://cl.aist-nara.ac.jp/~taku-ku/>)).
+
+== Translation
+
+The original version of this document is written in Japanese by
+((<Mr. Satoru Takabayashi|URL:http://namazu.org/~satoru/>)).
+Translation of this document is by
+((<Yuichiro AIZAWA|URL:http://www.mdbl.sfc.keio.ac.jp/~yaizawa/>))
+and
+Takashi OTA.
+
+=end
diff --git a/mail/quickml/files/without_quickml-analog b/mail/quickml/files/without_quickml-analog
new file mode 100644
index 000000000000..bdec5c9f8ce2
--- /dev/null
+++ b/mail/quickml/files/without_quickml-analog
@@ -0,0 +1,24 @@
+*** Makefile.in.with_analog Thu Jul 1 00:20:16 2004
+--- Makefile.in Thu Jul 1 00:22:28 2004
+***************
+*** 142,151 ****
+ RD = quickml.en.rd ml-usage.en.rd quickml.ja.rd with-mta.ja.rd
+ MESSAGES = messages.ja
+ EXTRA_DIST = $(RD) $(MESSAGES) quickml.in quickml-ctl.in \
+! quickmlrc.sample.in quickml-analog.in
+
+ CLEANFILES = quickml quickml-ctl quickmlrc.sample quickml-analog
+- bin_SCRIPTS = quickml-analog
+ sbin_SCRIPTS = quickml quickml-ctl
+ quickmlstatedir = $(localstatedir)/quickml
+ etcdir = $(sysconfdir)
+--- 142,150 ----
+ RD = quickml.en.rd ml-usage.en.rd quickml.ja.rd with-mta.ja.rd
+ MESSAGES = messages.ja
+ EXTRA_DIST = $(RD) $(MESSAGES) quickml.in quickml-ctl.in \
+! quickmlrc.sample.in
+
+ CLEANFILES = quickml quickml-ctl quickmlrc.sample quickml-analog
+ sbin_SCRIPTS = quickml quickml-ctl
+ quickmlstatedir = $(localstatedir)/quickml
+ etcdir = $(sysconfdir)
diff --git a/mail/quickml/pkg-descr b/mail/quickml/pkg-descr
new file mode 100644
index 000000000000..a912aa494123
--- /dev/null
+++ b/mail/quickml/pkg-descr
@@ -0,0 +1,7 @@
+quickml server is a very-easy-to-use mailing list system. quickml
+server provides very-easy-to-use mailing list service.
+
+WWW: http://quickml.com/quickml/
+
+- Yuichiro AIZAWA
+yaizawa@mdbl.sfc.keio.ac.jp
diff --git a/mail/quickml/pkg-install b/mail/quickml/pkg-install
new file mode 100644
index 000000000000..6c062cf6541d
--- /dev/null
+++ b/mail/quickml/pkg-install
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# $FreeBSD: /tmp/pcvs/ports/mail/quickml/Attic/pkg-install,v 1.1 2004-07-05 17:20:17 pav Exp $
+#
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+case $2 in
+
+PRE-INSTALL)
+ echo "---> Starting pre-install script:"
+
+ if pw showgroup "%%GROUP%%" 2>/dev/null; then
+ echo "---> Using existing group \"%%GROUP%%\""
+ else
+ echo "---> Adding group \"%%GROUP%%\""
+ pw addgroup %%GROUP%% -g 109 -h - || exit 1
+ fi
+
+ # Create user if required
+ if pw showuser "%%USER%%" 2>/dev/null; then
+ echo "---> Using existing user \"%%USER%%\""
+ else
+ echo "---> Adding user \"%%USER%%\""
+ pw adduser %%USER%% -u 109 -g %%GROUP%% -h - \
+ -d "/nonexistent" -s "/sbin/nologin" -c "quickml Server" || exit 1
+ fi
+
+ ;;
+
+esac
diff --git a/mail/quickml/pkg-message b/mail/quickml/pkg-message
new file mode 100644
index 000000000000..4b8f873cfb2e
--- /dev/null
+++ b/mail/quickml/pkg-message
@@ -0,0 +1,12 @@
+----------------------------------------------------------------------
+Installation of QuickML is finished. QuickML works as a SMTP server.
+The default configuration let QuickML hold tcp/25, so if you are using
+the host as a SMTP server you must change settings.
+
+You can change port for QuickML in %%PREFIX%%/etc/quickmlrc like:
+ :port => 10025,
+
+Please see also :
+ %%DOCSDIR%%/with-mta.en.rd
+ %%DOCSDIR%%/with-mta.ja.rd
+----------------------------------------------------------------------
diff --git a/mail/quickml/pkg-plist b/mail/quickml/pkg-plist
new file mode 100644
index 000000000000..693aade1237f
--- /dev/null
+++ b/mail/quickml/pkg-plist
@@ -0,0 +1,23 @@
+%%RUBY_LIBDIR%%/quickml/config.rb
+%%RUBY_LIBDIR%%/quickml/gettext.rb
+%%RUBY_LIBDIR%%/quickml/mail.rb
+%%RUBY_LIBDIR%%/quickml/sweeper.rb
+%%RUBY_LIBDIR%%/quickml/core.rb
+%%RUBY_LIBDIR%%/quickml/logger.rb
+%%RUBY_LIBDIR%%/quickml/server.rb
+%%RUBY_LIBDIR%%/quickml/utils.rb
+%%RUBY_LIBDIR%%/quickml/version.rb
+%%RUBY_LIBDIR%%/quickml.rb
+bin/quickml-analog
+sbin/quickml
+sbin/quickml-ctl
+@unexec if cmp -s %D/etc/quickmlrc %D/etc/quickmlrc.sample; then rm -f %D/etc/quickmlrc; fi
+etc/quickmlrc.sample
+etc/rc.d/quickml.sh
+@dirrm %%RUBY_LIBDIR%%/quickml
+%%PORTDOCS%%%%DOCSDIR%%/ml-usage.en.rd
+%%PORTDOCS%%%%DOCSDIR%%/quickml.en.rd
+%%PORTDOCS%%%%DOCSDIR%%/quickml.ja.rd
+%%PORTDOCS%%%%DOCSDIR%%/with-mta.en.rd
+%%PORTDOCS%%%%DOCSDIR%%/with-mta.ja.rd
+%%PORTDOCS%%@dirrm %%DOCSDIR%%