aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2004-06-04 17:29:38 +0000
committerAde Lovett <ade@FreeBSD.org>2004-06-04 17:29:38 +0000
commit1a628ded35ecbbc5eeb75598dd844d830aca8cb2 (patch)
tree128ce8505dc266bea10a8cf389f38de197424aed /mail
parent639a61155c89af6b9b01d796a82cbd2ad643a299 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa2/Makefile4
-rw-r--r--mail/cyrus-imapd22/Makefile2
-rw-r--r--mail/cyrus-imapd23/Makefile2
-rw-r--r--mail/cyrus-imapd24/Makefile2
-rw-r--r--mail/libnewmail/Makefile4
-rw-r--r--mail/mutt-devel/Makefile1
-rw-r--r--mail/mutt/Makefile1
-rw-r--r--mail/mutt14/Makefile1
-rw-r--r--mail/pop3proxy/Makefile2
-rw-r--r--mail/up-imapproxy/Makefile2
10 files changed, 12 insertions, 9 deletions
diff --git a/mail/balsa2/Makefile b/mail/balsa2/Makefile
index 2f67bfd32840..a853d455f80e 100644
--- a/mail/balsa2/Makefile
+++ b/mail/balsa2/Makefile
@@ -17,9 +17,9 @@ COMMENT= A mail reader for the GNOME 2 desktop
LIB_DEPENDS= aspell.15:${PORTSDIR}/textproc/aspell \
pcre.0:${PORTSDIR}/devel/pcre \
- esmtp.6:${PORTSDIR}/mail/libesmtp \
- ltdl.4:${PORTSDIR}/devel/libltdl
+ esmtp.6:${PORTSDIR}/mail/libesmtp
+USE_LIBLTDL= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_PERL5= yes
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index 555eb20cc5c4..86a150e133cb 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -102,8 +102,8 @@ CONFIGURE_ARGS+=--enable-netscapehack
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aclocal.m4 \
${FILESDIR}/extra-patch-configure.in
-USE_AUTOHEADER= YES
USE_AUTOCONF_VER=257
+USE_AUTOHEADER_VER=257
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 555eb20cc5c4..86a150e133cb 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -102,8 +102,8 @@ CONFIGURE_ARGS+=--enable-netscapehack
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aclocal.m4 \
${FILESDIR}/extra-patch-configure.in
-USE_AUTOHEADER= YES
USE_AUTOCONF_VER=257
+USE_AUTOHEADER_VER=257
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 555eb20cc5c4..86a150e133cb 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -102,8 +102,8 @@ CONFIGURE_ARGS+=--enable-netscapehack
EXTRA_PATCHES+= ${WRKSRC}/contrib/drac_auth.patch
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-aclocal.m4 \
${FILESDIR}/extra-patch-configure.in
-USE_AUTOHEADER= YES
USE_AUTOCONF_VER=257
+USE_AUTOHEADER_VER=257
CONFIGURE_ARGS+=--with-drac=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
.endif
diff --git a/mail/libnewmail/Makefile b/mail/libnewmail/Makefile
index 3b526d47ff08..1216d2a0d218 100644
--- a/mail/libnewmail/Makefile
+++ b/mail/libnewmail/Makefile
@@ -15,9 +15,9 @@ MAINTAINER= krion@FreeBSD.org
COMMENT= Generic mail checking library
LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls \
- oop.4:${PORTSDIR}/devel/liboop \
- ltdl.4:${PORTSDIR}/devel/libltdl
+ oop.4:${PORTSDIR}/devel/liboop
+USE_LIBLTDL= yes
GNU_CONFIGURE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index ad20670ed277..97387b4877c7 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -123,6 +123,7 @@ CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
USE_REINPLACE= yes
USE_AUTOMAKE_VER= 14
+USE_AUTOCONF_VER= 213
USE_OPENSSL= yes
PLIST= ${WRKDIR}/PLIST
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 48b1cbef7f49..7f86b45917a4 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -73,6 +73,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_AUTOMAKE_VER= 14 # configure.in is patched by <PATCHFILES>
+USE_AUTOCONF_VER= 213
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 48b1cbef7f49..7f86b45917a4 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -73,6 +73,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_AUTOMAKE_VER= 14 # configure.in is patched by <PATCHFILES>
+USE_AUTOCONF_VER= 213
USE_REINPLACE= yes
CONFIGURE_TARGET=${ARCH}-portbld-freebsd${OSREL}
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/mail/pop3proxy/Makefile b/mail/pop3proxy/Makefile
index 5de9ebf1d3bd..e09f7aa98974 100644
--- a/mail/pop3proxy/Makefile
+++ b/mail/pop3proxy/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= mbr@FreeBSD.org
COMMENT= POP3 Proxy Server derived from UP IMAP Proxy
GNU_CONFIGURE= YES
-USE_AUTOCONF= YES
+USE_AUTOCONF_VER=213
USE_RC_SUBR= YES
SAMPLE_EXT= sample
diff --git a/mail/up-imapproxy/Makefile b/mail/up-imapproxy/Makefile
index a5ebd85cf154..e9c08e569367 100644
--- a/mail/up-imapproxy/Makefile
+++ b/mail/up-imapproxy/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= mbr@FreeBSD.org
COMMENT= A caching IMAP proxy server
GNU_CONFIGURE= YES
-USE_AUTOCONF= YES
+USE_AUTOCONF_VER=213
USE_RC_SUBR= YES
SAMPLE_EXT= sample