aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
commit1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /mail
parent7cb0f3c9b4ec333deb7e94ba00c6dc2d3b9c6220 (diff)
downloadports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.tar.gz
ports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/libetpan/files/patch-configure.ac18
-rw-r--r--mail/neomutt/Makefile1
-rw-r--r--mail/wmmaiload/Makefile10
3 files changed, 23 insertions, 6 deletions
diff --git a/mail/libetpan/files/patch-configure.ac b/mail/libetpan/files/patch-configure.ac
new file mode 100644
index 000000000000..e5a82587bffc
--- /dev/null
+++ b/mail/libetpan/files/patch-configure.ac
@@ -0,0 +1,18 @@
+--- configure.ac.orig 2016-05-26 05:27:47 UTC
++++ configure.ac
+@@ -313,13 +313,13 @@ if test x$enable_iconv = xyes; then
+ saved_LIBS="$LIBS"
+ for lib in iconv ; do
+ if test "x$ICONV_LINKED" = "x0" ; then
+- LIBS=-l$lib
++ LIBS="-l$lib $saved_LIBS"
+ AC_TRY_LINK([#include <stdlib.h>
+ #include <iconv.h>],
+ [iconv_t cd = iconv_open("","");
+ iconv(cd,NULL,NULL,NULL,NULL);
+ iconv_close(cd);],
+- [LIBICONV="$LIBS" ; ICONV_LINKED=1],
++ [LIBICONV="-l$lib" ; ICONV_LINKED=1],
+ [])
+ fi
+ done
diff --git a/mail/neomutt/Makefile b/mail/neomutt/Makefile
index ffccf245e2a3..508f16dd4d79 100644
--- a/mail/neomutt/Makefile
+++ b/mail/neomutt/Makefile
@@ -81,6 +81,7 @@ DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
post-patch:
@${REINPLACE_CMD} -e "s/\`date/\`gdate/" ${WRKSRC}/Makefile.am ${WRKSRC}/doc/Makefile.am
+ @${REINPLACE_CMD} '/LIBS=$$/d' ${WRKSRC}/configure.ac
post-install:
${RM} -f ${STAGEDIR}${PREFIX}/etc/mime*
diff --git a/mail/wmmaiload/Makefile b/mail/wmmaiload/Makefile
index a56b07108009..57e6dd08f0f0 100644
--- a/mail/wmmaiload/Makefile
+++ b/mail/wmmaiload/Makefile
@@ -12,16 +12,14 @@ COMMENT= Incoming mail monitor dockapp with a similar look to wmcpuload
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= gmake localbase pkgconfig tar:bzip2
+USES= gmake localbase:ldflags pkgconfig ssl tar:bzip2
USE_XORG= xpm
USE_GNOME= gtk20
-USE_OPENSSL= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
-MAKE_ENV= DEBUG_CFLAGS="-I${OPENSSLINC}" \
- DEBUG_LDFLAGS="-L${OPENSSLLIB}"
-
-CFLAGS+= -D_GNU_SOURCE
+CPPFLAGS+= -I${OPENSSLINC} -D_GNU_SOURCE
+LDFLAGS+= -L${OPENSSLLIB}
+MAKE_ENV= DEBUG_CFLAGS="" DEBUG_LDFLAGS=""
PLIST_FILES= bin/wmmaiload bin/wmmaiload-config \
man/man1/wmmaiload.1.gz man/man1/wmmaiload-config.1.gz