aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-03 08:12:59 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-03 08:12:59 +0000
commit405c9ff689a406041fa859f85504434da98726a3 (patch)
treeaa4c75e6d0beaba3f9073ab5780b10fd5a588fd9 /mail
parentf67f0b4174d0dcdc18db4bcec0f077ee3b8d443e (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/liboe/Makefile24
-rw-r--r--mail/liboe/distinfo1
-rw-r--r--mail/liboe/pkg-comment1
-rw-r--r--mail/liboe/pkg-descr8
-rw-r--r--mail/liboe/pkg-plist3
6 files changed, 38 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index b73d59f36a45..8020e83595f2 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -57,6 +57,7 @@
SUBDIR += knewmail
SUBDIR += lbdb
SUBDIR += libesmtp
+ SUBDIR += liboe
SUBDIR += listar
SUBDIR += listmanager
SUBDIR += mahogany
diff --git a/mail/liboe/Makefile b/mail/liboe/Makefile
new file mode 100644
index 000000000000..75aa720a9b08
--- /dev/null
+++ b/mail/liboe/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# New ports collection makefile for: liboe
+# Date created: Jun 3, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboe
+PORTVERSION= 0.92
+CATEGORIES= mail
+MASTER_SITES= http://www.gpl.no/liboe/download/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+MAKEFILE= makefile
+ALL_TARGET= clean oe2mbx liboe
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^PREFIX,#PREFIX,g ; \
+ s,gcc,${CC} ${CFLAGS},g" ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/mail/liboe/distinfo b/mail/liboe/distinfo
new file mode 100644
index 000000000000..9f2a9fcf1328
--- /dev/null
+++ b/mail/liboe/distinfo
@@ -0,0 +1 @@
+MD5 (liboe-0.92.tar.gz) = 7bf5ddbf8de1ec5bd04d429c502a7e61
diff --git a/mail/liboe/pkg-comment b/mail/liboe/pkg-comment
new file mode 100644
index 000000000000..9fdabb400400
--- /dev/null
+++ b/mail/liboe/pkg-comment
@@ -0,0 +1 @@
+Convert Outlook Express messages to the Unix mailbox format
diff --git a/mail/liboe/pkg-descr b/mail/liboe/pkg-descr
new file mode 100644
index 000000000000..21f28f597f2a
--- /dev/null
+++ b/mail/liboe/pkg-descr
@@ -0,0 +1,8 @@
+liboe is a C library that reads Outlook Express 4 and 5.x mailboxes and
+returns a standard Unix mailbox to a function specified as a parameter to
+the converter
+
+oe2mbx is a C program using liboe to convert Outlook Express messages to
+the Unix mailbox format
+
+WWW: http://www.gpl.no/liboe/
diff --git a/mail/liboe/pkg-plist b/mail/liboe/pkg-plist
new file mode 100644
index 000000000000..73b36f516b82
--- /dev/null
+++ b/mail/liboe/pkg-plist
@@ -0,0 +1,3 @@
+bin/oe2mbx
+include/liboe.h
+lib/liboe.so