aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2006-12-11 14:05:23 +0000
committerClive Lin <clive@FreeBSD.org>2006-12-11 14:05:23 +0000
commit9bab5a25f342ac3f1d56705a55e79e62c301f3af (patch)
treedf2fb4d2f8501427874ce0d67190a2c0cb55dcbf /mail
parentfed84b4e925074f7b554b3c32b6609953f3eef47 (diff)
downloadports-9bab5a25f342ac3f1d56705a55e79e62c301f3af.tar.gz
ports-9bab5a25f342ac3f1d56705a55e79e62c301f3af.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/nullmailer/Makefile6
-rw-r--r--mail/nullmailer/distinfo6
-rw-r--r--mail/nullmailer/files/patch-doc-nullmailer-send.816
-rw-r--r--mail/nullmailer/files/patch-lib-list.h13
-rw-r--r--mail/nullmailer/files/patch-smtp_authentication127
-rw-r--r--mail/nullmailer/files/pkg-message.proto5
-rw-r--r--mail/nullmailer/files/remotes.sample2
7 files changed, 12 insertions, 163 deletions
diff --git a/mail/nullmailer/Makefile b/mail/nullmailer/Makefile
index 8cfbf11ba7f9..7e47556455b9 100644
--- a/mail/nullmailer/Makefile
+++ b/mail/nullmailer/Makefile
@@ -7,10 +7,10 @@
PORTNAME= nullmailer
PORTEPOCH= 1
-PORTVERSION= 1.00
+PORTVERSION= 1.03
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/nullmailer/ \
- ftp://mirrors.dataloss.nl/mirrors/bgware/nullmailer/%SUBDIR%/
+ http://untroubled.org/nullmailer/archive/
MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= clive@FreeBSD.org
@@ -19,7 +19,7 @@ COMMENT= MTA for hosts which relay to a fixed set of smart relays
HAS_CONFIGURE= yes
USE_SUBMAKE= yes
-CXXFLAGS+= -lstdc++
+
MAN1= nullmailer-inject.1 sendmail.1
MAN7= nullmailer.7
MAN8= nullmailer-queue.8 nullmailer-send.8
diff --git a/mail/nullmailer/distinfo b/mail/nullmailer/distinfo
index 1990828fbbc5..78c20faa1887 100644
--- a/mail/nullmailer/distinfo
+++ b/mail/nullmailer/distinfo
@@ -1,3 +1,3 @@
-MD5 (nullmailer-1.00.tar.gz) = ead32b3543ef652891edf3856ec759dd
-SHA256 (nullmailer-1.00.tar.gz) = 1ebb63f010a46dce9559b1025f76e74741429071cd2d4f380a63a5ced3ce8340
-SIZE (nullmailer-1.00.tar.gz) = 170605
+MD5 (nullmailer-1.03.tar.gz) = 4e94a84f359571b0872f398f0859a22a
+SHA256 (nullmailer-1.03.tar.gz) = 1471ab6c0c6038d7df4d301734e9e7f93b75147a954b52cb95e669c503fb9479
+SIZE (nullmailer-1.03.tar.gz) = 172250
diff --git a/mail/nullmailer/files/patch-doc-nullmailer-send.8 b/mail/nullmailer/files/patch-doc-nullmailer-send.8
deleted file mode 100644
index 670c5bbf2a20..000000000000
--- a/mail/nullmailer/files/patch-doc-nullmailer-send.8
+++ /dev/null
@@ -1,16 +0,0 @@
---- doc/nullmailer-send.8~ Sat Mar 5 10:13:38 2005
-+++ doc/nullmailer-send.8 Sat Mar 5 10:16:51 2005
-@@ -57,10 +57,11 @@
- The protocol name defaults to
- .IR smtp ,
- and may be followed by command-line arguments for that module.
--For example, to connect to port 2525 on your SMTP smart host, use:
-+For example, to connect to port 2525 on your SMTP smart host,
-+which also requires SMTP authentication, use:
-
- .EX
-- smarthost.dom smtp --port=2525
-+ smarthost.dom smtp --port=2525 --auth=user,pass
- .EE
-
- Blank lines and lines starting with a pound are ignored.
diff --git a/mail/nullmailer/files/patch-lib-list.h b/mail/nullmailer/files/patch-lib-list.h
deleted file mode 100644
index fc634a31af51..000000000000
--- a/mail/nullmailer/files/patch-lib-list.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/list.h~ Sat Mar 5 01:16:28 2005
-+++ lib/list.h Sat Mar 5 01:13:35 2005
-@@ -18,8 +18,8 @@
- typedef list_node<T> node;
- typedef list_iterator<T> iter;
- typedef const_list_iterator<T> const_iter;
-- friend class iter;
-- friend class const_iter;
-+ friend class list_iterator<T>;;
-+ friend class const_list_iterator<T>;;
-
- list()
- : head(0), tail(0), cnt(0)
diff --git a/mail/nullmailer/files/patch-smtp_authentication b/mail/nullmailer/files/patch-smtp_authentication
deleted file mode 100644
index ee91be69cef2..000000000000
--- a/mail/nullmailer/files/patch-smtp_authentication
+++ /dev/null
@@ -1,127 +0,0 @@
---- protocols/protocol.cc~ Sat Mar 5 09:38:23 2005
-+++ protocols/protocol.cc Sat Mar 5 09:39:42 2005
-@@ -30,10 +30,12 @@
- const char* cli_help_suffix = "";
- const char* cli_args_usage = "remote-address < mail-file";
- const int cli_args_min = 1;
--const int cli_args_max = 1;
-+const int cli_args_max = 2;
- cli_option cli_options[] = {
- { 'p', "port", cli_option::integer, 0, &port,
- "Set the port number on the remote host to connect to", 0 },
-+ { 'a', "auth", cli_option::string, 0, &auth,
-+ "Set the user and password for authentication (user,pass)", 0 },
- {0, 0, cli_option::flag, 0, 0, 0, 0}
- };
-
---- protocols/protocol.h~ Sat Mar 5 09:40:15 2005
-+++ protocols/protocol.h Sat Mar 5 09:40:46 2005
-@@ -8,6 +8,7 @@
-
- // This must be provided by the protocol, but will be set by the lib.
- extern int port;
-+extern char* auth;
-
- extern void protocol_prep(fdibuf* in);
- extern void protocol_send(fdibuf* in, int fd);
---- protocols/qmqp.cc~ Sat Mar 5 09:40:59 2005
-+++ protocols/qmqp.cc Sat Mar 5 09:41:21 2005
-@@ -31,6 +31,7 @@
- #include "protocol.h"
-
- int port = 628;
-+char* auth = "";
- const char* cli_program = "qmqp";
- const char* cli_help_prefix = "Send an emal message via QMQP\n";
-
---- protocols/smtp.cc~ Sat Mar 5 09:41:31 2005
-+++ protocols/smtp.cc Sat Mar 5 09:44:58 2005
-@@ -30,6 +30,7 @@
- #include "protocol.h"
-
- int port = 25;
-+char* auth = "";
- const char* cli_program = "smtp";
- const char* cli_help_prefix = "Send an email message via SMTP\n";
-
-@@ -136,6 +137,11 @@
- {
- }
-
-+void to64(char* infile, char* outfile);
-+void to64(const mystring& infile, mystring& outfile);
-+void output64chunk(int c1, int c2, int c3, int pads, char** outfile);
-+void output64chunk(int c1, int c2, int c3, int pads, mystring& outfile);
-+
- void protocol_send(fdibuf* in, int fd)
- {
- mystring hh = getenv("HELOHOST");
-@@ -143,5 +149,68 @@
- smtp conn(fd);
- conn.docmd("", 200);
- conn.docmd("HELO " + hh, 200);
-+
-+ if ( strlen(auth) > 0 )
-+ {
-+ mystring authstr = auth;
-+ mystring uname = authstr.left(authstr.find_first(','));
-+ mystring pass = authstr.sub(authstr.find_first(',')+1,authstr.length());
-+ mystring plain = uname + "\1" + uname + "\1" + pass;
-+ mystring encoded = "AUTH PLAIN ";
-+ to64(plain,encoded);
-+ conn.docmd(encoded,200);
-+ }
-+
- conn.send(in);
- }
-+
-+static char basis_64[] =
-+ "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
-+
-+void to64(const mystring& infile, mystring& outfile)
-+{
-+ int c1, c2, c3;
-+ size_t inpos = 0;
-+ while ((c1 = infile[inpos++])) {
-+ c2 = infile[inpos++];
-+ if (!c2) {
-+ output64chunk(c1, 0, 0, 2, outfile);
-+ } else {
-+ c3 = infile[inpos++];
-+ if (!c3) {
-+ output64chunk(c1, c2, 0, 1, outfile);
-+ } else {
-+ output64chunk(c1, c2, c3, 0, outfile);
-+ }
-+ }
-+ }
-+}
-+
-+void output64chunk(int c1, int c2, int c3, int pads, mystring& outfile)
-+{
-+ if (c1==1) c1 = 0;
-+ if (c2==1) c2 = 0;
-+ if (c3==1) c3 = 0;
-+
-+ char out[5];
-+ out[0] = basis_64[c1>>2];
-+ out[1] = basis_64[((c1 & 0x3)<< 4) | ((c2 & 0xF0) >> 4)];
-+ switch (pads)
-+ {
-+ case 0:
-+ out[2] = basis_64[((c2 & 0xF) << 2) | ((c3 & 0xC0) >>6)];
-+ out[3] = basis_64[c3 & 0x3F];
-+ break;
-+ case 1:
-+ out[2] = basis_64[((c2 & 0xF) << 2) | ((c3 & 0xC0) >>6)];
-+ out[3] = '=';
-+ break;
-+ case 2:
-+ out[2] = '=';
-+ out[3] = '=';
-+ break;
-+ };
-+ out[4] = 0;
-+ outfile += out;
-+}
-+
diff --git a/mail/nullmailer/files/pkg-message.proto b/mail/nullmailer/files/pkg-message.proto
index 31cd29851229..abea721d7dad 100644
--- a/mail/nullmailer/files/pkg-message.proto
+++ b/mail/nullmailer/files/pkg-message.proto
@@ -13,4 +13,9 @@ mailq %%PREFIX%%/libexec/nullmailer/mailq
WARNING! It will cause problem in case delivering to local recipients.
Also man nullmailer-send(8) for more details
+NOTE for the ones upgrading from 1.00:
+The smtp authentication option has been changed from
+--auth=joe,secret to --user=joe and --pass=secret, see nullmailer-send(8)
+for details.
+
==================================================================
diff --git a/mail/nullmailer/files/remotes.sample b/mail/nullmailer/files/remotes.sample
index ed99b002be5c..b471cabf7321 100644
--- a/mail/nullmailer/files/remotes.sample
+++ b/mail/nullmailer/files/remotes.sample
@@ -1 +1 @@
-localhost smtp --port=25 --auth=user,pass
+localhost smtp --port=25 --user=user --pass=pass