aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-09-08 21:46:13 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-09-08 21:46:13 +0000
commit1f37352beb83383ab1f65f9a5321e600b318ba8d (patch)
tree94322ad272d913c3ddc6d8c57dd42531160d28b9 /mail
parent1da1b1f812d520417280c117184ed6ac320b04f5 (diff)
downloadports-1f37352beb83383ab1f65f9a5321e600b318ba8d.tar.gz
ports-1f37352beb83383ab1f65f9a5321e600b318ba8d.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile2
-rw-r--r--mail/bogofilter-kc/Makefile21
-rw-r--r--mail/bogofilter-lmdb/Makefile21
-rw-r--r--mail/bogofilter-sqlite/Makefile3
-rw-r--r--mail/bogofilter-tc/Makefile6
-rw-r--r--mail/bogofilter/Makefile24
-rw-r--r--mail/bogofilter/distinfo5
7 files changed, 66 insertions, 16 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ad087b1e6528..d965394bc3e5 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -36,6 +36,8 @@
SUBDIR += bincimap
SUBDIR += bmf
SUBDIR += bogofilter
+ SUBDIR += bogofilter-kc
+ SUBDIR += bogofilter-lmdb
SUBDIR += bogofilter-sqlite
SUBDIR += bogofilter-tc
SUBDIR += bsfilter
diff --git a/mail/bogofilter-kc/Makefile b/mail/bogofilter-kc/Makefile
new file mode 100644
index 000000000000..d6c1a0235557
--- /dev/null
+++ b/mail/bogofilter-kc/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= bogofilter
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -kc
+
+MAINTAINER= mandree@FreeBSD.org
+
+LIB_DEPENDS= libkyotocabinet.so:databases/kyotocabinet
+
+CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-lmdb-[0-9]* bogofilter-sqlite-[0-9]* bogofilter-tc-[0-9]*
+
+CONFIGURE_ARGS= --with-database=kyotocabinet
+BF_CPPFLAGS= -I${LOCALBASE}/include
+BF_LIBS=
+DESCR= ${PKGDIR}/pkg-descr
+
+MASTERDIR= ${.CURDIR}/../bogofilter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/bogofilter-lmdb/Makefile b/mail/bogofilter-lmdb/Makefile
new file mode 100644
index 000000000000..1c0068bd3670
--- /dev/null
+++ b/mail/bogofilter-lmdb/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= bogofilter
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -lmdb
+
+MAINTAINER= mandree@FreeBSD.org
+
+LIB_DEPENDS= liblmdb.so:databases/lmdb
+
+CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-kc-[0-9]* bogofilter-sqlite-[0-9]* *bogofilter-tc-[0-9]*
+
+CONFIGURE_ARGS= --with-database=lmdb
+BF_CPPFLAGS= -I${LOCALBASE}/include
+BF_LIBS=
+DESCR= ${PKGDIR}/pkg-descr
+
+MASTERDIR= ${.CURDIR}/../bogofilter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
index 963813e95b3b..07f2a58c2b1f 100644
--- a/mail/bogofilter-sqlite/Makefile
+++ b/mail/bogofilter-sqlite/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= bogofilter
-PORTREVISION= 4
CATEGORIES= mail
PKGNAMESUFFIX= -sqlite
MAINTAINER= mandree@FreeBSD.org
USES= sqlite
-CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
+CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-lmdb-[0-9]* bogofilter-kc-[0-9]* bogofilter-tc-[0-9]*
CONFIGURE_ARGS= --with-database=sqlite
BF_CPPFLAGS= -I${LOCALBASE}/include
diff --git a/mail/bogofilter-tc/Makefile b/mail/bogofilter-tc/Makefile
index f1a672b5b867..9e03b3e6eb9b 100644
--- a/mail/bogofilter-tc/Makefile
+++ b/mail/bogofilter-tc/Makefile
@@ -2,16 +2,18 @@
# $FreeBSD$
PORTNAME= bogofilter
-PORTREVISION= 3
CATEGORIES= mail
PKGNAMESUFFIX= -tc
+DEPRECATED= TokyoCabinet is being phased out in favor of KyotoCabinet.
+EXPIRATION_DATE=2020-12-31
+
MAINTAINER= mandree@FreeBSD.org
# Blanket approval for changes by Zach Thompson (address above)
LIB_DEPENDS= libtokyocabinet.so:databases/tokyocabinet
-CONFLICTS_INSTALL= bogofilter-[0-9]* [a-z][a-z]-bogofilter-[1-9]* bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]*
+CONFLICTS_INSTALL= bogofilter-[0-9]* bogofilter-sqlite-[0-9]* bogofilter-kc-[0-9]* bogofilter-lmdb-[0-9]*
CONFIGURE_ARGS= --with-database=tokyocabinet
BF_CPPFLAGS= -I${LOCALBASE}/include
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index a244c05ba566..a07141515ce1 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= bogofilter
-PORTVERSION= 1.2.4
-PORTREVISION?= 8
+DISTVERSION= 1.2.5.rc1
+PORTREVISION?= 0
CATEGORIES?= mail
-MASTER_SITES= SF/bogofilter/bogofilter-current/bogofilter-${PORTVERSION}
+MASTER_SITES= SF/bogofilter/bogofilter-current/bogofilter-1.2.5/
MAINTAINER?= mandree@FreeBSD.org
COMMENT= Fast, teachable, learning spam detector
@@ -22,9 +22,13 @@ OPTIONS_DEFAULT= GSL UNICODE
GSL_DESC= Link with system-wide GSL dynamically (recommended)
UNICODE_DESC= Normalize tokens to Unicode (UTF-8) (recommended)
-CONFLICTS_INSTALL?= bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
+CONFLICTS_INSTALL?= bogofilter-sqlite-[0-9]* bogofilter-tc-[0-9]* bogofilter-lmdb-[0-9]* \
+ bogofilter-kc-[0-9]*
-USES+= cpe perl5 shebangfix tar:bzip2
+# XXX FIXME: autoreconf:build should not be required,
+# but something hoses timestamps on src/tests/Makefile.am
+# but not src/tests/Makefile.in.
+USES+= autoreconf:build cpe perl5 shebangfix tar:xz
SHEBANG_FILES= contrib/randomtrain.sh contrib/scramble.sh \
src/tests/unsort.pl contrib/*.pl
USE_PERL5= run
@@ -59,16 +63,16 @@ post-patch:
-e 's/ENVIRON_TESTS = t.abort/ENVIRON_TESTS =/' \
${WRKSRC}/src/tests/Makefile.am
-# XXX: disable self-tests until issue with automake-1.13 is sorted out
-# post-build::
-# cd ${WRKSRC}/src && make check SHELL=${SH}
+post-build:
+ cd ${WRKSRC}/src && ${SETENV} SHELL=${SH} ${MAKE_CMD} ${TEST_TARGET} ${_MAKE_JOBS} SHELL=${SH} \
+ || { r=$$? ; head -n30000 ${WRKSRC}/src/tests/test-suite.log ; exit $$r ; }
-post-install::
+post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/contrib
.for i in html programmer xml
@${MKDIR} ${STAGEDIR}${DOCSDIR}/${i}
.endfor
-.for i in AUTHORS COPYING INSTALL NEWS README README.svn \
+.for i in AUTHORS COPYING INSTALL NEWS README README.git \
doc/README.validation TODO GETTING.STARTED \
RELEASE.NOTES doc/README.db doc/README.sqlite \
doc/integrating-with-postfix doc/integrating-with-qmail \
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index edf94524a2e7..18176c8f62d7 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bogofilter-1.2.4.tar.bz2) = e10287a58d135feaea26880ce7d4b9fa2841fb114a2154bf7da8da98aab0a6b4
-SIZE (bogofilter-1.2.4.tar.bz2) = 887848
+TIMESTAMP = 1567975270
+SHA256 (bogofilter-1.2.5.rc1.tar.xz) = 62a9a00ca575b1253bafd5ae308049cbf388816e5ef0a9a18ee8167cf6c42680
+SIZE (bogofilter-1.2.5.rc1.tar.xz) = 802008