aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-04-11 00:51:02 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2014-04-11 00:51:02 +0000
commitaa5812b1b095488e37d27f6966c2b1f84b4ff41f (patch)
treef1552adaefa521b213911b7db31ff8a8d4b779c7 /mail
parentdc43860dcd1162fe10b34c166a16c5645f82b213 (diff)
- Update to 5.4.33
- Move auth options into its own single group - Clarify PASSWD and VALIAS options Changes: (* was already applied in our 5.4.32) Matt Brookings * - Defaulted to Server::Disable=True in vusagec.conf * - Fixed bug that didn't install vusagec.conf - Changed relevant quota code to use storage_t 64bit type - Fixed bug where backfill code wouldn't compile when FILE_LOCKING was enabled - Updated MySQL module to support larger quota sizes - Fixed typo - Added disable_maildrop flag to MySQL limits feature - More changes to allow for larger quota sizes in MySQL module Tullio Andreatta - Dynamic allocation of valias data - Use of open/fchdir rather than getcwd/chdir to maintain current working directory - Fixed a broken symbolic link check Drew Wells - Modification to vdelivermail to properly handle Maildir paths that begin with "./" <kenji@kens.fm> - Removed call to maildir_addquota inside user_over_maildirquota causing duplicate maildirsize entries
Notes
Notes: svn path=/head/; revision=350866
Diffstat (limited to 'mail')
-rw-r--r--mail/vpopmail/Makefile17
-rw-r--r--mail/vpopmail/distinfo4
-rw-r--r--mail/vpopmail/files/patch-Makefile.in8
-rw-r--r--mail/vpopmail/files/patch-vpopmail.c35
-rw-r--r--mail/vpopmail/files/patch-vusagec.conf17
5 files changed, 31 insertions, 50 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index 82302ce8bef4..c917c6912cbc 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vpopmail
-PORTVERSION= 5.4.32
-PORTREVISION= 5
+PORTVERSION= 5.4.33
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}-devel/${PORTVERSION}
@@ -47,14 +46,8 @@ OPTIONS_DEFINE= DOCS \
MD5_PASSWORDS \
CLEAR_PASSWD \
LEARN_PASSWORDS \
- MYSQL \
MYSQL_REPLICATION \
MYSQL_LIMITS \
- PGSQL \
- SYBASE \
- ORACLE \
- LDAP \
- LDAP_SASL \
VALIAS \
ROAMING \
IP_ALIAS \
@@ -75,8 +68,11 @@ OPTIONS_DEFINE= DOCS \
AUTH_LOG \
SQL_LOG \
SQL_LOG_TRIM
+OPTIONS_SINGLE= AUTH
+OPTIONS_SINGLE_AUTH= CDB MYSQL PGSQL LDAP LDAP_SASL ORACLE SYBASE
OPTIONS_DEFAULT=MD5_PASSWORDS \
+ CDB \
ROAMING \
FILE_LOCKING \
USERS_BIG_DIR \
@@ -84,7 +80,8 @@ OPTIONS_DEFAULT=MD5_PASSWORDS \
FPIC \
AUTH_LOG
-PASSWD_DESC= Auth via /etc/passwd
+CDB_DESC= Auth via CDB
+PASSWD_DESC= /etc/passwd account support
MYSQL_DESC= Auth via MySQL
PGSQL_DESC= Auth via PostgreSQL
SYBASE_DESC= Auth via Sybase
@@ -96,7 +93,7 @@ MYSQL_LIMITS_DESC= MySQL mailbox limitations support
ORACLE_DESC= Auth via Oracle
LDAP_DESC= Auth via LDAP
LDAP_SASL_DESC= Auth via LDAP SASL
-VALIAS_DESC= valias processing
+VALIAS_DESC= Store aliases in DB instead of .qmail files
ROAMING_DESC= roaming users support
IP_ALIAS_DESC= IP alias support
QMAIL_EXT_DESC= qmail-like user-* address support
diff --git a/mail/vpopmail/distinfo b/mail/vpopmail/distinfo
index 34df20440dbf..d90920e0db21 100644
--- a/mail/vpopmail/distinfo
+++ b/mail/vpopmail/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vpopmail-5.4.32.tar.gz) = 20dc467d46703f7f9fb5ab5f77929ed599cbdc73fb0490691f41210ed76776b6
-SIZE (vpopmail-5.4.32.tar.gz) = 612426
+SHA256 (vpopmail-5.4.33.tar.gz) = 383c7436dfb18e773336f608f1771fc08559143c4f3938a5807a0cc5994c44f4
+SIZE (vpopmail-5.4.33.tar.gz) = 612271
diff --git a/mail/vpopmail/files/patch-Makefile.in b/mail/vpopmail/files/patch-Makefile.in
index bbabb8bcafdc..ac39e150b55d 100644
--- a/mail/vpopmail/files/patch-Makefile.in
+++ b/mail/vpopmail/files/patch-Makefile.in
@@ -1,19 +1,19 @@
Description: Install config files with -dist, do not add -fPIC.
Install the config files with a -dist extension.
Do not unconditionally add -fPIC, this is done only for shared libs.
- Actually look for and install the vusagec.conf sample file!
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-09-13
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -357,12 +357,12 @@
+--- Makefile.in.orig 2011-02-28 11:00:45.000000000 -0600
++++ Makefile.in 2014-04-10 11:17:21.360658218 -0500
+@@ -357,13 +357,12 @@
noinst_HEADERS = md5.h vpopmail.h file_lock.h vauth.h vlimits.h maildirquota.h vcdb.h vldap.h vmysql.h voracle.h vpgsql.h vsybase.h vlog.h global.h hmac_md5.h seek.h vutil.h
COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c vutil.c vlistlib.c backfill.c client.c conf.c ippp.c
CONFIG_CLEAN_FILES = vauth.c cdb/conf-cc cdb/conf-ld cdb/compile cdb/load
-MYSQLCONF = $(DESTDIR)@vpopmaildir@/etc/vpopmail.mysql
-VLIMITS = $(DESTDIR)@vpopmaildir@/etc/vlimits.default
+-VUSAGECCONF = $(DESTDIR)@vpopmaildir@/etc/vusagec.conf
+MYSQLCONF = $(DESTDIR)@vpopmaildir@/etc/vpopmail.mysql-dist
+VLIMITS = $(DESTDIR)@vpopmaildir@/etc/vlimits.default-dist
+VUSAGECCONF = $(DESTDIR)@vpopmaildir@/etc/vusagec.conf-dist
diff --git a/mail/vpopmail/files/patch-vpopmail.c b/mail/vpopmail/files/patch-vpopmail.c
index 8f496ed0eff2..1fd11de9186e 100644
--- a/mail/vpopmail/files/patch-vpopmail.c
+++ b/mail/vpopmail/files/patch-vpopmail.c
@@ -9,9 +9,9 @@ Author: Peter Pentchev <roam@FreeBSD.org>,
Alex Dupre <ale@FreeBSD.org>
Last-Update: 2009-11-26
---- a/vpopmail.c
-+++ b/vpopmail.c
-@@ -945,6 +945,7 @@
+--- vpopmail.c.orig 2011-02-28 11:00:45.000000000 -0600
++++ vpopmail.c 2014-04-10 11:20:59.892641589 -0500
+@@ -981,6 +981,7 @@ int vdelfiles(char *dir)
/* print error message and return and error */
fprintf (stderr, "Failed to delete directory %s", mydirent->d_name);
@@ -19,7 +19,7 @@ Last-Update: 2009-11-26
return(-1);
}
}
-@@ -1563,7 +1564,7 @@
+@@ -1603,7 +1604,7 @@ while(( s[i]==' ')||(s[i]=='\t')) {
i++;
}
@@ -28,7 +28,7 @@ Last-Update: 2009-11-26
if( i>0 ) {
for( j=0; j<k; j++ ) {
-@@ -1575,7 +1576,7 @@
+@@ -1615,7 +1616,7 @@ if( i>0 ) {
// trim spaces and tabs from end
i = strlen(s) - 1;
@@ -37,8 +37,8 @@ Last-Update: 2009-11-26
i--;
}
-@@ -2348,7 +2349,12 @@
- char calling_dir[MAX_BUFF];
+@@ -2387,7 +2388,12 @@ char *make_user_dir(char *username, char
+ int call_dir;
char domain_dir[MAX_BUFF];
const char *dirnames[] = {"Maildir", "Maildir/new", "Maildir/cur",
- "Maildir/tmp"};
@@ -51,21 +51,21 @@ Last-Update: 2009-11-26
int i;
verrori = 0;
-@@ -3114,6 +3120,13 @@
- if (mkdir("cur",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
- if (mkdir("new",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
- if (mkdir("tmp",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
+@@ -3154,6 +3160,13 @@ int vmake_maildir(char *domain, char *di
+ if (mkdir("cur",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
+ if (mkdir("new",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
+ if (mkdir("tmp",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
+#ifdef SPAM_JUNKFOLDER
-+ if (mkdir(".Junk",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
-+ if (chdir(".Junk") == -1) { chdir(calling_dir); return(-1); }
-+ if (mkdir("cur",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
-+ if (mkdir("new",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
-+ if (mkdir("tmp",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
++ if (mkdir(".Junk",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
++ if (chdir(".Junk") == -1) { fchdir(call_dir); close(call_dir); return(-1); }
++ if (mkdir("cur",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
++ if (mkdir("new",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
++ if (mkdir("tmp",VPOPMAIL_DIR_MODE) == -1) { fchdir(call_dir); close(call_dir); return(-1); }
+#endif
/* set permissions on the user's dir */
chdir(dir);
-@@ -4163,11 +4176,19 @@
+@@ -4220,12 +4233,20 @@ int call_onchange ( const char *cmd )
}
else if ( pid > 0 )
{
@@ -89,3 +89,4 @@ Last-Update: 2009-11-26
+ return(rv);
}
#endif
+
diff --git a/mail/vpopmail/files/patch-vusagec.conf b/mail/vpopmail/files/patch-vusagec.conf
deleted file mode 100644
index e1ce2aa6ec75..000000000000
--- a/mail/vpopmail/files/patch-vusagec.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Disable vusage.conf since we don't install vusaged at all.
- Tracked down by: Renato Botelho <garga@FreeBSD.org>
-Forwarded: not-needed
-Author: Peter Pentchev <roam@FreeBSD.org>
-Last-Update: 2010-02-09
-
---- a/vusagec.conf
-+++ b/vusagec.conf
-@@ -23,7 +23,7 @@
- True or False
- */
-
-- Disable = False;
-+ Disable = True;
-
- /*
- Daemon is listening on local socket