aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-05-31 20:31:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-05-31 20:31:08 +0000
commitaa952fd48fe9143007307348e16bccf3b9f95ca9 (patch)
tree3b8a3dc07f043f3e20ba7e542d841e8086021135 /mail
parent06f1947ff91cd30655ff4ea79c4400e4c07e7bab (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/dbmail23/Makefile1
-rw-r--r--mail/dovecot-devel/Makefile1
-rw-r--r--mail/gmime24/Makefile2
-rw-r--r--mail/james/Makefile1
-rw-r--r--mail/qmail-scanner1/Makefile1
-rw-r--r--mail/squirrelmail-compatibility-plugin1/Makefile1
6 files changed, 5 insertions, 2 deletions
diff --git a/mail/dbmail23/Makefile b/mail/dbmail23/Makefile
index 552cf81b4037..ff4f3f14e24d 100644
--- a/mail/dbmail23/Makefile
+++ b/mail/dbmail23/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS+= mhash.2:${PORTSDIR}/security/mhash
LIB_DEPENDS+= zdb.6:${PORTSDIR}/databases/libzdb
CONFLICTS= dbmail-*-2.0.* dbmail-2.1.* dbmail-2.2.*
+NO_LATEST_LINK= yes
OPTIONS= MYSQL "Build with MySQL support" on \
POSTGRESQL "Build with PostgreSQL support" off \
diff --git a/mail/dovecot-devel/Makefile b/mail/dovecot-devel/Makefile
index ffbb5d591ecc..91bd20b758d4 100644
--- a/mail/dovecot-devel/Makefile
+++ b/mail/dovecot-devel/Makefile
@@ -20,6 +20,7 @@ USE_RC_SUBR= dovecot.sh
DEPRECATED= Please use mail/dovecot instead
CONFLICTS?= ${PORTNAME}-1.[02-9].*
+NO_LATEST_LINK= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-shadow --localstatedir=/var
diff --git a/mail/gmime24/Makefile b/mail/gmime24/Makefile
index 88718a78bda1..a8695c42246b 100644
--- a/mail/gmime24/Makefile
+++ b/mail/gmime24/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS?= --with-libiconv=${LOCALBASE} \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib"
-LATEST_LINK?= ${PORTNAME}2
+LATEST_LINK?= ${PORTNAME}24
post-patch:
@${REINPLACE_CMD} -e "s|stdint.h|inttypes.h|" ${WRKSRC}/zentimer.h
diff --git a/mail/james/Makefile b/mail/james/Makefile
index 545995325be5..b9f3b14cad3b 100644
--- a/mail/james/Makefile
+++ b/mail/james/Makefile
@@ -26,7 +26,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
APP_HOME?= ${PREFIX}/${PKGBASE}${PORTVERSION}
PID_FILE= /var/run/${APP_SHORTNAME}.pid
PLIST_SUB+= T=${APP_HOME:S/^${PREFIX}\///}
-LATEST_LINK= ${APP_SHORTNAME}
SUB_LIST= JAVA_HOME=${JAVA_HOME} \
PID_FILE=${PID_FILE} \
diff --git a/mail/qmail-scanner1/Makefile b/mail/qmail-scanner1/Makefile
index ba9a1e9f17a2..ac183f70b72c 100644
--- a/mail/qmail-scanner1/Makefile
+++ b/mail/qmail-scanner1/Makefile
@@ -22,6 +22,7 @@ BUILD_DEPENDS= reformime:${PORTSDIR}/mail/maildrop \
MANUAL_PACKAGE_BUILD= Requires qmail built with non-standard setting
+NO_LATEST_LINK= yes
CONFLICTS= qmail-scanner-2.*
QMAIL_QUEUE= ${QMAIL_PREFIX}/bin/qmail-queue
diff --git a/mail/squirrelmail-compatibility-plugin1/Makefile b/mail/squirrelmail-compatibility-plugin1/Makefile
index 6e6862b44cfb..5f3408b49a13 100644
--- a/mail/squirrelmail-compatibility-plugin1/Makefile
+++ b/mail/squirrelmail-compatibility-plugin1/Makefile
@@ -19,6 +19,7 @@ COMMENT= Required by many plugins for compatibility with SquirrelMail
RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail
CONFLICTS= squirrelmail-compatibility-plugin-2.*
+NO_LATEST_LINK= yes
SQUIRREL_PLUGIN_NAME= ${PORTNAME}