aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-07-15 16:47:45 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-07-15 16:47:45 +0000
commite6246d1055202098dd1df8f2a827665d39dddde8 (patch)
tree6a8029cf8aa42fc328c40fc63ed5d1ae25d0c255 /mail
parenta7000e3a390271ff985d84e575f89d8239e49aa7 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/balsa/Makefile3
-rw-r--r--mail/claws-mail/Makefile1
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt-devel/files/patch-crypt-gpgme.c10
-rw-r--r--mail/sylpheed/Makefile4
-rw-r--r--mail/sylpheed2/Makefile3
-rw-r--r--mail/sylpheed3/Makefile3
7 files changed, 20 insertions, 6 deletions
diff --git a/mail/balsa/Makefile b/mail/balsa/Makefile
index 08253ff1859d..53932a69361f 100644
--- a/mail/balsa/Makefile
+++ b/mail/balsa/Makefile
@@ -8,6 +8,7 @@
PORTNAME= balsa
PORTVERSION= 2.3.28
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
DISTNAME= balsa-${PORTVERSION}
@@ -50,7 +51,7 @@ OPTIONS= LDAP "Enable LDAP support" on \
.include <bsd.port.pre.mk>
.if defined(WITH_GPG)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}/bin/gpgme-config
.endif
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 74c33f1e5507..64b6b6a33358 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= claws-mail
PORTVERSION= 3.7.2
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= SF/sylpheed-claws
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index fb2352b0382e..d46d26d1d5e6 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -115,7 +115,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.20
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
diff --git a/mail/mutt-devel/files/patch-crypt-gpgme.c b/mail/mutt-devel/files/patch-crypt-gpgme.c
new file mode 100644
index 000000000000..2fb9536f3cd6
--- /dev/null
+++ b/mail/mutt-devel/files/patch-crypt-gpgme.c
@@ -0,0 +1,10 @@
+--- ./crypt-gpgme.c.orig 2009-07-01 21:28:51.000000000 -0400
++++ ./crypt-gpgme.c 2009-07-01 21:31:52.000000000 -0400
+@@ -342,6 +342,7 @@
+ gpgme_error_t err;
+ gpgme_ctx_t ctx;
+
++ gpgme_check_version (NULL);
+ if (!GpgmeLocaleSet)
+ {
+ gpgme_set_locale (NULL, LC_CTYPE, setlocale (LC_CTYPE, NULL));
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 635e77c497de..3a87fbce9477 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 1.0.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v1.0/
@@ -49,7 +49,7 @@ CONFIGURE_ARGS+=--disable-imlib
CONFIGURE_ARGS+=--disable-gdk-pixbuf
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index e6c1d84e0c30..9cf56fe36fb1 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/
@@ -52,7 +53,7 @@ CONFIGURE_ARGS+=--disable-ssl
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index e6c1d84e0c30..9cf56fe36fb1 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/
@@ -52,7 +53,7 @@ CONFIGURE_ARGS+=--disable-ssl
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.else