aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-12-02 00:45:49 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-12-02 00:45:49 +0000
commit2227e221a1010ebfb6a983905f382e604bb23bd5 (patch)
tree959845570f5d700d219c690c4302c43e4acc7419 /mail
parent08a9421aaf2f898ccbf80cf7d0edd9a056c047da (diff)
downloadports-2227e221a1010ebfb6a983905f382e604bb23bd5.tar.gz
ports-2227e221a1010ebfb6a983905f382e604bb23bd5.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/gmail/Makefile10
-rw-r--r--mail/mmc/Makefile8
2 files changed, 14 insertions, 4 deletions
diff --git a/mail/gmail/Makefile b/mail/gmail/Makefile
index 0bc21cf86886..29adeb312447 100644
--- a/mail/gmail/Makefile
+++ b/mail/gmail/Makefile
@@ -12,8 +12,6 @@ MASTER_SITES= http://gmail.linuxpower.org/
MAINTAINER= baskruit@bsltwr.dnsalias.org
-BROKEN= "Does not build"
-
LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client \
gmime.6:${PORTSDIR}/mail/gmime
@@ -22,4 +20,10 @@ USE_GMAKE= YES
USE_GNOME= YES
USE_LIBTOOL= YES
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/mmc/Makefile b/mail/mmc/Makefile
index c5278b6a9f00..2e1a47e12a61 100644
--- a/mail/mmc/Makefile
+++ b/mail/mmc/Makefile
@@ -22,6 +22,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -29,4 +35,4 @@ pre-patch:
's|\$$\(gnomedatadir\)/gnome/|\$$\(datadir\)/|g ; \
s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>