aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2001-03-01 13:05:47 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2001-03-01 13:05:47 +0000
commit4c8ae3e1933d6d5ce0c191249ef3408687443c46 (patch)
tree83b83949929206bef63246baff6585adca962686 /mail
parentd8cb00b627e29caa8aa8e9d90be28e9c51f775ac (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/vpopmail-devel/Makefile14
-rw-r--r--mail/vpopmail-stable/Makefile14
-rw-r--r--mail/vpopmail/Makefile14
3 files changed, 30 insertions, 12 deletions
diff --git a/mail/vpopmail-devel/Makefile b/mail/vpopmail-devel/Makefile
index f5f37ed80fca..5e4d50169e5a 100644
--- a/mail/vpopmail-devel/Makefile
+++ b/mail/vpopmail-devel/Makefile
@@ -50,7 +50,7 @@ CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
HARDQUOTA?= 10000000
RELAYCLEAR?= 30
LOGLEVEL?= y
-APOPFILE?= /etc/apop-secrets
+APOPFILE?= /usr/local/vpopmail/etc/apop-secrets
.if exists(${LOCALBASE}/qmail/bin/qmail-send)
QMAIL_DIR?= ${LOCALBASE}/qmail
@@ -80,6 +80,12 @@ CONFIGURE_ARGS+= --enable-passwd=n
.if defined(WITH_APOP)
CONFIGURE_ARGS+= --enable-apop=y \
--enable-apop-file=${APOPFILE}
+.else
+CONFIGURE_ARGS+= --enable-apop=n
+.endif
+
+.if !defined(WITH_SQWEBMAIL)
+CONFIGURE_ARGS+= --enable-sqwebmail-pass=n
.endif
.if !defined(WITHOUT_ROAMING)
@@ -89,9 +95,9 @@ CONFIGURE_ARGS+= --enable-roaming-users=y \
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= --with-mysql=y \
- --with-sqlincdir=${LOCALBASE}/include/mysql \
- --with-sqllibdir=${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+= --enable-mysql=y \
+ --enable-sqlincdir=${LOCALBASE}/include/mysql \
+ --enable-sqllibdir=${LOCALBASE}/lib/mysql
.endif
.if defined(DEFAULT_DOMAIN)
diff --git a/mail/vpopmail-stable/Makefile b/mail/vpopmail-stable/Makefile
index f5f37ed80fca..5e4d50169e5a 100644
--- a/mail/vpopmail-stable/Makefile
+++ b/mail/vpopmail-stable/Makefile
@@ -50,7 +50,7 @@ CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
HARDQUOTA?= 10000000
RELAYCLEAR?= 30
LOGLEVEL?= y
-APOPFILE?= /etc/apop-secrets
+APOPFILE?= /usr/local/vpopmail/etc/apop-secrets
.if exists(${LOCALBASE}/qmail/bin/qmail-send)
QMAIL_DIR?= ${LOCALBASE}/qmail
@@ -80,6 +80,12 @@ CONFIGURE_ARGS+= --enable-passwd=n
.if defined(WITH_APOP)
CONFIGURE_ARGS+= --enable-apop=y \
--enable-apop-file=${APOPFILE}
+.else
+CONFIGURE_ARGS+= --enable-apop=n
+.endif
+
+.if !defined(WITH_SQWEBMAIL)
+CONFIGURE_ARGS+= --enable-sqwebmail-pass=n
.endif
.if !defined(WITHOUT_ROAMING)
@@ -89,9 +95,9 @@ CONFIGURE_ARGS+= --enable-roaming-users=y \
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= --with-mysql=y \
- --with-sqlincdir=${LOCALBASE}/include/mysql \
- --with-sqllibdir=${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+= --enable-mysql=y \
+ --enable-sqlincdir=${LOCALBASE}/include/mysql \
+ --enable-sqllibdir=${LOCALBASE}/lib/mysql
.endif
.if defined(DEFAULT_DOMAIN)
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index f5f37ed80fca..5e4d50169e5a 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -50,7 +50,7 @@ CONFIGURE_ARGS= --enable-qmail-dir=${QMAIL_DIR} \
HARDQUOTA?= 10000000
RELAYCLEAR?= 30
LOGLEVEL?= y
-APOPFILE?= /etc/apop-secrets
+APOPFILE?= /usr/local/vpopmail/etc/apop-secrets
.if exists(${LOCALBASE}/qmail/bin/qmail-send)
QMAIL_DIR?= ${LOCALBASE}/qmail
@@ -80,6 +80,12 @@ CONFIGURE_ARGS+= --enable-passwd=n
.if defined(WITH_APOP)
CONFIGURE_ARGS+= --enable-apop=y \
--enable-apop-file=${APOPFILE}
+.else
+CONFIGURE_ARGS+= --enable-apop=n
+.endif
+
+.if !defined(WITH_SQWEBMAIL)
+CONFIGURE_ARGS+= --enable-sqwebmail-pass=n
.endif
.if !defined(WITHOUT_ROAMING)
@@ -89,9 +95,9 @@ CONFIGURE_ARGS+= --enable-roaming-users=y \
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= --with-mysql=y \
- --with-sqlincdir=${LOCALBASE}/include/mysql \
- --with-sqllibdir=${LOCALBASE}/lib/mysql
+CONFIGURE_ARGS+= --enable-mysql=y \
+ --enable-sqlincdir=${LOCALBASE}/include/mysql \
+ --enable-sqllibdir=${LOCALBASE}/lib/mysql
.endif
.if defined(DEFAULT_DOMAIN)