aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-03 19:44:26 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-03 19:44:26 +0000
commit4f008d725474533a1cd77c99faed8f7ae34df8d4 (patch)
tree5e95a00e2dbdad5443e9ac71898320cf574dad5b /mail
parenteabc22a00d5bab47c760609160d9d6ec03aea5d1 (diff)
downloadports-4f008d725474533a1cd77c99faed8f7ae34df8d4.tar.gz
ports-4f008d725474533a1cd77c99faed8f7ae34df8d4.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Email-Filter/Makefile8
-rw-r--r--mail/p5-Email-LocalDelivery/Makefile6
-rw-r--r--mail/p5-IMAP-Client/Makefile6
-rw-r--r--mail/p5-Mail-ClamAV/Makefile2
-rw-r--r--mail/p5-Mail-Graph/Makefile8
-rw-r--r--mail/p5-Mail-Mbox-MessageParser/Makefile4
-rw-r--r--mail/p5-Mail-RBL/Makefile2
-rw-r--r--mail/p5-POE-Component-Client-POP3/Makefile2
-rw-r--r--mail/p5-POE-Component-Client-SMTP/Makefile4
9 files changed, 21 insertions, 21 deletions
diff --git a/mail/p5-Email-Filter/Makefile b/mail/p5-Email-Filter/Makefile
index 6cb1aeee8ef4..6ecb637c7b7f 100644
--- a/mail/p5-Email-Filter/Makefile
+++ b/mail/p5-Email-Filter/Makefile
@@ -15,10 +15,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= Library for creating easy email filters
-BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
- ${SITE_PERL}/Email/LocalDelivery.pm:${PORTSDIR}/mail/p5-Email-LocalDelivery \
- ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
- ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger
+BUILD_DEPENDS= p5-Email-Simple>=0:${PORTSDIR}/mail/p5-Email-Simple \
+ p5-Email-LocalDelivery>=0:${PORTSDIR}/mail/p5-Email-LocalDelivery \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
+ p5-Class-Trigger>=0:${PORTSDIR}/devel/p5-Class-Trigger
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Email-LocalDelivery/Makefile b/mail/p5-Email-LocalDelivery/Makefile
index b1230ebb4e81..9639789305f2 100644
--- a/mail/p5-Email-LocalDelivery/Makefile
+++ b/mail/p5-Email-LocalDelivery/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Deliver a piece of email - simply
-RUN_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
- ${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType \
- ${SITE_PERL}/File/Path/Expand.pm:${PORTSDIR}/devel/p5-File-Path-Expand
+RUN_DEPENDS= p5-Email-Simple>=0:${PORTSDIR}/mail/p5-Email-Simple \
+ p5-Email-FolderType>=0:${PORTSDIR}/mail/p5-Email-FolderType \
+ p5-File-Path-Expand>=0:${PORTSDIR}/devel/p5-File-Path-Expand
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-IMAP-Client/Makefile b/mail/p5-IMAP-Client/Makefile
index 5b526c5e6c21..a6db44b12d22 100644
--- a/mail/p5-IMAP-Client/Makefile
+++ b/mail/p5-IMAP-Client/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Advanced manipulation of IMAP services w/ referral support
-RUN_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/URI/imap.pm:${PORTSDIR}/mail/p5-URI-imap
+RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-URI-imap>=0:${PORTSDIR}/mail/p5-URI-imap
PERL_CONFIGURE= yes
diff --git a/mail/p5-Mail-ClamAV/Makefile b/mail/p5-Mail-ClamAV/Makefile
index 8764821ebf69..15659997a826 100644
--- a/mail/p5-Mail-ClamAV/Makefile
+++ b/mail/p5-Mail-ClamAV/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for the clamav virus scanner
-BUILD_DEPENDS= ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
+BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline \
clamscan:${PORTSDIR}/security/clamav
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/mail/p5-Mail-Graph/Makefile b/mail/p5-Mail-Graph/Makefile
index a3142f41543a..101249ebac36 100644
--- a/mail/p5-Mail-Graph/Makefile
+++ b/mail/p5-Mail-Graph/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for drawing graphical stats for mails/spams
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
- ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
- ${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
- ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
+RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
+ p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph \
+ p5-GD-TextUtil>=0:${PORTSDIR}/graphics/p5-GD-TextUtil \
+ p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Mail-Mbox-MessageParser/Makefile b/mail/p5-Mail-Mbox-MessageParser/Makefile
index 91f1f04b2987..5518d75ef6b9 100644
--- a/mail/p5-Mail-Mbox-MessageParser/Makefile
+++ b/mail/p5-Mail-Mbox-MessageParser/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A fast and simple mbox folder reader
-BUILD_DEPENDS= ${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
- ${SITE_PERL}/FileHandle/Unget.pm:${PORTSDIR}/devel/p5-FileHandle-Unget
+BUILD_DEPENDS= p5-Text-Diff>=0:${PORTSDIR}/textproc/p5-Text-Diff \
+ p5-FileHandle-Unget>=0:${PORTSDIR}/devel/p5-FileHandle-Unget
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-Mail-RBL/Makefile b/mail/p5-Mail-RBL/Makefile
index d588497482bc..36366a1154b4 100644
--- a/mail/p5-Mail-RBL/Makefile
+++ b/mail/p5-Mail-RBL/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension to access RBL-style host verification services
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
p5-NetAddr-IP>0:${PORTSDIR}/net-mgmt/p5-NetAddr-IP
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/mail/p5-POE-Component-Client-POP3/Makefile b/mail/p5-POE-Component-Client-POP3/Makefile
index ecf87d314dad..badb263953c1 100644
--- a/mail/p5-POE-Component-Client-POP3/Makefile
+++ b/mail/p5-POE-Component-Client-POP3/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Implement a POP3 client POE component
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/mail/p5-POE-Component-Client-SMTP/Makefile b/mail/p5-POE-Component-Client-SMTP/Makefile
index ba4aa7e99f4e..3f2c37150c13 100644
--- a/mail/p5-POE-Component-Client-SMTP/Makefile
+++ b/mail/p5-POE-Component-Client-SMTP/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= SMTP client POE component
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/POE/Filter/Transparent/SMTP.pm:${PORTSDIR}/mail/p5-POE-Filter-Transparent-SMTP
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-POE-Filter-Transparent-SMTP>=0:${PORTSDIR}/mail/p5-POE-Filter-Transparent-SMTP
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes