aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /mail
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/adcomplain/Makefile10
-rw-r--r--mail/adcomplain/files/patch-adcomplain.pl628
-rw-r--r--mail/assp/Makefile6
-rw-r--r--mail/bogofilter/Makefile7
-rw-r--r--mail/cyrus-imapd23/Makefile4
-rw-r--r--mail/cyrus-imapd24/Makefile4
-rw-r--r--mail/cyrus-imapd25/Makefile4
-rw-r--r--mail/cyrus2dovecot/Makefile6
-rw-r--r--mail/dkimproxy/Makefile7
-rw-r--r--mail/elmo-devel/Makefile5
-rw-r--r--mail/exipick/Makefile13
-rw-r--r--mail/imapsync/Makefile8
-rw-r--r--mail/mailagent/Makefile4
-rw-r--r--mail/pflogstats/Makefile6
-rw-r--r--mail/qmhandle/Makefile6
-rw-r--r--mail/rlytest/Makefile6
-rw-r--r--mail/sqlgrey/Makefile2
-rw-r--r--mail/swaks/Makefile28
18 files changed, 351 insertions, 403 deletions
diff --git a/mail/adcomplain/Makefile b/mail/adcomplain/Makefile
index ee6ce6177865..4b7d77ffb19c 100644
--- a/mail/adcomplain/Makefile
+++ b/mail/adcomplain/Makefile
@@ -11,7 +11,8 @@ EXTRACT_SUFX= .uu
MAINTAINER= ports@FreeBSD.org
COMMENT= Complain about inappropriate commercial use (f.e. SPAM) of usenet/e-mail
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= adcomplain.pl
EXTRACT_CMD= /usr/bin/uudecode
EXTRACT_BEFORE_ARGS= <
@@ -20,10 +21,9 @@ NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/adcomplain
-post-patch:
- cd ${WRKSRC}; \
- ${CP} adcomplain.pl adcomplain.pl.old; \
- ${SED} 's=%PERL5%=${PERL}=' < adcomplain.pl.old > adcomplain.pl
+# fix-shebang normally runs before the patches in ${FILESDIR} are applied. In
+# this case, we need it to run after, so that it can fix the right shebang.
+TARGET_ORDER_OVERRIDE= 750:fix-shebang
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/adcomplain.pl \
diff --git a/mail/adcomplain/files/patch-adcomplain.pl b/mail/adcomplain/files/patch-adcomplain.pl
index 44054e48a201..2fbe371df03b 100644
--- a/mail/adcomplain/files/patch-adcomplain.pl
+++ b/mail/adcomplain/files/patch-adcomplain.pl
@@ -1,326 +1,302 @@
-*** adcomplain.pl.orig Mon Feb 21 03:23:03 2000
---- adcomplain.pl Mon Feb 21 03:24:27 2000
-***************
-*** 1,3 ****
---- 1,4 ----
-+ #!%PERL5%
- #! /bin/sh -- # -*- perl -*-
- # first line invokes sh. Some systems may need to refer to perl directly, i.e.:
-
-***************
-*** 7,14 ****
- # allows perl to be _anywhere_ in the user's path. The intent is to reduce
- # the need to edit this file.
-
-! eval 'exec perl $0 ${1+"$@"}'
-! if 0; # tee hee! This is on a separate line, so /bin/sh never sees it.
-
- # use strict;
-
---- 8,15 ----
- # allows perl to be _anywhere_ in the user's path. The intent is to reduce
- # the need to edit this file.
-
-! #eval 'exec perl $0 ${1+"$@"}'
-! #if 0; # tee hee! This is on a separate line, so /bin/sh never sees it.
-
- # use strict;
-
-***************
-*** 533,538 ****
---- 534,540 ----
- $quiet, # control flag, limits interaction and output
- %rematch_aliases, # heuristic list, resets priority of another header
- $response, # text of letter we will send
-+ @rusu_3level, # 3rd level .RU/.SU exceptions
- $site, # site we will send the complaint to
- @site_exceptions, # sites that have irregular syntactic form
- $subject, # subject header of the ad
-***************
-*** 2520,2526 ****
- ($site2 = $host) =~ s/.*\.(.*\..*)/$1/;
- ($site3 = $host) =~ s/.*\.(.*\..*\..*)/$1/;
- ($junk = $host) =~ s/.*\.(.*)/$1/;
-! if (length($junk) >= 3) {
- ($junk = $site3) =~ s/(\W)/\\$1/g; # remove special characters
-
- if (grep(/^$junk$/, @site_exceptions) != 0) {
---- 2522,2538 ----
- ($site2 = $host) =~ s/.*\.(.*\..*)/$1/;
- ($site3 = $host) =~ s/.*\.(.*\..*\..*)/$1/;
- ($junk = $host) =~ s/.*\.(.*)/$1/;
-! if ($junk eq "ru" || $junk eq "su") {
-! ($junk = $site2) =~ s/(\W)/\\$1/g; # remove special characters
-!
-! if (grep(/^$junk$/, @rusu_3level) != 0) {
-! $site = $site3;
-! }
-! else {
-! $site = $site2;
-! }
-! }
-! elsif (length($junk) >= 3) {
- ($junk = $site3) =~ s/(\W)/\\$1/g; # remove special characters
-
- if (grep(/^$junk$/, @site_exceptions) != 0) {
-***************
-*** 2618,2623 ****
---- 2630,2636 ----
- # Pick the alias with the _most_ dots
- local($alias);
- foreach $alias (split(' ', $aliases)) {
-+ $alias =~ s/\.$//; # this adcomplain cannot deal with "foo.bar.com."
- $cd = ($alias =~ tr/././);
- if ($cd > $nd) {
- $result = $alias;
-***************
-*** 3077,3082 ****
---- 3090,3337 ----
- 'xs4all.nl',
- );
- @site_exceptions = sort @site_exceptions; # needed for bsearch to work
-+
-+ @rusu_3level = (
-+ 'abkhazia.su',
-+ 'adygeya.ru',
-+ 'adygeya.su',
-+ 'aktyubinsk.su',
-+ 'alma-ata.su',
-+ 'altai.ru',
-+ 'altai.su',
-+ 'amur.ru',
-+ 'amur.su',
-+ 'amursk.ru',
-+ 'arkhangelsk.ru',
-+ 'arkhangelsk.su',
-+ 'armenia.su',
-+ 'ashgabad.su',
-+ 'astrakhan.ru',
-+ 'astrakhan.su',
-+ 'azerbaijan.su',
-+ 'baikal.ru',
-+ 'balashov.su',
-+ 'bashkiria.ru',
-+ 'bashkiria.su',
-+ 'belgorod.ru',
-+ 'belgorod.su',
-+ 'bir.ru',
-+ 'bishkek.su',
-+ 'bryansk.ru',
-+ 'bryansk.su',
-+ 'bukhara.su',
-+ 'buriatia.su',
-+ 'buryatia.ru',
-+ 'cbg.ru',
-+ 'chel.ru',
-+ 'chel.su',
-+ 'chelyabinsk.ru',
-+ 'chimkent.su',
-+ 'chita.ru',
-+ 'chita.su',
-+ 'chukotka.ru',
-+ 'chuvashia.ru',
-+ 'chuvashia.su',
-+ 'cmw.ru',
-+ 'com.ru',
-+ 'dagestan.ru',
-+ 'dagestan.su',
-+ 'dubna.su',
-+ 'dudinka.ru',
-+ 'e-burg.ru',
-+ 'e-burg.su',
-+ 'east-kazakhstan.su',
-+ 'engels.su',
-+ 'fareast.ru',
-+ 'georgia.su',
-+ 'grozny.ru',
-+ 'grozny.su',
-+ 'irkutsk.ru',
-+ 'irkutsk.su',
-+ 'ivanovo.ru',
-+ 'ivanovo.su',
-+ 'izhevsk.ru',
-+ 'jamal.ru',
-+ 'jambyl.su',
-+ 'jar.ru',
-+ 'joshkar-ola.ru',
-+ 'k-uralsk.ru',
-+ 'kalmykia.ru',
-+ 'kalmykia.su',
-+ 'kaluga.ru',
-+ 'kaluga.su',
-+ 'kamchatka.ru',
-+ 'kamchatka.su',
-+ 'karacol.su',
-+ 'karaganda.su',
-+ 'karakol.su',
-+ 'karelia.ru',
-+ 'karelia.su',
-+ 'kazan.ru',
-+ 'kazan.su',
-+ 'kchr.ru',
-+ 'kemerovo.ru',
-+ 'kemerovo.su',
-+ 'khabarovsk.ru',
-+ 'khabarovsk.su',
-+ 'khakassia.ru',
-+ 'khakassia.su',
-+ 'khv.ru',
-+ 'kirov.ru',
-+ 'kms.ru',
-+ 'koenig.ru',
-+ 'koenig.su',
-+ 'komi.ru',
-+ 'komi.su',
-+ 'kostroma.ru',
-+ 'kostroma.su',
-+ 'krasnodar.su',
-+ 'krasnoyarsk.ru',
-+ 'krasnoyarsk.su',
-+ 'kuban.ru',
-+ 'kuban.su',
-+ 'kurgan.ru',
-+ 'kurgan.su',
-+ 'kursk.ru',
-+ 'kursk.su',
-+ 'kustanai.ru',
-+ 'kustanai.su',
-+ 'kuzbass.ru',
-+ 'lipetsk.ru',
-+ 'lipetsk.su',
-+ 'magadan.ru',
-+ 'magadan.su',
-+ 'magnitka.ru',
-+ 'mangyshlak.su',
-+ 'mari-el.ru',
-+ 'mari.ru',
-+ 'mari.su',
-+ 'marine.ru',
-+ 'marine.su',
-+ 'moldova.su',
-+ 'mordovia.ru',
-+ 'mordovia.su',
-+ 'mosreg.ru',
-+ 'msk.ru',
-+ 'msk.su',
-+ 'murmansk.ru',
-+ 'murmansk.su',
-+ 'mytis.ru',
-+ 'nakhodka.ru',
-+ 'nalchik.ru',
-+ 'nalchik.su',
-+ 'naryn.su',
-+ 'navoi.su',
-+ 'net.ru',
-+ 'nkz.ru',
-+ 'nnov.ru',
-+ 'nnov.su',
-+ 'norilsk.ru',
-+ 'north-kazakhstan.su',
-+ 'nov.ru',
-+ 'nov.su',
-+ 'novosibirsk.ru',
-+ 'nsk.ru',
-+ 'nsk.su',
-+ 'obninsk.su',
-+ 'omsk.ru',
-+ 'omsk.su',
-+ 'orenburg.ru',
-+ 'orenburg.su',
-+ 'org.ru',
-+ 'oryol.ru',
-+ 'oryol.su',
-+ 'osh.su',
-+ 'oskol.ru',
-+ 'palana.ru',
-+ 'pavlodar.su',
-+ 'penza.ru',
-+ 'penza.su',
-+ 'perm.ru',
-+ 'perm.su',
-+ 'pokrovsk.su',
-+ 'pp.ru',
-+ 'pskov.ru',
-+ 'pskov.su',
-+ 'ptz.ru',
-+ 'pyatigorsk.ru',
-+ 'pyatigorsk.su',
-+ 'rnd.ru',
-+ 'rostov-na-donu.su',
-+ 'rubtsovsk.ru',
-+ 'ryazan.ru',
-+ 'ryazan.su',
-+ 'sakhalin.ru',
-+ 'sakhalin.su',
-+ 'samara.ru',
-+ 'samara.su',
-+ 'saratov.ru',
-+ 'saratov.su',
-+ 'semsk.su',
-+ 'serpukhov.su',
-+ 'simbirsk.ru',
-+ 'simbirsk.su',
-+ 'smolensk.ru',
-+ 'smolensk.su',
-+ 'sochi.su',
-+ 'spb.ru',
-+ 'spb.su',
-+ 'stavropol.ru',
-+ 'stavropol.su',
-+ 'stv.ru',
-+ 'surgut.ru',
-+ 'surgut.su',
-+ 'syzran.ru',
-+ 'tambov.ru',
-+ 'tambov.su',
-+ 'tashkent.su',
-+ 'tatarstan.ru',
-+ 'termez.su',
-+ 'togliatti.su',
-+ 'tom.ru',
-+ 'tomsk.ru',
-+ 'tomsk.su',
-+ 'troitsk.su',
-+ 'tsaritsyn.ru',
-+ 'tsaritsyn.su',
-+ 'tselinograd.su',
-+ 'tsk.ru',
-+ 'tula.ru',
-+ 'tula.su',
-+ 'tuva.ru',
-+ 'tuva.su',
-+ 'tver.ru',
-+ 'tver.su',
-+ 'tyumen.ru',
-+ 'tyumen.su',
-+ 'udm.ru',
-+ 'udmurtia.ru',
-+ 'udmurtia.su',
-+ 'ulan-ude.ru',
-+ 'vdonsk.ru',
-+ 'vladikavkaz.ru',
-+ 'vladikavkaz.su',
-+ 'vladimir.ru',
-+ 'vladimir.su',
-+ 'vladivostok.ru',
-+ 'volgograd.ru',
-+ 'vologda.ru',
-+ 'vologda.su',
-+ 'voronezh.ru',
-+ 'voronezh.su',
-+ 'vrn.ru',
-+ 'vyatka.ru',
-+ 'vyatka.su',
-+ 'yakutia.ru',
-+ 'yakutia.su',
-+ 'yamal.ru',
-+ 'yaroslavl.ru',
-+ 'yaroslavl.su',
-+ 'yekaterinburg.ru',
-+ 'yuzhno-sakhalinsk.ru',
-+ 'zgrad.ru',
-+ 'zgrad.su',
-+ );
-
- %rematch_aliases = (
- 'nonexistent.com', 'X-NNTP-Posting-Host:',
+--- adcomplain.pl.orig 2015-12-17 16:02:13 UTC
++++ adcomplain.pl
+@@ -1,15 +1,5 @@
+-#! /bin/sh -- # -*- perl -*-
+-# first line invokes sh. Some systems may need to refer to perl directly, i.e.:
+-
+ #! /bin/perl
+
+-# But the first way is preferable, because we have a trick (below) that
+-# allows perl to be _anywhere_ in the user's path. The intent is to reduce
+-# the need to edit this file.
+-
+-eval 'exec perl $0 ${1+"$@"}'
+-if 0; # tee hee! This is on a separate line, so /bin/sh never sees it.
+-
+ # use strict;
+
+ #-----------------------------------------------
+@@ -533,6 +523,7 @@ local(
+ $quiet, # control flag, limits interaction and output
+ %rematch_aliases, # heuristic list, resets priority of another header
+ $response, # text of letter we will send
++ @rusu_3level, # 3rd level .RU/.SU exceptions
+ $site, # site we will send the complaint to
+ @site_exceptions, # sites that have irregular syntactic form
+ $subject, # subject header of the ad
+@@ -2520,7 +2511,17 @@ sub find_site {
+ ($site2 = $host) =~ s/.*\.(.*\..*)/$1/;
+ ($site3 = $host) =~ s/.*\.(.*\..*\..*)/$1/;
+ ($junk = $host) =~ s/.*\.(.*)/$1/;
+- if (length($junk) >= 3) {
++ if ($junk eq "ru" || $junk eq "su") {
++ ($junk = $site2) =~ s/(\W)/\\$1/g; # remove special characters
++
++ if (grep(/^$junk$/, @rusu_3level) != 0) {
++ $site = $site3;
++ }
++ else {
++ $site = $site2;
++ }
++ }
++ elsif (length($junk) >= 3) {
+ ($junk = $site3) =~ s/(\W)/\\$1/g; # remove special characters
+
+ if (grep(/^$junk$/, @site_exceptions) != 0) {
+@@ -2618,6 +2619,7 @@ sub fqdn_name {
+ # Pick the alias with the _most_ dots
+ local($alias);
+ foreach $alias (split(' ', $aliases)) {
++ $alias =~ s/\.$//; # this adcomplain cannot deal with "foo.bar.com."
+ $cd = ($alias =~ tr/././);
+ if ($cd > $nd) {
+ $result = $alias;
+@@ -3078,6 +3080,248 @@ sub get_constants_and_environment {
+ );
+ @site_exceptions = sort @site_exceptions; # needed for bsearch to work
+
++ @rusu_3level = (
++ 'abkhazia.su',
++ 'adygeya.ru',
++ 'adygeya.su',
++ 'aktyubinsk.su',
++ 'alma-ata.su',
++ 'altai.ru',
++ 'altai.su',
++ 'amur.ru',
++ 'amur.su',
++ 'amursk.ru',
++ 'arkhangelsk.ru',
++ 'arkhangelsk.su',
++ 'armenia.su',
++ 'ashgabad.su',
++ 'astrakhan.ru',
++ 'astrakhan.su',
++ 'azerbaijan.su',
++ 'baikal.ru',
++ 'balashov.su',
++ 'bashkiria.ru',
++ 'bashkiria.su',
++ 'belgorod.ru',
++ 'belgorod.su',
++ 'bir.ru',
++ 'bishkek.su',
++ 'bryansk.ru',
++ 'bryansk.su',
++ 'bukhara.su',
++ 'buriatia.su',
++ 'buryatia.ru',
++ 'cbg.ru',
++ 'chel.ru',
++ 'chel.su',
++ 'chelyabinsk.ru',
++ 'chimkent.su',
++ 'chita.ru',
++ 'chita.su',
++ 'chukotka.ru',
++ 'chuvashia.ru',
++ 'chuvashia.su',
++ 'cmw.ru',
++ 'com.ru',
++ 'dagestan.ru',
++ 'dagestan.su',
++ 'dubna.su',
++ 'dudinka.ru',
++ 'e-burg.ru',
++ 'e-burg.su',
++ 'east-kazakhstan.su',
++ 'engels.su',
++ 'fareast.ru',
++ 'georgia.su',
++ 'grozny.ru',
++ 'grozny.su',
++ 'irkutsk.ru',
++ 'irkutsk.su',
++ 'ivanovo.ru',
++ 'ivanovo.su',
++ 'izhevsk.ru',
++ 'jamal.ru',
++ 'jambyl.su',
++ 'jar.ru',
++ 'joshkar-ola.ru',
++ 'k-uralsk.ru',
++ 'kalmykia.ru',
++ 'kalmykia.su',
++ 'kaluga.ru',
++ 'kaluga.su',
++ 'kamchatka.ru',
++ 'kamchatka.su',
++ 'karacol.su',
++ 'karaganda.su',
++ 'karakol.su',
++ 'karelia.ru',
++ 'karelia.su',
++ 'kazan.ru',
++ 'kazan.su',
++ 'kchr.ru',
++ 'kemerovo.ru',
++ 'kemerovo.su',
++ 'khabarovsk.ru',
++ 'khabarovsk.su',
++ 'khakassia.ru',
++ 'khakassia.su',
++ 'khv.ru',
++ 'kirov.ru',
++ 'kms.ru',
++ 'koenig.ru',
++ 'koenig.su',
++ 'komi.ru',
++ 'komi.su',
++ 'kostroma.ru',
++ 'kostroma.su',
++ 'krasnodar.su',
++ 'krasnoyarsk.ru',
++ 'krasnoyarsk.su',
++ 'kuban.ru',
++ 'kuban.su',
++ 'kurgan.ru',
++ 'kurgan.su',
++ 'kursk.ru',
++ 'kursk.su',
++ 'kustanai.ru',
++ 'kustanai.su',
++ 'kuzbass.ru',
++ 'lipetsk.ru',
++ 'lipetsk.su',
++ 'magadan.ru',
++ 'magadan.su',
++ 'magnitka.ru',
++ 'mangyshlak.su',
++ 'mari-el.ru',
++ 'mari.ru',
++ 'mari.su',
++ 'marine.ru',
++ 'marine.su',
++ 'moldova.su',
++ 'mordovia.ru',
++ 'mordovia.su',
++ 'mosreg.ru',
++ 'msk.ru',
++ 'msk.su',
++ 'murmansk.ru',
++ 'murmansk.su',
++ 'mytis.ru',
++ 'nakhodka.ru',
++ 'nalchik.ru',
++ 'nalchik.su',
++ 'naryn.su',
++ 'navoi.su',
++ 'net.ru',
++ 'nkz.ru',
++ 'nnov.ru',
++ 'nnov.su',
++ 'norilsk.ru',
++ 'north-kazakhstan.su',
++ 'nov.ru',
++ 'nov.su',
++ 'novosibirsk.ru',
++ 'nsk.ru',
++ 'nsk.su',
++ 'obninsk.su',
++ 'omsk.ru',
++ 'omsk.su',
++ 'orenburg.ru',
++ 'orenburg.su',
++ 'org.ru',
++ 'oryol.ru',
++ 'oryol.su',
++ 'osh.su',
++ 'oskol.ru',
++ 'palana.ru',
++ 'pavlodar.su',
++ 'penza.ru',
++ 'penza.su',
++ 'perm.ru',
++ 'perm.su',
++ 'pokrovsk.su',
++ 'pp.ru',
++ 'pskov.ru',
++ 'pskov.su',
++ 'ptz.ru',
++ 'pyatigorsk.ru',
++ 'pyatigorsk.su',
++ 'rnd.ru',
++ 'rostov-na-donu.su',
++ 'rubtsovsk.ru',
++ 'ryazan.ru',
++ 'ryazan.su',
++ 'sakhalin.ru',
++ 'sakhalin.su',
++ 'samara.ru',
++ 'samara.su',
++ 'saratov.ru',
++ 'saratov.su',
++ 'semsk.su',
++ 'serpukhov.su',
++ 'simbirsk.ru',
++ 'simbirsk.su',
++ 'smolensk.ru',
++ 'smolensk.su',
++ 'sochi.su',
++ 'spb.ru',
++ 'spb.su',
++ 'stavropol.ru',
++ 'stavropol.su',
++ 'stv.ru',
++ 'surgut.ru',
++ 'surgut.su',
++ 'syzran.ru',
++ 'tambov.ru',
++ 'tambov.su',
++ 'tashkent.su',
++ 'tatarstan.ru',
++ 'termez.su',
++ 'togliatti.su',
++ 'tom.ru',
++ 'tomsk.ru',
++ 'tomsk.su',
++ 'troitsk.su',
++ 'tsaritsyn.ru',
++ 'tsaritsyn.su',
++ 'tselinograd.su',
++ 'tsk.ru',
++ 'tula.ru',
++ 'tula.su',
++ 'tuva.ru',
++ 'tuva.su',
++ 'tver.ru',
++ 'tver.su',
++ 'tyumen.ru',
++ 'tyumen.su',
++ 'udm.ru',
++ 'udmurtia.ru',
++ 'udmurtia.su',
++ 'ulan-ude.ru',
++ 'vdonsk.ru',
++ 'vladikavkaz.ru',
++ 'vladikavkaz.su',
++ 'vladimir.ru',
++ 'vladimir.su',
++ 'vladivostok.ru',
++ 'volgograd.ru',
++ 'vologda.ru',
++ 'vologda.su',
++ 'voronezh.ru',
++ 'voronezh.su',
++ 'vrn.ru',
++ 'vyatka.ru',
++ 'vyatka.su',
++ 'yakutia.ru',
++ 'yakutia.su',
++ 'yamal.ru',
++ 'yaroslavl.ru',
++ 'yaroslavl.su',
++ 'yekaterinburg.ru',
++ 'yuzhno-sakhalinsk.ru',
++ 'zgrad.ru',
++ 'zgrad.su',
++ );
++
+ %rematch_aliases = (
+ 'nonexistent.com', 'X-NNTP-Posting-Host:',
+ 'nym.alias.net', 'Message-Id:',
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index f8fd638c54f2..29eedd03698b 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-Net-DNS>=0.68:${PORTSDIR}/dns/p5-Net-DNS \
p5-libwww>=6.04:${PORTSDIR}/www/p5-libwww \
p5-HTML-Parser>=3.69:${PORTSDIR}/www/p5-HTML-Parser
-USES= perl5 zip:infozip
+USES= perl5 zip:infozip shebangfix
+SHEBANG_FILES= *.pl
NO_BUILD= yes
USE_PERL5= run
@@ -122,9 +123,6 @@ RUN_DEPENDS+= p5-IO-Socket-INET6>=2.69:${PORTSDIR}/net/p5-IO-Socket-INET6
EXTRACT_AFTER_ARGS= -d ${PORTNAME}-${PORTVERSION}
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/*.pl
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/images \
${STAGEDIR}${DATADIR}/logs ${STAGEDIR}${DATADIR}/reports
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index a98bd3f66079..60616271b515 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -23,8 +23,8 @@ UNICODE_DESC= Normalize tokens to Unicode (UTF-8) (recommended)
CONFLICTS_INSTALL?= bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
USES= cpe perl5 shebangfix tar:bzip2
-SHEBANG_FILES= contrib/randomtrain.sh \
- contrib/scramble.sh
+SHEBANG_FILES= contrib/randomtrain.sh contrib/scramble.sh \
+ src/tests/unsort.pl contrib/*.pl
USE_PERL5= run
GNU_CONFIGURE= yes
@@ -55,9 +55,6 @@ CONFIGURE_ENV+= PERL="${PERL}"
INSTALL_TARGET= install-strip prefix=${PREFIX} mandir=${MANPREFIX}/man
post-patch:
- ${REINPLACE_CMD} -e 's|^#!.*perl|#! ${PERL}|' \
- ${WRKSRC}/src/tests/unsort.pl \
- ${WRKSRC}/contrib/*.pl
${REINPLACE_CMD} -e 's/INTEGRITY_TESTS = t.lock1 t.lock3 t.valgrind/INTEGRITY_TESTS = t.lock1/' \
-e 's/ENVIRON_TESTS = t.abort/ENVIRON_TESTS =/' \
${WRKSRC}/src/tests/Makefile.am
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index 197b7c60fcd1..3fb11b5d75ec 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.3.19
-#PORTREVISION= 10
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-imapd/
PKGNAMESUFFIX= 23
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-bdb=${BDB_LIB_NAME} \
--with-com_err \
--with-openssl=${OPENSSLBASE} \
- --with-perl=${PERL5}
+ --with-perl=${PERL}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index de76be68ad39..4929259d5211 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.4.18
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-imapd/ \
http://cyrusimap.org/releases/
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-bdb=${BDB_LIB_NAME} \
--with-com_err \
--with-openssl=${OPENSSLBASE} \
- --with-perl=${PERL5}
+ --with-perl=${PERL}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
diff --git a/mail/cyrus-imapd25/Makefile b/mail/cyrus-imapd25/Makefile
index 22ef3f3d7481..aa3bec0c4c81 100644
--- a/mail/cyrus-imapd25/Makefile
+++ b/mail/cyrus-imapd25/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cyrus-imapd
PORTVERSION= 2.5.7
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-imapd/ \
http://cyrusimap.org/releases/
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-bdb=${BDB_LIB_NAME} \
--with-com_err \
--with-openssl=${OPENSSLBASE} \
- --with-perl=${PERL5}
+ --with-perl=${PERL}
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
diff --git a/mail/cyrus2dovecot/Makefile b/mail/cyrus2dovecot/Makefile
index cff4ffc2b717..d7cea2cb6e7b 100644
--- a/mail/cyrus2dovecot/Makefile
+++ b/mail/cyrus2dovecot/Makefile
@@ -16,15 +16,13 @@ LICENSE_COMB= dual
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${DISTNAME}
NO_WRKSUBDIR= yes
post-extract:
@${CP} -v ${DISTDIR}/${DISTNAME} ${WRKSRC}
-post-patch:
- @${REINPLACE_CMD} -e '1s,^#!.*,#!${PERL},' ${WRKSRC}/${DISTNAME}
-
do-build:
pod2man --section=1 --release=${PORTVERSION} \
--name=${PORTNAME} --center=${PORTNAME}" user guide" \
diff --git a/mail/dkimproxy/Makefile b/mail/dkimproxy/Makefile
index 9e0df0b8feab..f517e5ba2e14 100644
--- a/mail/dkimproxy/Makefile
+++ b/mail/dkimproxy/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= IPV6
GNU_CONFIGURE= yes
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= scripts/*
NO_ARCH= yes
USE_RC_SUBR= dkimproxy_in dkimproxy_out
@@ -39,8 +40,4 @@ IPV6_EXTRA_PATCHES= ${FILESDIR}/extra-patch-scripts-dkimproxy.out
IPV6_EXTRA_PATCHES= ${FILESDIR}/extra-patch-scripts-dkimproxy_in.conf.example
IPV6_EXTRA_PATCHES= ${FILESDIR}/extra-patch-scripts-dkimproxy_out.conf.example
-post-patch:
- @${GREP} -Ril 'perl' ${WRKDIR} | ${XARGS} ${REINPLACE_CMD} -i '' \
- -e 's|/usr/bin/perl|${PERL}|' -e 's|@PERL@|${PERL}|'
-
.include <bsd.port.mk>
diff --git a/mail/elmo-devel/Makefile b/mail/elmo-devel/Makefile
index 321462fcedff..006b5ce5918c 100644
--- a/mail/elmo-devel/Makefile
+++ b/mail/elmo-devel/Makefile
@@ -14,7 +14,8 @@ COMMENT= Receive, filter, read, compose, and send mail at the text console
CONFLICTS= elmo-[0-9]*
GNU_CONFIGURE= yes
-USES= iconv perl5
+USES= iconv perl5 shebangfix
+SHEBANG_FILES= src/elmoconf.pl
USE_OPENSSL= yes
USE_PERL5= run
@@ -48,8 +49,6 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|/usr/bin/env perl|${PERL} -w|" \
- ${WRKSRC}/src/elmoconf.pl
@${REINPLACE_CMD} -e 's|gpgme4|gpgme|g' -e 's|== "|= "|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|gpgme4|gpgme|g' ${WRKSRC}/src/pgp.c
diff --git a/mail/exipick/Makefile b/mail/exipick/Makefile
index 157ba937cd17..e045ed0e0b8e 100644
--- a/mail/exipick/Makefile
+++ b/mail/exipick/Makefile
@@ -13,21 +13,22 @@ COMMENT= Display messages from Exim queue based on a variety of criteria
PLIST_FILES= bin/${PORTNAME}
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${DISTNAME}
USE_PERL5= run
+NO_BUILD= yes
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKSRC}
@${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} ${WRKSRC}
-do-build:
- @${SED} -e '1s|/usr/bin/perl|${PERL}|' \
- -e 's;\/local\/exim\/spool;\/var\/spool\/exim;g' \
- ${WRKSRC}/${DISTNAME} > ${WRKSRC}/${PORTNAME}.pl
+post-patch:
+ @${REINPLACE_CMD} -e 's;\/local\/exim\/spool;\/var\/spool\/exim;g' \
+ ${WRKSRC}/${DISTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>
diff --git a/mail/imapsync/Makefile b/mail/imapsync/Makefile
index 16240d609fe2..ad718740e0b1 100644
--- a/mail/imapsync/Makefile
+++ b/mail/imapsync/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Mail-IMAPClient>0:${PORTSDIR}/mail/p5-Mail-IMAPClient \
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}
-USES= cpe perl5 tar:tgz
+USES= cpe perl5 tar:tgz shebangfix
+SHEBANG_FILES= ${PORTNAME}
USE_GITHUB= yes
GH_ACCOUNT= imapsync
@@ -32,11 +33,6 @@ PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
POD2MAN?= pod2man
-do-patch:
- ${REINPLACE_CMD} \
- -e 's|/usr/bin/perl|${PERL}|g' \
- ${WRKSRC}/${PORTNAME}
-
do-install:
${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index b4851ae09da6..f7a85ea326bc 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mailagent
PORTVERSION= 3.1.78
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://eron.info/
@@ -25,7 +25,7 @@ CONFIGURE_ARGS= -dres \
-Dprefix='${PREFIX}' \
-Dmansrc='${STAGEDIR}${PREFIX}/man/man1'
MAKE_JOBS_UNSAFE= yes
-MAKE_ENV= PATH=`dirname ${PERL5}`:${PATH} INSTALL_PREFIX=${STAGEDIR}
+MAKE_ENV= PATH=`dirname ${PERL}`:${PATH} INSTALL_PREFIX=${STAGEDIR}
INSTALL_TARGET= install install.man
SUB_LIST+= ORGFILE="${ORGFILE}"
diff --git a/mail/pflogstats/Makefile b/mail/pflogstats/Makefile
index e7a8a9132696..44aeee3f9b81 100644
--- a/mail/pflogstats/Makefile
+++ b/mail/pflogstats/Makefile
@@ -22,12 +22,12 @@ RUN_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
p5-XML-Dumper>=0:${PORTSDIR}/textproc/p5-XML-Dumper
NO_BUILD= yes
-USES= perl5
-SITE_PERL_INST= ${SITE_PERL:S/${LOCALBASE}/${PREFIX}/}
+USES= perl5 shebangfix
+SHEBANG_FILES= *.pl
+SITE_PERL_INST= ${PREFIX}/${SITE_PERL_REL}
post-patch:
@${REINPLACE_CMD} \
- -e 's|/usr/bin/perl.*|${PERL}|' \
-e 's|/usr/local/lib/pflogstats|${SITE_PERL_INST}/Pflogstats|' \
${WRKSRC}/apachelogiostats.pl \
${WRKSRC}/pflogstats.pl \
diff --git a/mail/qmhandle/Makefile b/mail/qmhandle/Makefile
index cf18b6caa0d5..03a58f69746c 100644
--- a/mail/qmhandle/Makefile
+++ b/mail/qmhandle/Makefile
@@ -12,7 +12,8 @@ COMMENT= Tool to view and manage a qmail queue
LICENSE= GPLv2
-USES= qmail:run perl5 tar:bzip2
+USES= qmail:run perl5 tar:bzip2 shebangfix
+SHEBANG_FILES= qmHandle
NO_BUILD= yes
NO_ARCH= yes
@@ -22,8 +23,7 @@ PORTDOCS= HISTORY README
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's,^#!/usr/bin/perl,#!${PERL},g' \
- -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
+ @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
-e '/^##* *USER *CONFIGURATION *BEGIN *##*$$/,/^##* *USER *CONFIGURATION *END *##*$$/s/^\(#*\)my/\1our/g' \
${WRKSRC}/qmHandle
@${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${FILESDIR}/qmHandle.conf.in > \
diff --git a/mail/rlytest/Makefile b/mail/rlytest/Makefile
index 5e715947db5d..16d35cdd5f5b 100644
--- a/mail/rlytest/Makefile
+++ b/mail/rlytest/Makefile
@@ -16,13 +16,11 @@ EXTRACT_AFTER_ARGS= > ${WRKSRC}/${PORTNAME}
NO_WRKSUBDIR= yes
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
PLIST_FILES= bin/rlytest man/man1/rlytest.1.gz
-post-patch:
- @${REINPLACE_CMD} -e 's|^#!.*|#!${PERL}|' ${WRKSRC}/${PORTNAME}
-
do-build:
@cd ${WRKSRC} && pod2man ${PORTNAME} > ${PORTNAME}.1
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 6e486c4810be..96e2d85997e7 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -57,7 +57,7 @@ RUN_DEPENDS+= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
.endif
post-patch:
- @${REINPLACE_CMD} -e 's-#!/usr/bin/perl-#!${PERL}-' -e 's!/etc/sqlgrey!${PREFIX}/${ETCDIR}!g' ${WRKSRC}/sqlgrey
+ @${REINPLACE_CMD} -e 's!/etc/sqlgrey!${PREFIX}/${ETCDIR}!g' ${WRKSRC}/sqlgrey
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/sqlgrey-logstats.pl ${STAGEDIR}/${PREFIX}/bin
diff --git a/mail/swaks/Makefile b/mail/swaks/Makefile
index 0cad84106e90..bd0582b0f978 100644
--- a/mail/swaks/Makefile
+++ b/mail/swaks/Makefile
@@ -18,28 +18,16 @@ PERL_NET_DNS_DESC= Add MX lookup support
PERL_NET_SSLEAY_DESC= Add TLS support
PERL_AUTHEN_NTLM_DESC= Add support for AUTH NTLM
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
USE_PERL5= run
+NO_BUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPERL_NET_DNS}
-RUN_DEPENDS+= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
-.endif
-
-.if ${PORT_OPTIONS:MPERL_NET_SSLEAY}
-RUN_DEPENDS+= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
-.endif
-
-.if ${PORT_OPTIONS:MPERL_AUTHEN_NTLM}
-RUN_DEPENDS+= p5-Authen-NTLM>=0:${PORTSDIR}/security/p5-Authen-NTLM
-.endif
-
-do-build:
- @${SED} -e '1s|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME} > ${WRKSRC}/${PORTNAME}.pl
+PERL_NET_DNS_RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+PERL_NET_SSLEAY_RUN_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
+PERL_AUTHEN_NTLM_RUN_DEPENDS= p5-Authen-NTLM>=0:${PORTSDIR}/security/p5-Authen-NTLM
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>