aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-08-24 12:55:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-08-24 12:55:56 +0000
commit8ab62fd7b131f88f644fc7cde40677d2f1e65841 (patch)
tree9197d8bc33a9e33ceb160f8b84719e19a8708abb /mail
parent6fd2476cd6d1b91b87486aabebe786b57f5dee4d (diff)
downloadports-8ab62fd7b131f88f644fc7cde40677d2f1e65841.tar.gz
ports-8ab62fd7b131f88f644fc7cde40677d2f1e65841.zip
MFH: r546075
gecko: update OSS patches Changes: https://github.com/kinetiknz/cubeb/compare/123ce2a...957847c PR: 248816 Submitted by: Ka Ho Ng Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2020Q3/; revision=546080
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-cubeb-oss7
2 files changed, 5 insertions, 3 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 4b2d05259e95..b674c6613357 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 68.11.0
+PORTREVISION= 1
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-cubeb-oss b/mail/thunderbird/files/patch-cubeb-oss
index 77d40ca3a55d..7a5e46dc338f 100644
--- a/mail/thunderbird/files/patch-cubeb-oss
+++ b/mail/thunderbird/files/patch-cubeb-oss
@@ -61,7 +61,7 @@ https://github.com/kinetiknz/cubeb/pull/600
#endif
--- /dev/null
+++ media/libcubeb/src/cubeb_oss.c
-@@ -0,0 +1,1128 @@
+@@ -0,0 +1,1129 @@
+/*
+ * Copyright © 2019-2020 Nia Alarie <nia@NetBSD.org>
+ * Copyright © 2020 Ka Ho Ng <khng300@gmail.com>
@@ -114,7 +114,7 @@ https://github.com/kinetiknz/cubeb/pull/600
+#define OSS_DEFAULT_NFRAMES (32)
+#endif
+
-+#define ENV_AUDIO_DEVICE "AUDIODEVICE"
++#define ENV_AUDIO_DEVICE "AUDIO_DEVICE"
+
+#ifndef OSS_MAX_CHANNELS
+# if defined(__FreeBSD__) || defined(__DragonFly__)
@@ -438,7 +438,8 @@ https://github.com/kinetiknz/cubeb/pull/600
+ continue;
+
+ devinfop[collection_cnt].device_id = strdup(sinfo.devname);
-+ devinfop[collection_cnt].friendly_name = strdup(sinfo.desc);
++ asprintf((char **)&devinfop[collection_cnt].friendly_name, "%s: %s",
++ sinfo.devname, sinfo.desc);
+ devinfop[collection_cnt].group_id = strdup(sinfo.devname);
+ devinfop[collection_cnt].vendor_name = NULL;
+ if (devinfop[collection_cnt].device_id == NULL ||