aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-09-20 13:35:44 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-09-20 13:35:44 +0000
commit8d9c1f04433e467443da7373363ebe36af0b49d8 (patch)
treeb8d7ae8f7798aa0dc564f2e751842204f21bb7b9 /mail
parent0fab0893cc9332f230be0ce06871f58f51c4fe4a (diff)
downloadports-8d9c1f04433e467443da7373363ebe36af0b49d8.tar.gz
ports-8d9c1f04433e467443da7373363ebe36af0b49d8.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/qmail-spamcontrol/Makefile2
-rw-r--r--mail/qmail/Makefile1
-rw-r--r--mail/qmail/files/extra-patch-spamcontrol-qmail-remote.c13
3 files changed, 15 insertions, 1 deletions
diff --git a/mail/qmail-spamcontrol/Makefile b/mail/qmail-spamcontrol/Makefile
index a5baec9efc8b..4d5a991c34b3 100644
--- a/mail/qmail-spamcontrol/Makefile
+++ b/mail/qmail-spamcontrol/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${SPAMCONTROL_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES+= http://www.fehcom.de/qmail/spamcontrol/:spamcontrol \
${MASTER_SITE_LOCAL:S/$/:spamcontrol/}
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 6e08eea8200a..6ef3844fa617 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -642,6 +642,7 @@ post-patch:
@cd ${UCSPISRC} && package/compile
@cd ${WRKSRC} && ./install_spamcontrol.sh
@${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-spamcontrol-qmail-smtpd.c
+ @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-spamcontrol-qmail-remote.c
. if defined(WITH_SPF_PATCH) && defined(SPF_SPAMCONTROL_PATCH)
@${PATCH} -d ${WRKSRC} < ${DISTDIR}/${DIST_SUBDIR}/${SPF_SPAMCONTROL_PATCH}
. if defined(WITH_EXTTODO_PATCH) && defined(EXTTODO_PATCH)
diff --git a/mail/qmail/files/extra-patch-spamcontrol-qmail-remote.c b/mail/qmail/files/extra-patch-spamcontrol-qmail-remote.c
new file mode 100644
index 000000000000..32da199d6125
--- /dev/null
+++ b/mail/qmail/files/extra-patch-spamcontrol-qmail-remote.c
@@ -0,0 +1,13 @@
+--- qmail-remote.c.orig 2010-09-20 10:31:12.000000000 -0300
++++ qmail-remote.c 2010-09-20 10:32:12.000000000 -0300
+@@ -507,6 +507,10 @@
+ j = str_chr(smtptext.s+i+8,'L'); /* AUTH LOGIN */
+ if (j > 0)
+ if (case_starts(smtptext.s+i+8+j,"LOGIN")) { mailfrom_login(); flagauth = 1; return; }
++ /* Deal with EHLO messages like "PLAIN LOGIN" in this order */
++ j = str_chr(smtptext.s+i+14,'L'); /* AUTH LOGIN */
++ if (j > 0)
++ if (case_starts(smtptext.s+i+14+j,"LOGIN")) { mailfrom_login(); flagauth = 1; return; }
+ j = str_chr(smtptext.s+i+8,'P'); /* AUTH PLAIN */
+ if (j > 0)
+ if (case_starts(smtptext.s+i+8+j,"PLAIN")) { mailfrom_plain(); flagauth = 2; return; }