aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-12-26 16:43:55 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-12-26 16:43:55 +0000
commite1ab2d0519baa121de1ac526f83fa749d54be474 (patch)
tree77672134959ce64ff207c6c0d3f444e70ec007a7 /mail
parent3b1eaf2b19f347b4382bfabd40d2aa3c416ca747 (diff)
downloadports-e1ab2d0519baa121de1ac526f83fa749d54be474.tar.gz
ports-e1ab2d0519baa121de1ac526f83fa749d54be474.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/qmail-mysql/Makefile2
-rw-r--r--mail/qmail-spamcontrol/Makefile2
-rw-r--r--mail/qmail-tls/Makefile2
-rw-r--r--mail/qmail/Makefile11
-rw-r--r--mail/qmail/files/extra-patch-amd6420
-rw-r--r--mail/qmail/files/qmail-smtpd.rcNG52
-rw-r--r--mail/qmail/pkg-plist1
7 files changed, 86 insertions, 4 deletions
diff --git a/mail/qmail-mysql/Makefile b/mail/qmail-mysql/Makefile
index a086af71463e..608e048f1e03 100644
--- a/mail/qmail-mysql/Makefile
+++ b/mail/qmail-mysql/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${MYSQL_PATCH_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
PKGNAMESUFFIX= -mysql
diff --git a/mail/qmail-spamcontrol/Makefile b/mail/qmail-spamcontrol/Makefile
index def2980c9651..7bc2ed32e0de 100644
--- a/mail/qmail-spamcontrol/Makefile
+++ b/mail/qmail-spamcontrol/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${SPAMCONTROL_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES+= http://www.fehcom.de/qmail/spamcontrol/:spamcontrol \
${MASTER_SITE_LOCAL:S/$/:spamcontrol/}
diff --git a/mail/qmail-tls/Makefile b/mail/qmail-tls/Makefile
index ea850720d33d..6e5c25fd94be 100644
--- a/mail/qmail-tls/Makefile
+++ b/mail/qmail-tls/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail
PORTVERSION= ${QMAIL_VERSION}.${TLS_PATCH_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
PKGNAMESUFFIX= -tls
diff --git a/mail/qmail/Makefile b/mail/qmail/Makefile
index 73925f43fadd..1d8d019b20aa 100644
--- a/mail/qmail/Makefile
+++ b/mail/qmail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qmail
PORTVERSION?= ${QMAIL_VERSION}
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES= mail
MASTER_SITES+= ${MASTER_SITE_QMAIL}
DISTNAME= ${PORTNAME}-${QMAIL_VERSION}
@@ -659,6 +659,10 @@ post-patch:
s!QUEUE_EXTRALEN 0!QUEUE_EXTRALEN 5!g' \
${WRKSRC}/extra.h
.endif
+.if ( ${ARCH} == "amd64" || ${ARCH} == "ia64" ) && \
+ ( !defined(SLAVE_SPAMCONTROL) && !defined(SLAVE_LDAP) )
+ @${PATCH} -d ${WRKSRC} < ${FILESDIR}/extra-patch-amd64
+.endif
do-configure:
@${SED} -e 's,%%RCDLINK%%,${RCDLINK},g; s,%%LOCALBASE%%,${LOCALBASE},g' \
@@ -694,6 +698,9 @@ do-install:
.for i in ${BOOTFILES}
${INSTALL_SCRIPT} ${WRKDIR}/${i:T} ${PREFIX}/boot
.endfor
+.if !defined(SLAVE_LDAP)
+ ${INSTALL_SCRIPT} ${FILESDIR}/qmail-smtpd.rcNG ${PREFIX}/boot
+.endif
.for i in 1 5 7 8
@${MKDIR} ${PREFIX}/man/man$i
. for j in ${MAN${i}}
@@ -750,6 +757,8 @@ certificate:
-out ${WRKDIR}/servercert.pem -days 366 \
-keyout ${WRKDIR}/servercert.pem ; \
${INSTALL} -o qmaild -g qmail -m 0640 ${WRKDIR}/servercert.pem ${PREFIX}/control/servercert.pem ; \
+ ${OPENSSLBASE}/bin/openssl ciphers > ${QMAIL_PREFIX}/control/tlsclientciphers
+ ${OPENSSLBASE}/bin/openssl ciphers > ${QMAIL_PREFIX}/control/tlsserverciphers
${ECHO_MSG} "===> Do not forget to do 'make clean' to clean up temporary files" ; \
else \
${ECHO_MSG} "===> You must create the file ${OPENSSLDIR}/openssl.cnf first." ; \
diff --git a/mail/qmail/files/extra-patch-amd64 b/mail/qmail/files/extra-patch-amd64
new file mode 100644
index 000000000000..68fa4ea6a32f
--- /dev/null
+++ b/mail/qmail/files/extra-patch-amd64
@@ -0,0 +1,20 @@
+--- alloc.c.orig 2007-12-26 14:24:10.000000000 -0200
++++ alloc.c 2007-12-26 14:25:40.000000000 -0200
+@@ -1,7 +1,6 @@
++#include <stdlib.h>
+ #include "alloc.h"
+ #include "error.h"
+-extern char *malloc();
+-extern void free();
+
+ #define ALIGNMENT 16 /* XXX: assuming that this alignment is enough */
+ #define SPACE 4096 /* must be multiple of ALIGNMENT */
+--- spawn.c.orig 2007-12-26 14:24:53.000000000 -0200
++++ spawn.c 2007-12-26 14:25:09.000000000 -0200
+@@ -1,5 +1,6 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include "alloc.h"
+ #include "sig.h"
+ #include "wait.h"
+ #include "substdio.h"
diff --git a/mail/qmail/files/qmail-smtpd.rcNG b/mail/qmail/files/qmail-smtpd.rcNG
new file mode 100644
index 000000000000..56c17163e019
--- /dev/null
+++ b/mail/qmail/files/qmail-smtpd.rcNG
@@ -0,0 +1,52 @@
+#!/bin/sh
+#
+# PROVIDE: qmailsmtpd
+# REQUIRE: LOGIN cleanvar
+#
+# To use the checkpassword interface to qmail-smtpd, set
+# qmailsmtpd_checkpassword to the full path to the checkpassword program (e.g.
+# security/checkpassword or security checkpassword-pam).
+#
+# Note: tcpserver can be found in the sysutils/ucspi-tcp package.
+
+. /etc/rc.subr
+
+name="qmailsmtpd"
+rcvar=`set_rcvar`
+load_rc_config $name
+
+: ${qmailsmtpd_tcpserver="/usr/local/bin/tcpserver"}
+: ${qmailsmtpd_tcprules="/usr/local/bin/tcprules"}
+: ${qmailsmtpd_enable="NO"}
+: ${qmailsmtpd_cdb="/etc/tcp.smtp"}
+: ${qmailsmtpd_flags="-R -H -u 82 -g 81"}
+: ${qmailsmtpd_host="0"}
+: ${qmailsmtpd_port="smtp"}
+: ${qmailsmtpd_smtpd="/var/qmail/bin/qmail-smtpd"}
+: ${qmailsmtpd_fqdn=`hostname`}
+: ${qmailsmtpd_checkpassword=""} # e.g. /usr/local/bin/checkpassword-pam
+: ${qmailsmtpd_checksubprogram="/usr/bin/true"}
+
+qmailsmtpd_start() {
+ $qmailsmtpd_tcprules $qmailsmtpd_cdb.cdb $qmailsmtpd_cdb.tmp < $qmailsmtpd_cdb \
+ || return 1
+
+ if [ "x$qmailsmtpd_checkpassword" != "x" ]; then
+ qmailsmtpd_usercheck="$qmailsmtpd_fqdn $qmailsmtpd_checkpassword $qmailsmtpd_checksubprogram"
+ fi
+
+ echo "Starting qmail-smtpd."
+
+ $qmailsmtpd_tcpserver -x $qmailsmtpd_cdb.cdb $qmailsmtpd_flags $qmailsmtpd_host $qmailsmtpd_port \
+ $qmailsmtpd_smtpd $qmailsmtpd_usercheck &
+ echo $! > /var/run/qmailsmtpd.pid
+}
+
+qmailsmtpd_stop() {
+ echo "Stopping qmail-smtpd"
+ kill `cat /var/run/qmailsmtpd.pid`
+}
+
+start_cmd="qmailsmtpd_start"
+stop_cmd="qmailsmtpd_stop"
+run_rc_command "$1"
diff --git a/mail/qmail/pkg-plist b/mail/qmail/pkg-plist
index 62a85bd3d959..e4f837bc1764 100644
--- a/mail/qmail/pkg-plist
+++ b/mail/qmail/pkg-plist
@@ -77,6 +77,7 @@ bin/tcp-env
%%NOT_LDAP%%boot/maildir
%%NOT_LDAP%%boot/proc
%%NOT_LDAP%%boot/proc+df
+%%NOT_LDAP%%boot/qmail-smtpd.rcNG
%%LDAP%%boot/qmail/log/run
%%LDAP%%boot/qmail/run
%%LDAP%%boot/qmail-smtpd/log/run