aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-10-02 18:26:49 +0000
committerSteve Wills <swills@FreeBSD.org>2011-10-02 18:26:49 +0000
commitf0cc09c6860e1a527524cb44473a9db106aea5cb (patch)
tree7301c5e5e0b96ea54160a1e53f3d0dcebfecd802 /mail
parent3b21c2bc0114d69baba05aed0419bbf46ccea693 (diff)
downloadports-f0cc09c6860e1a527524cb44473a9db106aea5cb.tar.gz
ports-f0cc09c6860e1a527524cb44473a9db106aea5cb.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rubygem-larch/Makefile27
-rw-r--r--mail/rubygem-larch/distinfo2
-rw-r--r--mail/rubygem-larch/pkg-descr8
4 files changed, 38 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6dd469969b15..769e21cf83e9 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -608,6 +608,7 @@
SUBDIR += ruby-rfilter
SUBDIR += ruby-rmail
SUBDIR += rubygem-actionmailer
+ SUBDIR += rubygem-larch
SUBDIR += rubygem-mail
SUBDIR += rubygem-mailfactory
SUBDIR += rubygem-pony
diff --git a/mail/rubygem-larch/Makefile b/mail/rubygem-larch/Makefile
new file mode 100644
index 000000000000..ec8cd99354a5
--- /dev/null
+++ b/mail/rubygem-larch/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: rubygem-larch
+# Date created: 28 June 2011
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= larch
+PORTVERSION= 1.1.1
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= Larch copies messages from one IMAP server to another
+
+RUN_DEPENDS= rubygem-amalgalite>=1.0:${PORTSDIR}/databases/rubygem-amalgalite \
+ rubygem-highline>=1.5:${PORTSDIR}/devel/rubygem-highline \
+ rubygem-sequel>=3.14:${PORTSDIR}/devel/rubygem-sequel \
+ rubygem-trollop>=1.13:${PORTSDIR}/devel/rubygem-trollop
+
+PLIST_FILES= bin/larch
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-larch/distinfo b/mail/rubygem-larch/distinfo
new file mode 100644
index 000000000000..a9d847a0c2ba
--- /dev/null
+++ b/mail/rubygem-larch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/larch-1.1.1.gem) = cc1abb842455834e53a626dcd3348243920a4a6891e81cebf93c4984f22b2f40
+SIZE (rubygem/larch-1.1.1.gem) = 31744
diff --git a/mail/rubygem-larch/pkg-descr b/mail/rubygem-larch/pkg-descr
new file mode 100644
index 000000000000..fee4b8fbb7d2
--- /dev/null
+++ b/mail/rubygem-larch/pkg-descr
@@ -0,0 +1,8 @@
+Larch is a tool to copy messages from one
+IMAP server to another quickly and safely.
+It's smart enough not to copy messages that
+already exist on the destination and robust
+enough to deal with interruptions caused by
+flaky connections or misbehaving servers.
+
+WWW: https://github.com/rgrove/larch