aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-06-20 14:52:57 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-06-20 14:52:57 +0000
commit09409b4f1c8a77e18cf348ca0f27ffda36e162d1 (patch)
tree804b640537f1a17f83a471762a8814027ed1c836 /mail
parentf3826383ab80b607419c505cf308b9b6e3a76888 (diff)
downloadports-09409b4f1c8a77e18cf348ca0f27ffda36e162d1.tar.gz
ports-09409b4f1c8a77e18cf348ca0f27ffda36e162d1.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/mailagent/files/patch-agent-examples-Makefile20
-rw-r--r--mail/mailagent/files/patch-agent-files-Makefile20
-rw-r--r--mail/mailagent/files/patch-agent-files-help-Makefile20
-rw-r--r--mail/mailagent/files/patch-agent-filter-Makefile19
4 files changed, 79 insertions, 0 deletions
diff --git a/mail/mailagent/files/patch-agent-examples-Makefile b/mail/mailagent/files/patch-agent-examples-Makefile
new file mode 100644
index 000000000000..2ca97d6eb39e
--- /dev/null
+++ b/mail/mailagent/files/patch-agent-examples-Makefile
@@ -0,0 +1,20 @@
+--- agent/examples/Makefile.orig 2014-06-20 11:31:53.597110451 -0300
++++ agent/examples/Makefile 2014-06-20 11:32:15.393108703 -0300
+@@ -54,7 +54,7 @@
+ install::
+ @for dir in $(PRIVLIB)/examples; do \
+ case '${MFLAGS}' in *[i]*) set +e;; esac; \
+- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
++ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
+ done
+
+ deinstall::
+@@ -63,7 +63,7 @@
+ install:: $(FILES)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ for i in $(FILES); do \
+- (set -x; $(INSTALL) -c -m 444 $$i $(PRIVLIB)/examples); \
++ (set -x; $(INSTALL) -c -m 444 $$i $(INSTALL_PREFIX)$(PRIVLIB)/examples); \
+ done
+
+ deinstall::
diff --git a/mail/mailagent/files/patch-agent-files-Makefile b/mail/mailagent/files/patch-agent-files-Makefile
new file mode 100644
index 000000000000..784c9f80524e
--- /dev/null
+++ b/mail/mailagent/files/patch-agent-files-Makefile
@@ -0,0 +1,20 @@
+--- agent/files/Makefile.orig 2014-06-20 11:29:40.559119965 -0300
++++ agent/files/Makefile 2014-06-20 11:30:00.539568981 -0300
+@@ -58,7 +58,7 @@
+ install::
+ @for dir in $(PRIVLIB); do \
+ case '${MFLAGS}' in *[i]*) set +e;; esac; \
+- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
++ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
+ done
+
+ deinstall::
+@@ -67,7 +67,7 @@
+ install:: $(FILES)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ for i in $(FILES); do \
+- (set -x; $(INSTALL) -c -m 444 $$i $(PRIVLIB)); \
++ (set -x; $(INSTALL) -c -m 444 $$i $(INSTALL_PREFIX)$(PRIVLIB)); \
+ done
+
+ deinstall::
diff --git a/mail/mailagent/files/patch-agent-files-help-Makefile b/mail/mailagent/files/patch-agent-files-help-Makefile
new file mode 100644
index 000000000000..b1594efd05aa
--- /dev/null
+++ b/mail/mailagent/files/patch-agent-files-help-Makefile
@@ -0,0 +1,20 @@
+--- agent/files/help/Makefile.orig 2014-06-20 11:30:51.718114891 -0300
++++ agent/files/help/Makefile 2014-06-20 11:31:10.122113536 -0300
+@@ -99,7 +99,7 @@
+ install::
+ @for dir in $(PRIVLIB) $(PRIVLIB)/help; do \
+ case '${MFLAGS}' in *[i]*) set +e;; esac; \
+- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
++ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
+ done
+
+ deinstall::
+@@ -108,7 +108,7 @@
+ install:: $(FILES)
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \
+ for i in $(FILES); do \
+- (set -x; $(INSTALL) -c -m 444 $$i $(PRIVLIB)/help); \
++ (set -x; $(INSTALL) -c -m 444 $$i $(INSTALL_PREFIX)$(PRIVLIB)/help); \
+ done
+
+ deinstall::
diff --git a/mail/mailagent/files/patch-agent-filter-Makefile b/mail/mailagent/files/patch-agent-filter-Makefile
new file mode 100644
index 000000000000..0d0d5ba7f0e0
--- /dev/null
+++ b/mail/mailagent/files/patch-agent-filter-Makefile
@@ -0,0 +1,19 @@
+--- agent/filter/Makefile.orig 2014-06-20 11:27:19.802128926 -0300
++++ agent/filter/Makefile 2014-06-20 11:29:16.092184615 -0300
+@@ -124,14 +124,14 @@
+ install::
+ @for dir in $(PRIVLIB); do \
+ case '${MFLAGS}' in *[i]*) set +e;; esac; \
+- (set -x; test -d $$dir || $(INSTALLDIR) $$dir); \
++ (set -x; test -d $$dir || $(INSTALLDIR) $(INSTALL_PREFIX)$$dir); \
+ done
+
+ deinstall::
+ $(RM) -r $(PRIVLIB)
+
+ install:: filter
+- $(INSTALL) -c -s -m 555 filter $(PRIVLIB)
++ $(INSTALL) -c -s -m 555 filter $(INSTALL_PREFIX)$(PRIVLIB)
+
+ deinstall::
+ $(RM) $(PRIVLIB)/filter