aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-03-26 14:01:11 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-03-26 14:01:11 +0000
commit844bcd2dcd554d627f99a92cc420e5cc152d7544 (patch)
tree0457c3708cb4043b1e7157d3aca8cf83ad7a0657 /mail
parentd385189fde0a343112ef77bb3679b97b8c6d29e8 (diff)
downloadports-844bcd2dcd554d627f99a92cc420e5cc152d7544.tar.gz
ports-844bcd2dcd554d627f99a92cc420e5cc152d7544.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/sendmail-old/Makefile35
-rw-r--r--mail/sendmail811/Makefile35
2 files changed, 56 insertions, 14 deletions
diff --git a/mail/sendmail-old/Makefile b/mail/sendmail-old/Makefile
index 124a01973d71..3004dc492299 100644
--- a/mail/sendmail-old/Makefile
+++ b/mail/sendmail-old/Makefile
@@ -11,13 +11,14 @@ PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/sendmail/&,}
+PKGNAMESUFFIX?= ${TLS_SUFFIX}${SFIO_SUFFIX}${SASL_SUFFIX}${LDAP_SUFFIX}${PKGNAMESUFFIX2}
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Reliable, highly configurable mail transfer agent with utilities
-CONFLICTS?= courier-0.* postfix-1.* postfix-2.* sendmail-8.12.* sendmail-*-8.12.* \
- smail-3.* zmailer-2.*
+CONFLICTS?= courier-0.* postfix-1.* postfix-2.* smail-3.* zmailer-2.*
+CONFLICTS+= sendmail-8.12.* sendmail-*-8.12.* sendmail+*-8.12.*
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WCONF= ${WRKSRC}/devtools/Site
@@ -40,22 +41,42 @@ LDAP_PORT?= net/openldap21-client
# SENDMAIL_WITH_LDAP=yes
.if defined(SENDMAIL_WITH_LDAP)
-PKGNAMESUFFIX?= -ldap
+LDAP_SUFFIX?= +ldap
+CONFLICTS+= sendmail+tls-8.* \
+ sendmail+tls+sfio-8.* \
+ sendmail+tls+sasl-8.* \
+ sendmail+tls+sfio+sasl-8.* \
+ sendmail+sfio-8.* \
+ sendmail+sfio+sasl-8.* \
+ sendmail+sasl-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-tls-8.*
LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
.endif
.if defined(SENDMAIL_WITH_SASL)
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-PKGNAMESUFFIX?= -sasl
+SASL_SUFFIX?= +sasl
+CONFLICTS+= sendmail+tls-8.* \
+ sendmail+tls+sfio-8.* \
+ sendmail+tls+sfio+ldap-8.* \
+ sendmail+tls+ldap-8.* \
+ sendmail+sfio-8.* \
+ sendmail+sfio+ldap-8.* \
+ sendmail+ldap-8.*
CONFLICTS+= sendmail-ldap-8.* sendmail-tls-8.*
+LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
.if defined(SENDMAIL_WITH_TLS) || defined(WITH_TLS)
-PKGNAMESUFFIX?= -tls
+TLS_SUFFIX?= +tls
+CONFLICTS+= sendmail+sfio-8.* \
+ sendmail+sfio+sasl-8.* \
+ sendmail+sfio+sasl+ldap-8.* \
+ sendmail+sasl-8.* \
+ sendmail+sasl+ldap-8.* \
+ sendmail+ldap-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-ldap-8.*
.endif
.if defined(SENDMAIL_WITH_SFIO)
-PKGNAMESUFFIX?= -sfio
+SFIO_SUFFIX?= +sfio
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsfio.a:${PORTSDIR}/devel/sfio
.endif
diff --git a/mail/sendmail811/Makefile b/mail/sendmail811/Makefile
index 124a01973d71..3004dc492299 100644
--- a/mail/sendmail811/Makefile
+++ b/mail/sendmail811/Makefile
@@ -11,13 +11,14 @@ PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/sendmail/&,}
+PKGNAMESUFFIX?= ${TLS_SUFFIX}${SFIO_SUFFIX}${SASL_SUFFIX}${LDAP_SUFFIX}${PKGNAMESUFFIX2}
DISTNAME= ${PORTNAME}.${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Reliable, highly configurable mail transfer agent with utilities
-CONFLICTS?= courier-0.* postfix-1.* postfix-2.* sendmail-8.12.* sendmail-*-8.12.* \
- smail-3.* zmailer-2.*
+CONFLICTS?= courier-0.* postfix-1.* postfix-2.* smail-3.* zmailer-2.*
+CONFLICTS+= sendmail-8.12.* sendmail-*-8.12.* sendmail+*-8.12.*
NO_LATEST_LINK= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
WCONF= ${WRKSRC}/devtools/Site
@@ -40,22 +41,42 @@ LDAP_PORT?= net/openldap21-client
# SENDMAIL_WITH_LDAP=yes
.if defined(SENDMAIL_WITH_LDAP)
-PKGNAMESUFFIX?= -ldap
+LDAP_SUFFIX?= +ldap
+CONFLICTS+= sendmail+tls-8.* \
+ sendmail+tls+sfio-8.* \
+ sendmail+tls+sasl-8.* \
+ sendmail+tls+sfio+sasl-8.* \
+ sendmail+sfio-8.* \
+ sendmail+sfio+sasl-8.* \
+ sendmail+sasl-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-tls-8.*
LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
LIB_DEPENDS+= lber.2:${PORTSDIR}/${LDAP_PORT}
.endif
.if defined(SENDMAIL_WITH_SASL)
-LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
-PKGNAMESUFFIX?= -sasl
+SASL_SUFFIX?= +sasl
+CONFLICTS+= sendmail+tls-8.* \
+ sendmail+tls+sfio-8.* \
+ sendmail+tls+sfio+ldap-8.* \
+ sendmail+tls+ldap-8.* \
+ sendmail+sfio-8.* \
+ sendmail+sfio+ldap-8.* \
+ sendmail+ldap-8.*
CONFLICTS+= sendmail-ldap-8.* sendmail-tls-8.*
+LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
.if defined(SENDMAIL_WITH_TLS) || defined(WITH_TLS)
-PKGNAMESUFFIX?= -tls
+TLS_SUFFIX?= +tls
+CONFLICTS+= sendmail+sfio-8.* \
+ sendmail+sfio+sasl-8.* \
+ sendmail+sfio+sasl+ldap-8.* \
+ sendmail+sasl-8.* \
+ sendmail+sasl+ldap-8.* \
+ sendmail+ldap-8.*
CONFLICTS+= sendmail-sasl-8.* sendmail-ldap-8.*
.endif
.if defined(SENDMAIL_WITH_SFIO)
-PKGNAMESUFFIX?= -sfio
+SFIO_SUFFIX?= +sfio
BUILD_DEPENDS+= ${LOCALBASE}/lib/libsfio.a:${PORTSDIR}/devel/sfio
.endif