aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-05 18:40:27 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-02-05 18:40:27 +0000
commitc5d04f810ca686591e1f8279a0648bc2040bd194 (patch)
treedf145921cb450a3c25d700355ca694728ca58ffe /mail
parent5c8c6a4536f681e5af46d10be285277b13219c5c (diff)
downloadports-c5d04f810ca686591e1f8279a0648bc2040bd194.tar.gz
ports-c5d04f810ca686591e1f8279a0648bc2040bd194.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rubygem-actionmailbox60/Makefile30
-rw-r--r--mail/rubygem-actionmailbox60/distinfo3
-rw-r--r--mail/rubygem-actionmailbox60/pkg-descr15
4 files changed, 49 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index d9c735079ced..37342ba52f88 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -582,6 +582,7 @@
SUBDIR += rspamd
SUBDIR += rspamd-devel
SUBDIR += rss2email3
+ SUBDIR += rubygem-actionmailbox60
SUBDIR += rubygem-actionmailer4
SUBDIR += rubygem-actionmailer5
SUBDIR += rubygem-actionmailer50
diff --git a/mail/rubygem-actionmailbox60/Makefile b/mail/rubygem-actionmailbox60/Makefile
new file mode 100644
index 000000000000..a8ac7bb74731
--- /dev/null
+++ b/mail/rubygem-actionmailbox60/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= actionmailbox
+PORTVERSION= 6.0.2.1
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 60
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Receive and process incoming emails in Rails applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+BROKEN_RUBY24= yes
+
+RUN_DEPENDS= rubygem-actionpack60>=${PORTVERSION}:www/rubygem-actionpack60 \
+ rubygem-activejob60>=${PORTVERSION}:devel/rubygem-activejob60 \
+ rubygem-activerecord60>=${PORTVERSION}:databases/rubygem-activerecord60 \
+ rubygem-activestorage60>=${PORTVERSION}:net/rubygem-activestorage60 \
+ rubygem-activesupport60>=${PORTVERSION}:devel/rubygem-activesupport60 \
+ rubygem-mail>=2.7.1,2:mail/rubygem-mail
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailbox60/distinfo b/mail/rubygem-actionmailbox60/distinfo
new file mode 100644
index 000000000000..02ea43080025
--- /dev/null
+++ b/mail/rubygem-actionmailbox60/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577687170
+SHA256 (rubygem/actionmailbox-6.0.2.1.gem) = 6132861d7706cefed207817d6a097e3e991e5656bdefd5b2c927e88465b957f7
+SIZE (rubygem/actionmailbox-6.0.2.1.gem) = 20480
diff --git a/mail/rubygem-actionmailbox60/pkg-descr b/mail/rubygem-actionmailbox60/pkg-descr
new file mode 100644
index 000000000000..3cf8870e8193
--- /dev/null
+++ b/mail/rubygem-actionmailbox60/pkg-descr
@@ -0,0 +1,15 @@
+Action Mailbox routes incoming emails to controller-like mailboxes for
+processing in Rails. It ships with ingresses for Mailgun, Mandrill, Postmark,
+and SendGrid. You can also handle inbound mails directly via the built-in Exim,
+Postfix, and Qmail ingresses.
+
+The inbound emails are turned into InboundEmail records using Active Record and
+feature lifecycle tracking, storage of the original email on cloud storage via
+Active Storage, and responsible data handling with on-by-default incineration.
+
+These inbound emails are routed asynchronously using Active Job to one or
+several dedicated mailboxes, which are capable of interacting directly with the
+rest of your domain model.
+
+WWW: https://rubyonrails.org/
+WWW: https://github.com/rails/rails/tree/master/actionmailbox