aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-11 21:10:54 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-06-11 21:10:54 +0000
commite312ebcda13d662b85d5b43f8c79fc5dbbe9ce48 (patch)
tree506048749f9d89a418e043223a3c2f0b5aca814a /mail
parent398f9a452cf9319b4319588cb767dd6e62dcf084 (diff)
downloadports-e312ebcda13d662b85d5b43f8c79fc5dbbe9ce48.tar.gz
ports-e312ebcda13d662b85d5b43f8c79fc5dbbe9ce48.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rmoldmail/Makefile29
-rw-r--r--mail/rmoldmail/distinfo1
-rw-r--r--mail/rmoldmail/pkg-comment1
-rw-r--r--mail/rmoldmail/pkg-descr9
-rw-r--r--mail/rmoldmail/pkg-plist3
6 files changed, 44 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index eb2a3740ffd5..05339a70d290 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -153,6 +153,7 @@
SUBDIR += rftp
SUBDIR += ripmime
SUBDIR += rlytest
+ SUBDIR += rmoldmail
SUBDIR += ruby-tmail
SUBDIR += sendmail
SUBDIR += serialmail
diff --git a/mail/rmoldmail/Makefile b/mail/rmoldmail/Makefile
new file mode 100644
index 000000000000..39d77cb0c582
--- /dev/null
+++ b/mail/rmoldmail/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: rmoldmail
+# Date created: 7 June 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= rmoldmail
+PORTVERSION= 0.1.0
+CATEGORIES= mail
+MASTER_SITES= http://probiers.net/projects/rmoldmail/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
+
+NO_BUILD= yes
+
+USE_PERL5= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/rmoldmail.RUNconfigure.pl \
+ ${PREFIX}/sbin/rmoldmail
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/rmoldmail
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/rmoldmail
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/rmoldmail/distinfo b/mail/rmoldmail/distinfo
new file mode 100644
index 000000000000..a14d3b2f2dc8
--- /dev/null
+++ b/mail/rmoldmail/distinfo
@@ -0,0 +1 @@
+MD5 (rmoldmail-0.1.0.tar.gz) = 94cbe1f2c995c36ae58426858d24965e
diff --git a/mail/rmoldmail/pkg-comment b/mail/rmoldmail/pkg-comment
new file mode 100644
index 000000000000..f4f966a825c7
--- /dev/null
+++ b/mail/rmoldmail/pkg-comment
@@ -0,0 +1 @@
+Prune a mailbox of messages older than a set number of days
diff --git a/mail/rmoldmail/pkg-descr b/mail/rmoldmail/pkg-descr
new file mode 100644
index 000000000000..388e5574ccb3
--- /dev/null
+++ b/mail/rmoldmail/pkg-descr
@@ -0,0 +1,9 @@
+rmoldmail is a Perl script which removes all mail messages older
+than a configurable number of months from a mailbox file. It is
+possible to use rmoldmail on a running mailserver; it shouldn't
+confuse your MTA or IMAP- or POP3-server.
+
+WWW: http://probiers.net/projects/rmoldmail/
+
+- Pete
+petef@databits.net
diff --git a/mail/rmoldmail/pkg-plist b/mail/rmoldmail/pkg-plist
new file mode 100644
index 000000000000..1d19e9a14d33
--- /dev/null
+++ b/mail/rmoldmail/pkg-plist
@@ -0,0 +1,3 @@
+sbin/rmoldmail
+%%PORTDOCS%%share/doc/rmoldmail/README
+%%PORTDOCS%%@dirrm share/doc/rmoldmail