aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-07 18:50:51 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-07 18:50:51 +0000
commitf7bf81333394350031877647fcb94fe1b32f3fde (patch)
tree4ce41644b6dcf5324dd9f0c6a4fc36dc4ddbaf56 /mail
parent4a462d4c387987fc1c89f726fadf6e82da7cbba9 (diff)
downloadports-f7bf81333394350031877647fcb94fe1b32f3fde.tar.gz
ports-f7bf81333394350031877647fcb94fe1b32f3fde.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/pgp4pine/Makefile4
-rw-r--r--mail/pgp4pine/files/patch-md5.c13
2 files changed, 13 insertions, 4 deletions
diff --git a/mail/pgp4pine/Makefile b/mail/pgp4pine/Makefile
index 162b4bf33fb0..e618b3bb3634 100644
--- a/mail/pgp4pine/Makefile
+++ b/mail/pgp4pine/Makefile
@@ -36,10 +36,6 @@ SCRIPTDIR= ${SAMPLEDIR}
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
-
# Post-patch
#
diff --git a/mail/pgp4pine/files/patch-md5.c b/mail/pgp4pine/files/patch-md5.c
new file mode 100644
index 000000000000..6f502f43888b
--- /dev/null
+++ b/mail/pgp4pine/files/patch-md5.c
@@ -0,0 +1,13 @@
+--- pgp4pine/md5.c.orig Sun Mar 7 13:55:00 2004
++++ pgp4pine/md5.c Sun Mar 7 13:55:02 2004
+@@ -288,8 +288,8 @@
+
+ p = hd->buf;
+ #ifdef WORDS_BIGENDIAN
+-#define X(a) do { *p++ = hd->##a ; *p++ = hd->##a >> 8; \
+- *p++ = hd->##a >> 16; *p++ = hd->##a >> 24; } while(0)
++#define X(a) do { *p++ = (*hd).a ; *p++ = (*hd).a >> 8; \
++ *p++ = (*hd).a >> 16; *p++ = (*hd).a >> 24; } while(0)
+ #else /* little endian */
+ /*#define X(a) do { *(u_int32_t*)p = hd->##a ; p += 4; } while(0)*/
+ /* Unixware's cpp doesn't like the above construct so we do it his way: