aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-03 07:36:35 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-03 07:36:35 +0000
commit6f2ab67ac2278d901d031929e4f7aa98513d0b2a (patch)
treedcbf629388aca01e0deb2a3fdcf13149dc0644ab /mail
parent8266a1ab65d7641adf76ade0aa550aa2ca1c8525 (diff)
downloadports-6f2ab67ac2278d901d031929e4f7aa98513d0b2a.tar.gz
ports-6f2ab67ac2278d901d031929e4f7aa98513d0b2a.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/zmailer/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index a3f58d98a9f6..0582285d0111 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zmailer
-# Date created: 4 January 1999
-# Whom: Alex Perel <veers@disturbed.net>
-#
+# Created by: Alex Perel <veers@disturbed.net>
# $FreeBSD$
-#
PORTNAME= zmailer
PORTVERSION= 2.99.57
@@ -16,24 +12,25 @@ COMMENT= Fully functional fast robust SMTP server and transport agent
CONFLICTS= courier-0.* postfix-1.* postfix-2.* sendmail-8.* sendmail-*-8.* smail-3.*
-OPTIONS= SSL "Enable SSL support" ON
+OPTIONS_DEFINE= SSL
+OPTIONS_DEFAULT=SSL
GNU_CONFIGURE= yes
USE_PERL5= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 900007
-EXTRA_PATCHES= ${FILESDIR}/extra-utmpx
-.endif
-
-.if defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
CONFIGURE_ARGS= --without-openssl
.else
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS= --with-openssl
.endif
+.if ${OSVERSION} >= 900007
+EXTRA_PATCHES= ${FILESDIR}/extra-utmpx
+.endif
+
CONFIGURE_ARGS+=--prefix=${PREFIX}/ \
--with-mailbin=${PREFIX}/sbin \
--with-mailbox=/var/mail \
@@ -84,4 +81,4 @@ post-install:
@${ECHO_CMD} 'mydomain=$$orgdomain' >> ${PREFIX}/etc/zmailer/mail.conf.sample
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>