aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2006-09-03 18:28:27 +0000
committerTim Bishop <tdb@FreeBSD.org>2006-09-03 18:28:27 +0000
commit6371623a9aa7d8711b73b28ab256e15e1ceba54c (patch)
treeaabed79e34e54287c40b212095536f59d0b28a63 /mail
parentd67449b05cdaab34eece61ec674afccea45d646b (diff)
downloadports-6371623a9aa7d8711b73b28ab256e15e1ceba54c.tar.gz
ports-6371623a9aa7d8711b73b28ab256e15e1ceba54c.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/gnubiff/Makefile3
-rw-r--r--mail/gnubiff/distinfo6
-rw-r--r--mail/gnubiff/files/patch-src__mailbox.cc10
-rw-r--r--mail/gnubiff/files/patch-src__mailbox.h10
4 files changed, 25 insertions, 4 deletions
diff --git a/mail/gnubiff/Makefile b/mail/gnubiff/Makefile
index c39d2e6c7e2e..122062a2e9b2 100644
--- a/mail/gnubiff/Makefile
+++ b/mail/gnubiff/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnubiff
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,6 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
# CXXFLAGS needed to work round issue with gcc and openssl 0.9.8a
# /usr/local/include/openssl/sha.h:173: error: ISO C++ does not support `long long'
+CONFIGURE_ARGS+= --infodir=${PREFIX}/info --mandir=${PREFIX}/man
MAN1= gnubiff.1
INFO= gnubiff
diff --git a/mail/gnubiff/distinfo b/mail/gnubiff/distinfo
index c91eddb8391f..a808872485d6 100644
--- a/mail/gnubiff/distinfo
+++ b/mail/gnubiff/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnubiff-2.2.1.tar.gz) = 8d2ef679f42e7a593dc88b750d0cca4c
-SHA256 (gnubiff-2.2.1.tar.gz) = a83f1126926cbc4a558917db9b9ec9905d15a21bf465d6a56ee68ab22c37c99f
-SIZE (gnubiff-2.2.1.tar.gz) = 804401
+MD5 (gnubiff-2.2.2.tar.gz) = 54e026ed12571350dcf8965a090dfa45
+SHA256 (gnubiff-2.2.2.tar.gz) = 120b6f1486f5c78df7fc3190ac1d19151f603261d2afd9e2c97a5c7eb4575306
+SIZE (gnubiff-2.2.2.tar.gz) = 812648
diff --git a/mail/gnubiff/files/patch-src__mailbox.cc b/mail/gnubiff/files/patch-src__mailbox.cc
new file mode 100644
index 000000000000..50cf51ed7da4
--- /dev/null
+++ b/mail/gnubiff/files/patch-src__mailbox.cc
@@ -0,0 +1,10 @@
+--- ./src/mailbox.cc.orig Sun Sep 3 13:08:05 2006
++++ ./src/mailbox.cc Sun Sep 3 13:07:46 2006
+@@ -30,6 +30,7 @@
+ // ========================================================================
+
+ #include <algorithm>
++#include <sys/types.h>
+ #include <regex.h>
+ #include "support.h"
+ #include "mailbox.h"
diff --git a/mail/gnubiff/files/patch-src__mailbox.h b/mail/gnubiff/files/patch-src__mailbox.h
new file mode 100644
index 000000000000..f8e9955b6642
--- /dev/null
+++ b/mail/gnubiff/files/patch-src__mailbox.h
@@ -0,0 +1,10 @@
+--- ./src/mailbox.h.orig Sun Sep 3 16:34:22 2006
++++ ./src/mailbox.h Sun Sep 3 16:34:36 2006
+@@ -38,6 +38,7 @@
+ #include <functional>
+ #include <glib.h>
+ #include <map>
++#include <sys/types.h>
+ #include <regex.h>
+ #include <set>
+ #include <string>