aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2007-12-21 10:39:14 +0000
committerDoug Barton <dougb@FreeBSD.org>2007-12-21 10:39:14 +0000
commita68aef9011bccd0f7e12bb7020339dd34b897d68 (patch)
tree329724abf63c1745cf0b4a07dc5659bf52484916 /mail
parenta89a5b605854c5f5a81d2f8fafbdb4591e2697bd (diff)
downloadports-a68aef9011bccd0f7e12bb7020339dd34b897d68.tar.gz
ports-a68aef9011bccd0f7e12bb7020339dd34b897d68.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/alpine/Makefile179
-rw-r--r--mail/alpine/distinfo9
-rw-r--r--mail/alpine/files/cons25-alpine_keymenu.c15
-rw-r--r--mail/alpine/pkg-descr24
-rw-r--r--mail/alpine/pkg-message5
-rw-r--r--mail/alpine/pkg-plist24
7 files changed, 257 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6a79949d0626..8777afba4420 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -8,6 +8,7 @@
SUBDIR += addresses
SUBDIR += addresses-goodies
SUBDIR += akpop3d
+ SUBDIR += alpine
SUBDIR += altermime
SUBDIR += althea
SUBDIR += annoyance-filter
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
new file mode 100644
index 000000000000..1d8f1e3f3a95
--- /dev/null
+++ b/mail/alpine/Makefile
@@ -0,0 +1,179 @@
+# New ports collection makefile for: alpine
+# Date created: December 21, 2007
+# Whom: Doug Barton <dougb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME?= alpine
+PORTVERSION= 1.00
+PORTREVISION?= 0
+CATEGORIES?= mail news ipv6
+MASTER_SITES= ftp://ftp.cac.washington.edu/alpine/ \
+ http://dougbarton.us/Downloads/alpine-${PORTVERSION}/
+DIST_SUBDIR= alpine-${PORTVERSION}
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT?= Mail and news client descended from Pine
+
+OPTIONS+= THREADS "Support for pthreads" on \
+ MOUSE "Enable mouse support for xterm" on \
+ NLS "National Language Support" off \
+ ISPELL "Use ispell instead of aspell as default speller" off \
+ NOSPELL "Use no default speller (overrides both)" off
+.if !defined(PICO_ALPINE_SLAVE)
+OPTIONS+= PICO "Build and install pico, the default editor" on \
+ IPV6 "Add support for IPv6" on \
+ LDAP "Add support for LDAP" off \
+ PASSFILE "Support for a stored password file (DANGEROUS)" off \
+ CONS25 "Add a patch to support color for default console" off \
+ QUOTA "Add a patch for disk quota checking on IMAP" off \
+ MAILDIR "Add a patch for maildir support" off
+.endif
+
+USE_BZIP2= yes
+
+GNU_CONFIGURE= yes
+
+.if !defined(PICO_ALPINE_SLAVE)
+CONFIGURE_ARGS+=--with-system-pinerc=${PREFIX}/etc/alpine.conf \
+ --with-system-fixed-pinerc=${PREFIX}/etc/alpine.conf.fixed \
+ --with-password-prog=/usr/bin/passwd \
+ --with-system-mail-directory=/var/mail \
+ --enable-background-post --without-krb5 --without-tcl
+.endif
+CONFIGURE_ARGS+=--with-debug-level=2
+
+CONFLICTS= pico-4* pine4-4*
+
+USE_OPENSSL= yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --with-pthread
+.else
+CONFIGURE_ARGS+= --without-pthread
+.endif
+
+.if !defined(WITHOUT_MOUSE)
+CONFIGURE_ARGS+= --enable-mouse
+.else
+CONFIGURE_ARGS+= --disable-mouse
+.endif
+
+.if defined(WITH_NLS)
+CONFIGURE_ARGS+= --with-nls
+.else
+CONFIGURE_ARGS+= --without-nls
+.endif
+
+.if !defined(WITH_NOSPELL)
+.if !defined(WITH_ISPELL)
+CONFIGURE_ARGS+=--with-spellcheck-prog="${LOCALBASE}/bin/aspell --dont-backup --mode=email check"
+RUN_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+.else
+CONFIGURE_ARGS+= --with-spellcheck-prog="${LOCALBASE}/bin/ispell
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+.endif
+.endif
+
+.if !defined(PICO_ALPINE_SLAVE)
+.if !defined(WITHOUT_PICO)
+RUN_DEPENDS+= pico:${PORTSDIR}/editors/pico-alpine
+.endif
+
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --with-ipv6
+.else
+CONFIGURE_ARGS+= --without-ipv6
+.endif
+
+.if defined(WITH_LDAP)
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+= --with-ldap --with-ldap-dir=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-ldap
+.endif
+
+.if defined(WITH_PASSFILE)
+ALPINE_PASSFILE?= .alpine.pwd
+CONFIGURE_ARGS+= --with-passfile=".alpine.pwd"
+.endif
+
+.if defined(WITH_CONS25)
+EXTRA_PATCHES= ${FILESDIR}/cons25-alpine_keymenu.c
+.endif
+
+.if defined(WITH_QUOTA) || defined(WITH_MAILDIR)
+PATCH_SITES= http://staff.washington.edu/chappa/alpine/patches/alpine-${PORTVERSION}/ \
+ http://dougbarton.us/Downloads/alpine-${PORTVERSION}/ \
+ ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= dougb/alpine-${PORTVERSION}/
+PATCH_DIST_ARGS+= -E --quiet -d ${PATCH_WRKSRC} -p1
+.endif
+
+.if defined(WITH_QUOTA)
+PATCHFILES+= quota.patch.gz
+.endif
+
+.if defined(WITH_MAILDIR)
+PATCHFILES+= maildir.patch.gz
+.endif
+
+.if defined(WITHOUT_SSL)
+MAKE_ARGS+= SSLTYPE=none
+.else
+EXTRA_OPTS+= SSLINCLUDE=${OPENSSLINC} SSLLIB=${OPENSSLLIB}
+.if defined(WITH_SSL_AND_PLAINTEXT)
+EXTRA_OPTS+= SSLTYPE=nopwd
+.else
+EXTRA_OPTS+= SSLTYPE=unix
+.endif
+.endif
+
+MAN1= alpine.1 rpdump.1 rpload.1
+
+pre-patch:
+ @${CHMOD} -R u+w ${WRKSRC}
+
+post-patch:
+ @${CP} ${WRKSRC}/imap/Makefile ${WRKSRC}/imap/Makefile.presed
+ @${SED} -e "s#^\(all:.*\) bundled\$$#\1#" \
+ ${WRKSRC}/imap/Makefile.presed > ${WRKSRC}/imap/Makefile
+ @${CP} ${WRKSRC}/pico/Makefile.in ${WRKSRC}/pico/Makefile.in.presed
+ @${SED} -e "s#^bin_PROGRAMS = pico.*#bin_PROGRAMS =#" \
+ -e "s#\$$(pico_SOURCES) \$$(pilot_SOURCES)##" \
+ ${WRKSRC}/pico/Makefile.in.presed > ${WRKSRC}/pico/Makefile.in
+ @${CP} ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in.presed
+ @${SED} -e "s#doc/pico.1 doc/pilot.1 ##" \
+ ${WRKSRC}/Makefile.in.presed > ${WRKSRC}/Makefile.in
+ @for i in ${WRKSRC}/README ${WRKSRC}/doc/alpine.1 \
+ ${WRKSRC}/doc/tech-notes.txt ${WRKSRC}/doc/tech-notes/*.html \
+ ${WRKSRC}/pith/pine.hlp ; do \
+ ${CP} $$i $$i.presed ; \
+ ${SED} -e "s:/usr/local/etc/:${PREFIX}/etc/:g" \
+ -e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
+ -e "s:@@PREFIX@@:${PREFIX}:g" \
+ -e "s:/usr/local/pine.conf:${PREFIX}/etc/alpine.conf:g" \
+ $$i.presed > $$i ; \
+ done
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${DOCSDIR} \
+ ${DOCSDIR}/tech-notes
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NOTICE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/brochure.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tech-notes.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tech-notes/*.html ${DOCSDIR}/tech-notes
+.endif
+ ${PREFIX}/bin/alpine -P ${PREFIX}/etc/alpine.conf -conf >${WRKSRC}/alpine.conf
+ ${INSTALL_DATA} ${WRKSRC}/alpine.conf ${PREFIX}/etc/alpine.conf
+
+ @${CAT} ${PKGMESSAGE}
+.endif # !defined(PICO_ALPINE_SLAVE)
+
+.include <bsd.port.post.mk>
diff --git a/mail/alpine/distinfo b/mail/alpine/distinfo
new file mode 100644
index 000000000000..1a2915e81c11
--- /dev/null
+++ b/mail/alpine/distinfo
@@ -0,0 +1,9 @@
+MD5 (alpine-1.00/alpine-1.00.tar.bz2) = c5dad25d8f848cad0e3077edd3038c43
+SHA256 (alpine-1.00/alpine-1.00.tar.bz2) = 7a832aacb7a6c005ea51e09bb9a4ea33b2afc029f9b65d34a83a2eef4d3c842d
+SIZE (alpine-1.00/alpine-1.00.tar.bz2) = 4792104
+MD5 (alpine-1.00/maildir.patch.gz) = e422e18dede9023cd489b0e02a907286
+SHA256 (alpine-1.00/maildir.patch.gz) = f0c39b840c1c3433da3422d0f11742b6ef8e8a57fc480698dc9d82d8235d2742
+SIZE (alpine-1.00/maildir.patch.gz) = 31778
+MD5 (alpine-1.00/quota.patch.gz) = 95d73bbad65e258ff1ad622a9c843f26
+SHA256 (alpine-1.00/quota.patch.gz) = ba6593c9c8db88cb64cfe4e1ff10cca82be03f03ad4ea3267cfc86cfc4e9d900
+SIZE (alpine-1.00/quota.patch.gz) = 3140
diff --git a/mail/alpine/files/cons25-alpine_keymenu.c b/mail/alpine/files/cons25-alpine_keymenu.c
new file mode 100644
index 000000000000..1d1507f4eff5
--- /dev/null
+++ b/mail/alpine/files/cons25-alpine_keymenu.c
@@ -0,0 +1,15 @@
+--- alpine/keymenu.c.orig 2007-12-21 01:53:12.000000000 -0800
++++ alpine/keymenu.c 2007-12-21 01:53:12.000000000 -0800
+@@ -2601,7 +2601,12 @@
+ char this_label[6*MAX_LABEL+1];
+
+ j = 6*i - 1;
++
++ /*
++ Change this line so that color works on cons25 terminals
+ if(i == 1 && !label_color)
++ */
++ if(i == 1)
+ max_column--; /* Some terminals scroll if you write in the
+ lower right hand corner. If user has a
+ label_color set we'll take our chances.
diff --git a/mail/alpine/pkg-descr b/mail/alpine/pkg-descr
new file mode 100644
index 000000000000..7a9407d8ea64
--- /dev/null
+++ b/mail/alpine/pkg-descr
@@ -0,0 +1,24 @@
+Alpine is a screen-oriented message-handling tool for news, and POP, IMAP,
+and local e-mail. In its default configuration it offers a limited set of
+functions geared toward the novice user, but it also has a large list of
+optional "power-user" and personal-preference features.
+
+Alpine's basic feature set includes:
+ * View, Save, Export, Delete, Print, Reply and Forward messages.
+ Compose messages in a simple editor with word-wrap and a
+ spelling checker. Messages may be postponed for later completion.
+ * Selection and management of message folders.
+ * Address book to keep a list of long or frequently-used
+ addresses. Personal distribution lists may be defined.
+ Addresses may be taken into the address book from incoming mail
+ without retyping them.
+ * New mail checking/notification occurs automatically (configurable).
+ * On-line, context-sensitive help screens.
+
+Alpine supports MIME (Multipurpose Internet Mail Extensions), an Internet
+Standard for representing multipart and multimedia data in email.
+
+WWW: http://www.washington.edu/alpine/
+
+- Doug Barton
+dougb@FreeBSD.org
diff --git a/mail/alpine/pkg-message b/mail/alpine/pkg-message
new file mode 100644
index 000000000000..1ab4c4be6b8e
--- /dev/null
+++ b/mail/alpine/pkg-message
@@ -0,0 +1,5 @@
+
+*******************************************************************************
+*** To use GnuPG with Alpine, take a look at the mail/pine-pgp-filters port ***
+*******************************************************************************
+
diff --git a/mail/alpine/pkg-plist b/mail/alpine/pkg-plist
new file mode 100644
index 000000000000..400015b10245
--- /dev/null
+++ b/mail/alpine/pkg-plist
@@ -0,0 +1,24 @@
+@unexec %D/bin/alpine -conf >%D/etc/alpine.conf.tmp
+@unexec if cmp -s %D/etc/alpine.conf %D/etc/alpine.conf.tmp; then rm -f %D/etc/alpine.conf; fi
+@unexec rm -f %D/etc/alpine.conf.tmp
+bin/alpine
+bin/rpdump
+bin/rpload
+@exec %D/bin/alpine -P %D/etc/alpine.conf -conf >%D/etc/alpine.conf.tmp
+@exec /bin/mv %D/etc/alpine.conf.tmp %D/etc/alpine.conf
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/brochure.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes.txt
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/background.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/cmd-line.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/config-notes.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/config.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/index.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/installation.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/low-level.html
+%%PORTDOCS%%%%DOCSDIR%%/tech-notes/porting.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/tech-notes
+%%PORTDOCS%%@dirrm %%DOCSDIR%%