aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2018-12-27 08:10:32 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2018-12-27 08:10:32 +0000
commite7db1030de5c109e693254e95552b9c22a8fc566 (patch)
treec30c1f87302d1103e88233dafb7f25c922559ec4 /mail
parent862cb2d249ec5bf8137415f2062887cc5463ae44 (diff)
downloadports-e7db1030de5c109e693254e95552b9c22a8fc566.tar.gz
ports-e7db1030de5c109e693254e95552b9c22a8fc566.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/s-nail/Makefile44
-rw-r--r--mail/s-nail/distinfo3
-rw-r--r--mail/s-nail/pkg-descr12
4 files changed, 60 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index f6a0367c0f44..84c6fe557dc4 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -637,6 +637,7 @@
SUBDIR += rubygem-ruby-qmail
SUBDIR += rubygem-tmail
SUBDIR += rubygem-vmail
+ SUBDIR += s-nail
SUBDIR += sa-stats
SUBDIR += sa-utils
SUBDIR += scam-backscatter
diff --git a/mail/s-nail/Makefile b/mail/s-nail/Makefile
new file mode 100644
index 000000000000..bb46ca0b7398
--- /dev/null
+++ b/mail/s-nail/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= s-nail
+PORTVERSION= 14.9.11
+CATEGORIES= mail
+MASTER_SITES= https://www.sdaoden.eu/downloads/
+
+MAINTAINER= yasu@utahime.org
+COMMENT= Send and receive Internet mail
+
+LICENSE= BSD3CLAUSE BSD4CLAUSE ISCL MIT RFC2104 RSA
+LICENSE_COMB= multi
+LICENSE_NAME_RFC2104= License of RFC2104
+LICENSE_NAME_RSA= RSA Data Security license
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS_RFC2104= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+LICENSE_PERMS_RSA= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= libidn2.so:dns/libidn2
+RUN_DEPENDS= mime-support>0:misc/mime-support
+
+USES= iconv ssl tar:xz
+
+PLIST_FILES= bin/s-nail \
+ "@sample etc/s-nail.rc.sample" \
+ libexec/s-nail-privsep \
+ man/man1/s-nail.1.gz
+
+MAKEFILE= makefile
+MAKE_ENV= VAL_PREFIX=${PREFIX} VAL_MANDIR=${MANPREFIX}/man VAL_MIME_TYPES_SYS=${PREFIX}/etc/mime.types VAL_IDNA=idn2
+MAKE_JOBS_UNSAFE= yes
+
+PORTDOCS= NEWS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/nail.rc ${STAGEDIR}${PREFIX}/etc/s-nail.rc.sample
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/s-nail/distinfo b/mail/s-nail/distinfo
new file mode 100644
index 000000000000..f308a9c2e19e
--- /dev/null
+++ b/mail/s-nail/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539245997
+SHA256 (s-nail-14.9.11.tar.xz) = 258d818449da889c5fc4976215698a817c0a3818fb77dd565fa9fe6afed0023e
+SIZE (s-nail-14.9.11.tar.xz) = 674464
diff --git a/mail/s-nail/pkg-descr b/mail/s-nail/pkg-descr
new file mode 100644
index 000000000000..fc74e35a536b
--- /dev/null
+++ b/mail/s-nail/pkg-descr
@@ -0,0 +1,12 @@
+S-nail provides a simple and friendly environment for sending and
+receiving mail. It is intended to provide the functionality of the
+POSIX mailx(1) command, but is MIME capable and optionally offers
+extensions for line editing, S/MIME, SMTP and POP3, among others.
+S-nail divides incoming mail into its constituent messages and allows
+the user to deal with them in any order. It offers many COMMANDS and
+INTERNAL VARIABLES for manipulating messages and sending mail. It
+provides the user simple editing capabilities to ease the composition
+of outgoing messages, and increasingly powerful and reliable
+non-interactive scripting capabilities.
+
+WWW: https://www.sdaoden.eu/code.html#s-mailx