aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:46:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 20:46:47 +0000
commitb678a81e598d69d32a6dd6a6c396170c9996e5bb (patch)
treeaeb224c361e079ad3b615cc52dc30c6df4018415 /mail
parentb3a47f11f3432ef2cf681dfdabf61762f13d1401 (diff)
downloadports-b678a81e598d69d32a6dd6a6c396170c9996e5bb.tar.gz
ports-b678a81e598d69d32a6dd6a6c396170c9996e5bb.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/squirrelmail-notes-plugin/Makefile75
-rw-r--r--mail/squirrelmail-notes-plugin/distinfo3
-rw-r--r--mail/squirrelmail-notes-plugin/files/pkg-message.in5
-rw-r--r--mail/squirrelmail-notes-plugin/pkg-descr4
-rw-r--r--mail/squirrelmail-notes-plugin/pkg-plist21
6 files changed, 109 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ca961726316c..ff89de28ff68 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -512,6 +512,7 @@
SUBDIR += squirrelmail-compatibility-plugin
SUBDIR += squirrelmail-devel
SUBDIR += squirrelmail-email_footer-plugin
+ SUBDIR += squirrelmail-notes-plugin
SUBDIR += squirrelmail-vlogin-plugin
SUBDIR += sqwebmail
SUBDIR += ssmtp
diff --git a/mail/squirrelmail-notes-plugin/Makefile b/mail/squirrelmail-notes-plugin/Makefile
new file mode 100644
index 000000000000..f800f0213108
--- /dev/null
+++ b/mail/squirrelmail-notes-plugin/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: squirrelmail-notes-plugin
+# Date created: 10 Feb 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
+PORTVERSION= 1.2
+CATEGORIES= mail www
+MASTER_SITES= http://www.squirrelmail.org/plugins/
+DISTNAME= ${SQUIRREL_PLUGIN_NAME}.${PORTVERSION}-1.4.0
+DIST_SUBDIR= squirrelmail
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Allows you to create notes
+
+RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
+ ${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin
+
+SQUIRREL_PLUGIN_NAME= notes
+
+.ifdef SQUIRRELDIR
+PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
+SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
+.else
+. ifndef WITHOUT_WWWDIR
+SQUIRRELDIR= ${PREFIX}/www/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
+SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
+. else
+SQUIRRELDIR= ${PREFIX}/squirrelmail
+PLIST_SUB+= SQUIRRELDIR=squirrelmail
+SUB_LIST+= "SQUIRRELDIR=squirrelmail"
+. endif
+.endif
+
+SUB_FILES= pkg-message
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+pre-everything::
+ @${ECHO} ""
+.ifndef WITHOUT_ACTIVATE
+ @${ECHO} "Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you don't want to automatically activate the plug-in set"
+ @${ECHO} "WITHOUT_ACTIVATE=yes"
+.else
+ @${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
+ @${ECHO} "If you want to automatically activate the plug-in unset"
+ @${ECHO} "WITHOUT_ACTIVATE"
+.endif
+ @${ECHO} ""
+
+do-install:
+ ${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
+
+post-install:
+.ifndef WITHOUT_ACTIVATE
+.if exists( ${SQUIRRELDIR}/config/config.php )
+ @${ECHO} "Activating plug-in in SquirrelMail"
+ ${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
+.endif
+.else
+ @${ECHO} "To activate the plug-in in SquirrelMail use"
+ @${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
+.endif
+ @${ECHO} ""
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/squirrelmail-notes-plugin/distinfo b/mail/squirrelmail-notes-plugin/distinfo
new file mode 100644
index 000000000000..c842fd4af9c7
--- /dev/null
+++ b/mail/squirrelmail-notes-plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (squirrelmail/notes.1.2-1.4.0.tar.gz) = 4a2aaa752e81e0c285dd9f47593a8823
+SHA256 (squirrelmail/notes.1.2-1.4.0.tar.gz) = 569755d8dc15773db90c55a833ead6e70c9659f6896f7559929515250672d88c
+SIZE (squirrelmail/notes.1.2-1.4.0.tar.gz) = 13661
diff --git a/mail/squirrelmail-notes-plugin/files/pkg-message.in b/mail/squirrelmail-notes-plugin/files/pkg-message.in
new file mode 100644
index 000000000000..bb53d88b1042
--- /dev/null
+++ b/mail/squirrelmail-notes-plugin/files/pkg-message.in
@@ -0,0 +1,5 @@
+For the port to work properly you must copy the file
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/notes/config.php.sample
+to
+%%PREFIX%%/%%SQUIRRELDIR%%/plugins/notes/config.php
+and edit the configuration to meet your needs.
diff --git a/mail/squirrelmail-notes-plugin/pkg-descr b/mail/squirrelmail-notes-plugin/pkg-descr
new file mode 100644
index 000000000000..fd82571edac5
--- /dev/null
+++ b/mail/squirrelmail-notes-plugin/pkg-descr
@@ -0,0 +1,4 @@
+Allows you to create notes, for easy reminders or
+quick saving of information for future use.
+
+WWW: http://www.squirrelmail.org
diff --git a/mail/squirrelmail-notes-plugin/pkg-plist b/mail/squirrelmail-notes-plugin/pkg-plist
new file mode 100644
index 000000000000..652e91bbd1e1
--- /dev/null
+++ b/mail/squirrelmail-notes-plugin/pkg-plist
@@ -0,0 +1,21 @@
+@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin notes; fi
+%%SQUIRRELDIR%%/plugins/notes/images/X.gif
+%%SQUIRRELDIR%%/plugins/notes/images/_.gif
+%%SQUIRRELDIR%%/plugins/notes/images/max.gif
+%%SQUIRRELDIR%%/plugins/notes/images/index.php
+%%SQUIRRELDIR%%/plugins/notes/locale/create_po.php
+%%SQUIRRELDIR%%/plugins/notes/locale/index.php
+%%SQUIRRELDIR%%/plugins/notes/locale/notes.po
+%%SQUIRRELDIR%%/plugins/notes/LICENSE
+%%SQUIRRELDIR%%/plugins/notes/README
+%%SQUIRRELDIR%%/plugins/notes/config.php.sample
+%%SQUIRRELDIR%%/plugins/notes/functions.php
+%%SQUIRRELDIR%%/plugins/notes/index.php
+%%SQUIRRELDIR%%/plugins/notes/notes.class.php
+%%SQUIRRELDIR%%/plugins/notes/notes.php
+%%SQUIRRELDIR%%/plugins/notes/setup.php
+%%SQUIRRELDIR%%/plugins/notes/version
+@dirrm %%SQUIRRELDIR%%/plugins/notes/images/
+@dirrm %%SQUIRRELDIR%%/plugins/notes/locale/
+@dirrm %%SQUIRRELDIR%%/plugins/notes/
+@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin notes; fi