aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-01-11 23:02:00 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2022-01-11 23:04:35 +0000
commitddb780fd16bc6ce25b5b2bd1367d1af6d6d466e2 (patch)
tree501278eecd56558f6b5d380a5680a4968a0021b5 /mail
parenta3644f050cb2db0d17bb4f3c087a930c667c9083 (diff)
downloadports-ddb780fd16bc6ce25b5b2bd1367d1af6d6d466e2.tar.gz
ports-ddb780fd16bc6ce25b5b2bd1367d1af6d6d466e2.zip
mail/thunderbird: update to 91.5.0
Release Notes: https://www.thunderbird.net/en-US/thunderbird/91.5.0/releasenotes/ (cherry picked from commit 7d188b8bad7df0366619c058ed2d0c30ad31d43c)
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-bug161891450
3 files changed, 4 insertions, 54 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index f5dcc4ddddca..26e0ea91ba7a 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -1,7 +1,7 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
PORTNAME= thunderbird
-DISTVERSION= 91.4.1
+DISTVERSION= 91.5.0
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index bfcffb9a47e1..8f7bc4190218 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1639748924
-SHA256 (thunderbird-91.4.1.source.tar.xz) = f1079ed2cbd335a417b18929c5018d8ade9fb1d0c8cba9fdb2b6d672f14074f1
-SIZE (thunderbird-91.4.1.source.tar.xz) = 408805472
+TIMESTAMP = 1641921486
+SHA256 (thunderbird-91.5.0.source.tar.xz) = b89a8e1b57d5be828a7346e817120d7c763a258a2397a23393b7ceb3ce810ab2
+SIZE (thunderbird-91.5.0.source.tar.xz) = 405937856
diff --git a/mail/thunderbird/files/patch-bug1618914 b/mail/thunderbird/files/patch-bug1618914
deleted file mode 100644
index c52ac49018b2..000000000000
--- a/mail/thunderbird/files/patch-bug1618914
+++ /dev/null
@@ -1,50 +0,0 @@
-From cea8e6a01bb03bbe565c9bf5dd4f439f30ca953f Mon Sep 17 00:00:00 2001
-From: Jan Beich <jbeich@FreeBSD.org>
-Date: Fri, 28 Feb 2020 16:49:38 +0000
-Subject: Bug 1618914 - [Wayland] Fall back to ftruncate if posix_fallocate isn't supported by filesystem.
-
-diff --git widget/gtk/WaylandShmBuffer.cpp widget/gtk/WaylandShmBuffer.cpp
-index 42eeedd3429ac..2a5c23d287413 100644
---- widget/gtk/WaylandShmBuffer.cpp
-+++ widget/gtk/WaylandShmBuffer.cpp
-@@ -67,36 +67,37 @@ static int WaylandAllocateShmMemory(int aSize) {
- return -1;
- }
-
- int ret = 0;
- #ifdef HAVE_POSIX_FALLOCATE
- do {
- ret = posix_fallocate(fd, 0, aSize);
- } while (ret == EINTR);
-- if (ret != 0) {
-+ if (ret == 0) {
-+ return fd;
-+ } else if (ret != ENODEV && ret != EINVAL && ret != EOPNOTSUPP) {
- NS_WARNING(
- nsPrintfCString("posix_fallocate() fails to allocate shm memory: %s",
- strerror(ret))
- .get());
- close(fd);
- return -1;
- }
--#else
-+#endif
- do {
- ret = ftruncate(fd, aSize);
- } while (ret < 0 && errno == EINTR);
- if (ret < 0) {
- NS_WARNING(nsPrintfCString("ftruncate() fails to allocate shm memory: %s",
- strerror(ret))
- .get());
- close(fd);
- fd = -1;
- }
--#endif
-
- return fd;
- }
-
- /* static */
- RefPtr<WaylandShmPool> WaylandShmPool::Create(
- const RefPtr<nsWaylandDisplay>& aWaylandDisplay, int aSize) {
- RefPtr<WaylandShmPool> shmPool = new WaylandShmPool(aSize);