aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-07-13 11:03:49 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-07-13 11:03:49 +0000
commit01db6a2efc6cb5004e56acea36559d89d5bbc972 (patch)
tree32729bbafa490e5a27796683830ef2b025eab6cf /mail
parentf700af214e059345fd77bae25481efb928d35af7 (diff)
downloadports-01db6a2efc6cb5004e56acea36559d89d5bbc972.tar.gz
ports-01db6a2efc6cb5004e56acea36559d89d5bbc972.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/notmuch/Makefile10
-rw-r--r--mail/notmuch/distinfo4
-rw-r--r--mail/notmuch/files/patch-Makefile.local11
-rw-r--r--mail/notmuch/files/patch-doc_Makefile.local8
-rw-r--r--mail/notmuch/files/patch-lib_Makefile.local16
-rw-r--r--mail/notmuch/pkg-plist3
6 files changed, 14 insertions, 38 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index ea038047d360..c1a05473796f 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.19
+PORTVERSION= 0.20.2
CATEGORIES= mail
MASTER_SITES= http://notmuchmail.org/releases/
-MAINTAINER= ross@rosstimson.com
+MAINTAINER= mp39590@gmail.com
COMMENT= Thread-based email index, search, and tagging application
LICENSE= GPLv3
@@ -37,12 +37,16 @@ USE_EMACS= yes
.endif
HAS_CONFIGURE= yes
-USES= pkgconfig python:build gmake
+USES= gmake pkgconfig python:build
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
USE_LDCONFIG= yes
MAKE_ENV+= PYTHONCMD=${PYTHON_CMD}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notmuch
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libnotmuch.so.4.2.0
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 900044
diff --git a/mail/notmuch/distinfo b/mail/notmuch/distinfo
index 69e70dd1964c..09b5cd4f33ee 100644
--- a/mail/notmuch/distinfo
+++ b/mail/notmuch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (notmuch-0.19.tar.gz) = 396fc6548423785ebbbe9a6cce321d957d3b2e856edb8225bb0988470833eeeb
-SIZE (notmuch-0.19.tar.gz) = 659038
+SHA256 (notmuch-0.20.2.tar.gz) = f741a26345bff389fd8a4a119c4174c6585730f71844809583a54ef2a865adec
+SIZE (notmuch-0.20.2.tar.gz) = 652945
diff --git a/mail/notmuch/files/patch-Makefile.local b/mail/notmuch/files/patch-Makefile.local
deleted file mode 100644
index f0b2bf84635e..000000000000
--- a/mail/notmuch/files/patch-Makefile.local
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.local.orig 2014-06-25 10:30:10.000000000 +0000
-+++ Makefile.local
-@@ -302,7 +302,7 @@ notmuch-shared: $(notmuch_client_modules
- .PHONY: install
- install: all install-man
- mkdir -p "$(DESTDIR)$(prefix)/bin/"
-- install notmuch-shared "$(DESTDIR)$(prefix)/bin/notmuch"
-+ ${BSD_INSTALL_PROGRAM} notmuch-shared "$(DESTDIR)$(prefix)/bin/notmuch"
- ifeq ($(MAKECMDGOALS), install)
- @echo ""
- @echo "Notmuch is now installed to $(DESTDIR)$(prefix)"
diff --git a/mail/notmuch/files/patch-doc_Makefile.local b/mail/notmuch/files/patch-doc_Makefile.local
index 2a89db236667..6c7f4ff4d2d9 100644
--- a/mail/notmuch/files/patch-doc_Makefile.local
+++ b/mail/notmuch/files/patch-doc_Makefile.local
@@ -1,13 +1,11 @@
---- doc/Makefile.local.orig 2014-06-25 10:30:10.000000000 +0000
+--- doc/Makefile.local.orig 2015-07-09 20:39:00 UTC
+++ doc/Makefile.local
-@@ -7,8 +7,8 @@ SPHINXOPTS := -q
+@@ -7,7 +7,7 @@ SPHINXOPTS := -q
SPHINXBUILD = sphinx-build
DOCBUILDDIR := $(dir)/_build
--prerst2man := python $(srcdir)/$(dir)/prerst2man.py
-mkdocdeps := python $(srcdir)/$(dir)/mkdocdeps.py
-+prerst2man := ${PYTHONCMD} $(srcdir)/$(dir)/prerst2man.py
-+mkdocdeps := ${PYTHONCMD} $(srcdir)/$(dir)/mkdocdeps.py
++mkdocdeps := $(PYTHON) $(srcdir)/$(dir)/mkdocdeps.py
# Internal variables.
ALLSPHINXOPTS := -d $(DOCBUILDDIR)/doctrees $(SPHINXOPTS) $(srcdir)/$(dir)
diff --git a/mail/notmuch/files/patch-lib_Makefile.local b/mail/notmuch/files/patch-lib_Makefile.local
deleted file mode 100644
index 4f450748b9f2..000000000000
--- a/mail/notmuch/files/patch-lib_Makefile.local
+++ /dev/null
@@ -1,16 +0,0 @@
---- lib/Makefile.local.orig 2014-06-25 10:30:10.000000000 +0000
-+++ lib/Makefile.local
-@@ -92,11 +92,11 @@ install: install-$(dir)
-
- install-$(dir): $(dir)/$(LIBNAME)
- mkdir -p "$(DESTDIR)$(libdir)/"
-- install -m0644 "$(lib)/$(LIBNAME)" "$(DESTDIR)$(libdir)/"
-+ ${BSD_INSTALL_LIB} "$(lib)/$(LIBNAME)" "$(DESTDIR)$(libdir)/"
- ln -sf $(LIBNAME) "$(DESTDIR)$(libdir)/$(SONAME)"
- ln -sf $(LIBNAME) "$(DESTDIR)$(libdir)/$(LINKER_NAME)"
- mkdir -p "$(DESTDIR)$(includedir)"
-- install -m0644 "$(srcdir)/$(lib)/notmuch.h" "$(DESTDIR)$(includedir)/"
-+ ${BSD_INSTALL_DATA} "$(srcdir)/$(lib)/notmuch.h" "$(DESTDIR)$(includedir)/"
- $(LIBRARY_INSTALL_POST_COMMAND)
-
- SRCS := $(SRCS) $(libnotmuch_c_srcs) $(libnotmuch_cxx_srcs)
diff --git a/mail/notmuch/pkg-plist b/mail/notmuch/pkg-plist
index 8f326a23f634..99bbe6724b99 100644
--- a/mail/notmuch/pkg-plist
+++ b/mail/notmuch/pkg-plist
@@ -2,12 +2,13 @@ bin/notmuch
include/notmuch.h
lib/libnotmuch.so
lib/libnotmuch.so.4
-lib/libnotmuch.so.4.1.0
+lib/libnotmuch.so.4.2.0
man/man1/notmuch-address.1.gz
man/man1/notmuch-compact.1.gz
man/man1/notmuch-config.1.gz
man/man1/notmuch-count.1.gz
man/man1/notmuch-dump.1.gz
+man/man1/notmuch-emacs-mua.1.gz
man/man1/notmuch-insert.1.gz
man/man1/notmuch-new.1.gz
man/man1/notmuch-reply.1.gz