aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-07-26 19:52:49 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-07-26 19:52:49 +0000
commit5e566bc0254f1c700dcc94fb5d9361ae39a18a09 (patch)
tree876d8be0d38388b70a65c49c75a364a99521a3e7 /mail
parent7ecc5ef8bc82da2f2f86c0f62c70848ce54b24ca (diff)
downloadports-5e566bc0254f1c700dcc94fb5d9361ae39a18a09.tar.gz
ports-5e566bc0254f1c700dcc94fb5d9361ae39a18a09.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile9
-rw-r--r--mail/mutt-devel/files/extra-patch-smime-no-outlook11
2 files changed, 19 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 766343b2e65d..ba5a1f2ccb8e 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -21,7 +21,7 @@
#
# In general you can choose between using the SLANG port (WITH_MUTT_SLANG)
# and ncurses (WITH_MUTT_NCURSES) which is the default. Note that you may
-# have to set the variables COLORTERM=yes and COLORFGBG=color,color in your
+# have to set the variables COLORTERM=yes and COLORFGBG=color,color in your
# environment to get slang function properly.
#
# If you want to install the mutt documentation in html format define:
@@ -50,6 +50,9 @@
# If you want to enable the pgp_outlook_compat function for use with pgp define:
# WITH_MUTT_PGP_OUTLOOK_PATCH
#
+# If you want to disable a outlook_compat function for use with smime define:
+# WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT
+#
# If you want to use the rethreading functions define:
# WITH_MUTT_EDIT_THREADS
@@ -161,6 +164,10 @@ WITH_MUTT_PGP_OUTLOOK_PATCH= yes
pre-configure::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-pgp-outlook
.endif
+.if defined(WITHOUT_MUTT_SMIME_OUTLOOK_COMPAT)
+pre-configure::
+ ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-smime-no-outlook
+.endif
.if defined(WITH_MUTT_LOCALES_FIX)
CONFIGURE_ARGS+= --enable-locales-fix
diff --git a/mail/mutt-devel/files/extra-patch-smime-no-outlook b/mail/mutt-devel/files/extra-patch-smime-no-outlook
new file mode 100644
index 000000000000..0d10becd82db
--- /dev/null
+++ b/mail/mutt-devel/files/extra-patch-smime-no-outlook
@@ -0,0 +1,11 @@
+--- smime.c.orig Thu May 2 01:20:42 2002
++++ smime.c Fri Jul 26 18:15:19 2002
+@@ -144,7 +144,7 @@
+ {
+ len++;
+ if (!ascii_strcasecmp ((t+len), "p7m"))
+-#if 0
++#if 1
+ return SMIMEENCRYPT;
+ #else
+ /* Not sure if this is the correct thing to do, but