aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-12-28 15:00:15 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-12-28 15:00:15 +0000
commit6e58cbf79034fcc5c39af402e808108dd660a93b (patch)
tree281e1eb56c253d45982512d34880fe346e1045f0 /mail
parent74008d8abdbbcc0b4b68c863d5c42203f1c5dc34 (diff)
downloadports-6e58cbf79034fcc5c39af402e808108dd660a93b.tar.gz
ports-6e58cbf79034fcc5c39af402e808108dd660a93b.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-spf/Makefile38
-rw-r--r--mail/py-spf/distinfo2
-rw-r--r--mail/py-spf/pkg-descr11
-rw-r--r--mail/py-spf/pkg-plist4
5 files changed, 56 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index e922c901b6cf..8329231b290f 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -352,6 +352,7 @@
SUBDIR += py-milter
SUBDIR += py-mimelib
SUBDIR += py-spambayes
+ SUBDIR += py-spf
SUBDIR += pygmy
SUBDIR += pymsgauth
SUBDIR += pyzor
diff --git a/mail/py-spf/Makefile b/mail/py-spf/Makefile
new file mode 100644
index 000000000000..06c9f8f5e0ee
--- /dev/null
+++ b/mail/py-spf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: py-spf
+# Date created: 26 Dec 2004
+# Whom: Marcus Grando <marcus@corp.grupos.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spf
+PORTVERSION= 1.6
+CATEGORIES= mail python
+MASTER_SITES= http://www.wayforward.net/spf/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= marcus@corp.grupos.com.br
+COMMENT= Python implementation of SPF
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/DNS/__init__.py:${PORTSDIR}/dns/py-dns
+
+DIST_SUBDIR= python
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+DOCSDIR?= ${PREFIX}/share/doc/py-${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CHMOD} 755 ${PYTHONPREFIX_SITELIBDIR}/spf.py
+ @${LN} -s ${PYTHONPREFIX_SITELIBDIR}/spf.py ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/py-spf/distinfo b/mail/py-spf/distinfo
new file mode 100644
index 000000000000..9e071e9c7060
--- /dev/null
+++ b/mail/py-spf/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/pyspf-1.6.tar.gz) = 7ff35d8f9db41f2f7e0068f78f243a3d
+SIZE (python/pyspf-1.6.tar.gz) = 11424
diff --git a/mail/py-spf/pkg-descr b/mail/py-spf/pkg-descr
new file mode 100644
index 000000000000..409ccb40d024
--- /dev/null
+++ b/mail/py-spf/pkg-descr
@@ -0,0 +1,11 @@
+Python implementation of SPF (Sender Permitted From)
+
+For more information about SPF, a tool against email forgery, see
+ http://spf.pobox.com
+
+For news, bugfixes, etc. visit the home page for this implementation at
+ http://www.wayforward.net/spf/
+
+WWW: http://www.wayforward.net/spf/
+
+Marcus Grando <marcus@corp.grupos.com.br>
diff --git a/mail/py-spf/pkg-plist b/mail/py-spf/pkg-plist
new file mode 100644
index 000000000000..0fdeff06a59b
--- /dev/null
+++ b/mail/py-spf/pkg-plist
@@ -0,0 +1,4 @@
+bin/spf.py
+lib/%%PYTHON_VERSION%%/site-packages/spf.py
+lib/%%PYTHON_VERSION%%/site-packages/spf.pyc
+lib/%%PYTHON_VERSION%%/site-packages/spf.pyo